SOLVED
Home

Add-RdsAccount : One or more errors occurred.

%3CLINGO-SUB%20id%3D%22lingo-sub-456086%22%20slang%3D%22en-US%22%3EAdd-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-456086%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20to%20all!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20Testing%20the%20new%20Windows%20Virtual%20Desktop%20on%20Azure...%3C%2FP%3E%3CP%3EI'm%20following%20this%20link%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-setup-azure-active-directory%26nbsp%3Bto%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-setup-azure-active-directory%26nbsp%3Bto%3C%2FA%3E%20create%20the%20service%20on%20my%20Azure%20Tenant.%3C%2FP%3E%3CP%3EWhen%20i'm%20tring%20to%20add%20the%20rds%20account%20to%20my%20tenant%20with%20powershell%20it%20sends%20me%20the%20next%20error%3A%3C%2FP%3E%3CP%3EAdd-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FP%3E%3CP%3EAt%20line%3A1%20char%3A1%3C%2FP%3E%3CP%3E%2B%20Add-RdsAccount%20-DeploymentUrl%20%22%3CA%20href%3D%22https%3A%2F%2Frdbroker.wvd.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdbroker.wvd.microsoft.com%3C%2FA%3E%22%3C%2FP%3E%3CP%3E%2B%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20%2B%20CategoryInfo%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3B%3A%20NotSpecified%3A%20(%3A)%20%5BAdd-RdsAccount%5D%2C%20AggregateException%3C%2FP%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20%2B%20FullyQualifiedErrorId%20%3A%20System.AggregateException%2CMicrosoft.RDInfra.RDPowershell.Context.AddRdsAccount%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20was%20searching%20any%20similar%20errors%20on%20the%20web%20but%20there%20is%20nothing%20about%20it.%20I%20hope%20you%20may%20help%20me.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EThis%20is%20my%20psping%20output%3A%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E.%2Fpsping.exe%20rdbroker.wvd.microsoft.com%3A443%3C%2FP%3E%3CP%3EPsPing%20v2.10%20-%20PsPing%20-%20ping%2C%20latency%2C%20bandwidth%20measurement%20utility%3CBR%20%2F%3ECopyright%20(C)%202012-2016%20Mark%20Russinovich%3CBR%20%2F%3ESysinternals%20-%20%3CA%20href%3D%22http%3A%2F%2Fwww.sysinternals.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ewww.sysinternals.com%3C%2FA%3E%3C%2FP%3E%3CP%3ETCP%20connect%20to%2052.177.206.73%3A443%3A%3CBR%20%2F%3E5%20iterations%20(warmup%201)%20ping%20test%3A%3CBR%20%2F%3EConnecting%20to%2052.177.206.73%3A443%20(warmup)%3A%20from%20192.168.11.143%3A20539%3A%20155.41ms%3CBR%20%2F%3EConnecting%20to%2052.177.206.73%3A443%3A%20from%20192.168.11.143%3A20541%3A%20168.12ms%3CBR%20%2F%3EConnecting%20to%2052.177.206.73%3A443%3A%20from%20192.168.11.143%3A20542%3A%202366.36ms%3CBR%20%2F%3EConnecting%20to%2052.177.206.73%3A443%3A%20from%20192.168.11.143%3A20543%3A%20161.27ms%3CBR%20%2F%3EConnecting%20to%2052.177.206.73%3A443%3A%20from%20192.168.11.143%3A20544%3A%20168.14ms%3C%2FP%3E%3CP%3ETCP%20connect%20statistics%20for%2052.177.206.73%3A443%3A%3CBR%20%2F%3ESent%20%3D%204%2C%20Received%20%3D%204%2C%20Lost%20%3D%200%20(0%25%20loss)%2C%3CBR%20%2F%3EMinimum%20%3D%20161.27ms%2C%20Maximum%20%3D%202366.36ms%2C%20Average%20%3D%20715.97ms%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-481174%22%20slang%3D%22en-US%22%3ERe%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-481174%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F76288%22%20target%3D%22_blank%22%3E%40Manuel%20Alejandro%20Pe%C3%B1a%20S%C3%A1nchez%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20experiencing%20the%20same%20issue.%20Microsoft's%20customer%20support%20can't%20help%20as%20this%20service%20is%20still%20in%20preview.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20you%20manage%20to%20resolve%20this%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-481243%22%20slang%3D%22en-US%22%3ERe%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-481243%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F325603%22%20target%3D%22_blank%22%3E%40Jez85%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20Jez%2C%20I%20came%20here%20cause%20Support%20also%20send%20me%20here.%20If%20i%20have%20any%20feed%20back%20or%20a%20solution%20i'll%20be%20posting%20it.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-481384%22%20slang%3D%22en-US%22%3ERE%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-481384%22%20slang%3D%22en-US%22%3EEnsure%20you%20are%20following%20the%20steps%20to%20described%20on%20consent%20and%20assigning%20the%20tenantcreator%20role.%20The%20issues%20you%20are%20running%20into%20are%20resulting%20from%20missing%20steps%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-setup-azure-active-directory%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-desktop%2Ftenant-setup-azure-active-directory%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-481411%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-481411%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F139744%22%20target%3D%22_blank%22%3E%40Eva%20Seydl%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20Eva...%20I%20really%20followed%20step%20by%20step%20the%20guide%20that%20you%20told%20me%20but%20didn't%20work.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-481425%22%20slang%3D%22en-US%22%3ERe%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-481425%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F325603%22%20target%3D%22_blank%22%3E%40Jez85%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F139744%22%20target%3D%22_blank%22%3E%40Eva%20Seydl%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20observing%20al%20AAD%20relation%20between%20my%20subscriptions%20and%20this%20is%20the%20conclusion%20that%20solved%20my%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20I%20am%20a%20Global%20Admin%20(Guest%20User)%20of%20a%20AAD%20where%20i%20was%20creating%20the%20WVD%20Service%2C%20like%20the%20guide%20says.%3C%2FP%3E%3CP%3E2.%20I%20observed%20that%20when%20you%20log-on%20with%20add-rdsaccount%20it%20takes%20the%20aadid%20of%20your%20account%20not%20the%20one%20that%20you%20are%20using%20to%20create%20the%20service%2C%20so%20in%20my%20case%20will%20never%20get%20that%20i%20was%20a%20Global%20Admin%20of%20the%20AAD%20that%20i%20was%20really%20using.%20I%20know%20it%20seems%20obvious%20but%2C%20Cause%20my%20account%20was%20member%20from%20another%20AAD%20ID.%3C%2FP%3E%3CP%3E3.%20So%20i%20created%20a%20new%20global%20admin%20user%20in%20the%20AAD%20that%20i%20used%20to%20register%20the%20WVD%20Service.%3C%2FP%3E%3CP%3E4.%20I%20run%20again%20the%20aad-rdsaccount%20and%20the%20command%20runned%20without%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20my%20recommendation%20is%20to%20see%20back%20on%20the%20aadid%20that%20you%20registered%20and%20verify%20that%20the%20account%20it's%20not%20only%20global%20admin%20so%20also%20it's%20should%20appears%20like%20a%20member%20of%20the%20AAD%20where%20you%20registered%20the%20WVD%20Enterprise%20Application.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHopes%20it%20helps%20you%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F325603%22%20target%3D%22_blank%22%3E%40Jez85%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-481489%22%20slang%3D%22en-US%22%3ERe%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-481489%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F76288%22%20target%3D%22_blank%22%3E%40Manuel%20Alejandro%20Pe%C3%B1a%20S%C3%A1nchez%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20sharing!%20I%20will%20try%20it%20out.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-481527%22%20slang%3D%22en-US%22%3ERe%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-481527%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F76288%22%20target%3D%22_blank%22%3E%40Manuel%20Alejandro%20Pe%C3%B1a%20S%C3%A1nchez%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGlad%20to%20know%20your%20problem%20is%20fixed.%20A%20quick%20question%20-%20is%20your%20account%20MFA%20enabled%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-482065%22%20slang%3D%22en-US%22%3ERe%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-482065%22%20slang%3D%22en-US%22%3ENo%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F325877%22%20target%3D%22_blank%22%3E%40manjeetr%3C%2FA%3E%20in%20my%20case%20there%20is%20no%20MFA%20enable%20on%20the%20account%20i%20used%20to%20register%20the%20RDS.%3CBR%20%2F%3EBut%20to%20do%20the%20register%20i%20guess%20you%20may%20do%20it%20with%20a%20MFA%20account%20and%20then%20change%20it%20to%20a%20Service%20Principal%2C%20like%20the%20guides%20says.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-482228%22%20slang%3D%22en-US%22%3ERe%3A%20Add-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-482228%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F76288%22%20target%3D%22_blank%22%3E%40Manuel%20Alejandro%20Pe%C3%B1a%20S%C3%A1nchez%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20my%20case%2C%20I%20am%20not%20that%20far%20in%20the%20process.%20I%20am%20not%20able%20to%20sign%20in%20to%20WVD%20using%26nbsp%3B%3CSPAN%3EAdd-RdsAccount%20command.%20After%20granting%20service%20permissions%20and%20assigning%20TenantCreator%20role%20to%20my%20id%2C%20the%20command%20-%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3EAdd-RdsAccount%26nbsp%3B%3CSPAN%20class%3D%22hljs-parameter%22%3E-DeploymentUrl%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22hljs-string%22%3E%22%3CA%20href%3D%22https%3A%2F%2Frdbroker.wvd.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdbroker.wvd.microsoft.com%3C%2FA%3E%22%3C%2FSPAN%3E%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CSPAN%20class%3D%22hljs-string%22%3Efails%20with%20the%20error%20-%26nbsp%3B%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3E%3CSPAN%20class%3D%22hljs-string%22%3EAdd-RdsAccount%20%3A%20One%20or%20more%20errors%20occurred.At%20line%3A1%20char%3A1%2B%20Add-RdsAccount%20-DeploymentUrl%20%22%3CA%20href%3D%22https%3A%2F%2Frdbroker.wvd.microsoft.com%26quot%3B%2B%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Frdbroker.wvd.microsoft.com%22%2B%3C%2FA%3E%20~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~%2B%20CategoryInfo%20%3A%20NotSpecified%3A%20(%3A)%20%5BAdd-RdsAccount%5D%2C%20AggregateException%2B%20FullyQualifiedErrorId%20%3A%20System.AggregateException%2CMicrosoft.RDInfra.RDPowershell.Context.AddRdsAccount%3C%2FSPAN%3E%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CEM%3E%3CSPAN%20class%3D%22hljs-string%22%3EI%20have%20installed%20and%20imported%20WVD%20module%20for%20the%20Powershell%20successfully%20using%20the%20following%20-%26nbsp%3B%3C%2FSPAN%3E%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3E%3CSPAN%20class%3D%22hljs-string%22%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fwindows-virtual-desktop%2Foverview%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fwindows-virtual-desktop%2Foverview%3C%2FA%3E%3C%2FSPAN%3E%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Manuel Alejandro Peña Sánchez
Occasional Contributor

Hi to all! 

 

I'm Testing the new Windows Virtual Desktop on Azure...

I'm following this link https://docs.microsoft.com/en-us/azure/virtual-desktop/tenant-setup-azure-active-directory to create the service on my Azure Tenant.

When i'm tring to add the rds account to my tenant with powershell it sends me the next error:

Add-RdsAccount : One or more errors occurred.

At line:1 char:1

+ Add-RdsAccount -DeploymentUrl "https://rdbroker.wvd.microsoft.com"

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [Add-RdsAccount], AggregateException

    + FullyQualifiedErrorId : System.AggregateException,Microsoft.RDInfra.RDPowershell.Context.AddRdsAccount

 

i was searching any similar errors on the web but there is nothing about it. I hope you may help me.

 

This is my psping output:

 

./psping.exe rdbroker.wvd.microsoft.com:443

PsPing v2.10 - PsPing - ping, latency, bandwidth measurement utility
Copyright (C) 2012-2016 Mark Russinovich
Sysinternals - www.sysinternals.com

TCP connect to 52.177.206.73:443:
5 iterations (warmup 1) ping test:
Connecting to 52.177.206.73:443 (warmup): from 192.168.11.143:20539: 155.41ms
Connecting to 52.177.206.73:443: from 192.168.11.143:20541: 168.12ms
Connecting to 52.177.206.73:443: from 192.168.11.143:20542: 2366.36ms
Connecting to 52.177.206.73:443: from 192.168.11.143:20543: 161.27ms
Connecting to 52.177.206.73:443: from 192.168.11.143:20544: 168.14ms

TCP connect statistics for 52.177.206.73:443:
Sent = 4, Received = 4, Lost = 0 (0% loss),
Minimum = 161.27ms, Maximum = 2366.36ms, Average = 715.97ms

9 Replies

@Manuel Alejandro Peña Sánchez 

 

We are experiencing the same issue. Microsoft's customer support can't help as this service is still in preview. 

 

Did you manage to resolve this issue?

 

Thanks.

@Jez85 

 

No Jez, I came here cause Support also send me here. If i have any feed back or a solution i'll be posting it. 

Ensure you are following the steps to described on consent and assigning the tenantcreator role. The issues you are running into are resulting from missing steps: https://docs.microsoft.com/en-us/azure/virtual-desktop/tenant-setup-azure-active-directory

@Eva Seydl 

 

Thanks Eva... I really followed step by step the guide that you told me but didn't work.

Solution

@Jez85 

@Eva Seydl 

 

Hi all,

 

I was observing al AAD relation between my subscriptions and this is the conclusion that solved my problem.

 

1. I am a Global Admin (Guest User) of a AAD where i was creating the WVD Service, like the guide says.

2. I observed that when you log-on with add-rdsaccount it takes the aadid of your account not the one that you are using to create the service, so in my case will never get that i was a Global Admin of the AAD that i was really using. I know it seems obvious but, Cause my account was member from another AAD ID.

3. So i created a new global admin user in the AAD that i used to register the WVD Service.

4. I run again the aad-rdsaccount and the command runned without problem.

 

So my recommendation is to see back on the aadid that you registered and verify that the account it's not only global admin so also it's should appears like a member of the AAD where you registered the WVD Enterprise Application.

 

Hopes it helps you @Jez85 

@Manuel Alejandro Peña Sánchez 

 

Thanks for sharing! I will try it out.

@Manuel Alejandro Peña Sánchez 

Glad to know your problem is fixed. A quick question - is your account MFA enabled? 

No @manjeetr in my case there is no MFA enable on the account i used to register the RDS.
But to do the register i guess you may do it with a MFA account and then change it to a Service Principal, like the guides says.

Thanks @Manuel Alejandro Peña Sánchez 

 

In my case, I am not that far in the process. I am not able to sign in to WVD using Add-RdsAccount command. After granting service permissions and assigning TenantCreator role to my id, the command -

 

Add-RdsAccount -DeploymentUrl "https://rdbroker.wvd.microsoft.com"

 

fails with the error - 

 

Add-RdsAccount : One or more errors occurred.
At line:1 char:1
+ Add-RdsAccount -DeploymentUrl "https://rdbroker.wvd.microsoft.com"
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Add-RdsAccount], AggregateException
+ FullyQualifiedErrorId : System.AggregateException,Microsoft.RDInfra.RDPowershell.Context.AddRdsAccount

 

I have installed and imported WVD module for the Powershell successfully using the following - 

https://docs.microsoft.com/en-us/powershell/windows-virtual-desktop/overview

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
38 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies