SOLVED
Home

"invisible" VM not shown in Hyper-V Manager or Failover Cluster Manager (2012 r2)

%3CLINGO-SUB%20id%3D%22lingo-sub-754944%22%20slang%3D%22en-US%22%3E%22invisible%22%20VM%20not%20shown%20in%20Hyper-V%20Manager%20or%20Failover%20Cluster%20Manager%20(2012%20r2)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-754944%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20VM%20that%20is%20up%20and%20running%20on%20my%202012%20r2%20cluster%20(psremoted%20it%2C%20RDP'd%20it%2C%20I%20personally%20created%20this%20VM%20on%20this%20failover%20cluster)%20but%20I%20can't%20see%20it%20in%20failover%20cluster%20manager%20or%20hyper-v%20manager%20anymore%20recently.%20I'm%20not%20sure%20exactly%20when%20it%20stopped%20being%20listed%20in%20either%20tool.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ebackstory%20that%20might%20be%20relevant%3A%20a%20CAU%20updating%20run%20failed%207%2F7%20and%20again%20yesterday%20for%20reasons%20unknown%20to%20me%20at%20this%20time%20(node%20failed%20to%20drain%2C%20and%20a%20specific%20kb%20-%20a%20.net%20one%20-%20failed%20to%20transition%20to%20installed).%20It%20almost%20seems%20like%20the%20vm%20in%20question%20is%20in%20limbo%20%22between%22%20the%20two%20nodes%20of%20the%20cluster.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eany%20help%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-754944%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EClustering%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHyper-V%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-756337%22%20slang%3D%22en-US%22%3ERe%3A%20%22invisible%22%20VM%20not%20shown%20in%20Hyper-V%20Manager%20or%20Failover%20Cluster%20Manager%20(2012%20r2)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-756337%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365532%22%20target%3D%22_blank%22%3E%40ajm-b%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EIf%20you%20look%20at%20the%20registry%20in%20the%20VM%2C%20it%20should%20tell%20you%20what%20host%20it's%20on%3C%2FP%3E%0A%3CBLOCKQUOTE%3E%0A%3CP%3E%60HKEY_LOCAL_MACHINE%5CSOFTWARE%5CMicrosoft%5CVirtual%20Machine%5CGuest%5CParameters%60%3C%2FP%3E%0A%3C%2FBLOCKQUOTE%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F123364iAF42B017362C6687%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Screen%20Shot%202019-07-16%20at%208.13.32%20PM.png%22%20title%3D%22Screen%20Shot%202019-07-16%20at%208.13.32%20PM.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-756760%22%20slang%3D%22en-US%22%3ERe%3A%20%22invisible%22%20VM%20not%20shown%20in%20Hyper-V%20Manager%20or%20Failover%20Cluster%20Manager%20(2012%20r2)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-756760%22%20slang%3D%22en-US%22%3EBless%20you%20Ben.%20Turns%20out%20this%20server's%20owner%20repurposed%20it%20w%2Fo%20informing%20me%2C%20so%20the%20guest's%20name%20didn't%20match%20its%20name%20on%20hypervisor%20side%20of%20things.%3CBR%20%2F%3E%3CBR%20%2F%3EPeace%20in%20Christ.%3C%2FLINGO-BODY%3E
ajm-b
Occasional Contributor

I have a VM that is up and running on my 2012 r2 cluster (psremoted it, RDP'd it, I personally created this VM on this failover cluster) but I can't see it in failover cluster manager or hyper-v manager anymore recently. I'm not sure exactly when it stopped being listed in either tool.

 

backstory that might be relevant: a CAU updating run failed 7/7 and again yesterday for reasons unknown to me at this time (node failed to drain, and a specific kb - a .net one - failed to transition to installed). It almost seems like the vm in question is in limbo "between" the two nodes of the cluster.

 

any help appreciated.

2 Replies
Highlighted
Solution

@ajm-b 
If you look at the registry in the VM, it should tell you what host it's on

`HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Virtual Machine\Guest\Parameters`

Screen Shot 2019-07-16 at 8.13.32 PM.png

Bless you Ben. Turns out this server's owner repurposed it w/o informing me, so the guest's name didn't match its name on hypervisor side of things.

Peace in Christ.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies