Home

Windows server 2016 - VM doesn't start automatically

%3CLINGO-SUB%20id%3D%22lingo-sub-172223%22%20slang%3D%22en-US%22%3EWindows%20server%202016%20-%20VM%20doesn't%20start%20automatically%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-172223%22%20slang%3D%22en-US%22%3E%3CP%3EHyper-V%3A%20Windows%20server%202016.%3CBR%20%2F%3EVM%20OS%3A%20Windows%20server%202012.%3CBR%20%2F%3EEven%20if%20the%20VM%20Automatic%20Start%20Action%20setting%20is%20Always%20start%2C%20sometimes%2C%20after%20Hyper-V%20restart%20the%20VM%20doesn't%20start%20and%20stays%20in%20an%20off%20state.%3CBR%20%2F%3ETried%20to%20change%20the%20startup%20delay%20without%20success.%3CBR%20%2F%3EAny%20idea%3F%3CBR%20%2F%3E%3CBR%20%2F%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-172223%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHyper-V%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-482378%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20server%202016%20-%20VM%20doesn't%20start%20automatically%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-482378%22%20slang%3D%22en-US%22%3E%3CP%3EDid%20you%20ever%20find%20a%20resolution%20for%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-216394%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20server%202016%20-%20VM%20doesn't%20start%20automatically%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-216394%22%20slang%3D%22en-US%22%3E%3CP%3Econtrol%20%3CSPAN%3Eattached%26nbsp%3B%3C%2FSPAN%3Edisk%20in%20Vm%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-215131%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20server%202016%20-%20VM%20doesn't%20start%20automatically%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-215131%22%20slang%3D%22en-US%22%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F93763%22%20target%3D%22_blank%22%3E%40James%20Anderson%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%3CP%3EHaving%20the%20same%20issue%20with%20replication%20enabled.%20This%20needs%20an%20urgent%20fix%20-%20if%20my%20server%20crashes%20the%20VMs%20do%20not%20automatically%20come%20back%20up%20when%20the%20server%20comes%20up.%3C%2FP%3E%0A%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%0A%3CP%3EI'd%20start%20a%20new%20thread%20detailing%20your%20issues.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-214819%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20server%202016%20-%20VM%20doesn't%20start%20automatically%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-214819%22%20slang%3D%22en-US%22%3E%3CP%3EI'd%20check%20the%20event%20logs%20(%3CSPAN%3EHyper-V-VMMS%20and%20Hyper-V-Worker%3C%2FSPAN%3E).%20It%20may%20have%20tried%20and%20failed%20for%20some%20reason.%20Also%20check%20here%20and%20with%20manufacturer%20that%20hardware%20is%20supported.%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.windowsservercatalog.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.windowsservercatalog.com%2F%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-214775%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20server%202016%20-%20VM%20doesn't%20start%20automatically%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-214775%22%20slang%3D%22en-US%22%3EIt%20seems%20that%20if%20I%20set%20the%20VM%20to%20always%20start%20automatically%20with%20a%20delay%20of%200%20seconds%2C%20the%20servers%20do%20come%20up.%20This%20is%20still%20not%20ideal.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-214770%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%20server%202016%20-%20VM%20doesn't%20start%20automatically%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-214770%22%20slang%3D%22en-US%22%3E%3CP%3EHaving%20the%20same%20issue%20with%20replication%20enabled.%20This%20needs%20an%20urgent%20fix%20-%20if%20my%20server%20crashes%20the%20VMs%20do%20not%20automatically%20come%20back%20up%20when%20the%20server%20comes%20up.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Deleted
Not applicable

Hyper-V: Windows server 2016.
VM OS: Windows server 2012.
Even if the VM Automatic Start Action setting is Always start, sometimes, after Hyper-V restart the VM doesn't start and stays in an off state.
Tried to change the startup delay without success.
Any idea?

Thanks.

6 Replies

Having the same issue with replication enabled. This needs an urgent fix - if my server crashes the VMs do not automatically come back up when the server comes up.

It seems that if I set the VM to always start automatically with a delay of 0 seconds, the servers do come up. This is still not ideal.

I'd check the event logs (Hyper-V-VMMS and Hyper-V-Worker). It may have tried and failed for some reason. Also check here and with manufacturer that hardware is supported.

https://www.windowsservercatalog.com/

 

 

 


@James Anderson wrote:

Having the same issue with replication enabled. This needs an urgent fix - if my server crashes the VMs do not automatically come back up when the server comes up.


I'd start a new thread detailing your issues.

 

 

control attached disk in Vm

Did you ever find a resolution for this issue?

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies