SOLVED
Home

Windows 2012 R2 server Bad network Performance

%3CLINGO-SUB%20id%3D%22lingo-sub-352711%22%20slang%3D%22en-US%22%3EWindows%202012%20R2%20server%20Bad%20network%20Performance%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-352711%22%20slang%3D%22en-US%22%3E%3CP%3EHPE%20ML350%20G9%20%2B%2032GB%20%2B%206HD%20SAS%20300GB%20RAID%205%20With%20Windows%202012%20R2%20Server%3C%2FP%3E%3CP%3ENetwork%20Card%20HP%26nbsp%3B1gb%204-port%20331i%3C%2FP%3E%3CP%3EI'm%20having%20a%20big%20of%20a%20problem%20here%2C%20my%20network%20performance%20is%20a%20joke%20on%20this%20server%2C%20i%20have%20read%20in%20the%20web%20to%20disable%20this%20parameters%20on%20the%20NIC%20card%3C%2FP%3E%3CDIV%3E%3CSPAN%3EIpv4%20checksum%20offload%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3Elargesend%20offload%20V2(ipv4)%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3Elargesend%20offload%20V2(ipv6)%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EVm%20queues%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ETCP%20Checksum%20offload%20(ipv4)%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3ETCP%20checksum%20offload%20(ipv6)%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EUdp%20checksum%20offload%20(ipv4)%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EUdp%20checksum%20offload%20(ipv6)%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EDone%20this%2C%20also%20disabled%20the%26nbsp%3BDigitally%20sign%20communications%20and%26nbsp%3BDigitally%20encrypt%20or%20sign%20secure%20channel%20data%2C%20but%20the%20problem%20remains.%20Transfering%20data%20across%20the%20local%20network%20i%20don't%20even%20get%201mb%2Fs.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EOn%20windows%202003%2C%20and%20the%20workstations%2C%20i%20have%20no%20problem%20getting%2010mb%2Fs%20and%20more.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EI%20have%20read%20that%20the%20solution%20goes%20by%20changing%20NIC%20to%20another%20brand.%20Will%20this%20solve%20my%20problem%3F%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EAny%20toughts%3F%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EBest%20Regards.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EP.S%20Working%20on%20a%20100Mbps%20network%2C%20it's%20not%20perfect%20but%20it's%20what%20i%20have%20to%20work%20for%20now.%20It%20will%20be%20upgrated%20soon%20to%201000Mbps.%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-352711%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-353452%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%202012%20R2%20server%20Bad%20network%20Performance%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-353452%22%20slang%3D%22en-US%22%3E%3CP%3EYou're%20welcome%2C%20glad%20to%20hear%20of%20success.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-353258%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%202012%20R2%20server%20Bad%20network%20Performance%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-353258%22%20slang%3D%22en-US%22%3EThanks%20for%20your%20tips%2C%20it%20did%20help.%3CBR%20%2F%3EI%20run%20HP%20SUM%20and%20it%20worked%2C%20not%20sure%20what%20was%20the%20problem%2C%20but%20it%20worked.%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%20for%20all%20your%20help%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-352744%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%202012%20R2%20server%20Bad%20network%20Performance%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-352744%22%20slang%3D%22en-US%22%3E%3CP%3EYou're%20welcome.%20I'd%20also%20ask%20for%20help%20with%20these%20hardware%20issues%20over%20here%20in%20HP%20forums.%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fcommunity.hpe.com%2Ft5%2FProLiant-Servers-ML-DL-SL%2Fbd-p%2Fitrc-264%23.XGsdQclYZaQ%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fcommunity.hpe.com%2Ft5%2FProLiant-Servers-ML-DL-SL%2Fbd-p%2Fitrc-264%23.XGsdQclYZaQ%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-352740%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%202012%20R2%20server%20Bad%20network%20Performance%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-352740%22%20slang%3D%22en-US%22%3EThanks%20for%20the%20reply.%3CBR%20%2F%3E%3CBR%20%2F%3EAlready%20asked%20HP%20for%20help%2C%20still%20waiting%20for%20an%20answer.%3CBR%20%2F%3EI%20run%20all%20possible%20updates%2C%20NIC%20updates%2C%20Windows%20updates%2C%20chipset%20updates.%3CBR%20%2F%3EI%20will%20try%20to%20use%20Smart%20update%20tool%20from%20HP%2C%20maybe%20a%20ROM%20BIOS%20would%20help.%3CBR%20%2F%3EThanks%20for%20the%20tip.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-352728%22%20slang%3D%22en-US%22%3ERe%3A%20Windows%202012%20R2%20server%20Bad%20network%20Performance%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-352728%22%20slang%3D%22en-US%22%3E%3CP%3EHave%20you%20asked%20HP%20for%20help%3F%20I'd%20also%20check%20that%20the%20server%20has%20the%20latest%20recommended%20ROM%20bios%2C%20firmware%2C%20chipset%20and%20driver%20support%20pack.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.hpe.com%2Fhpesc%2Fpublic%2Fhome%2FdriverHome%3Fsp4ts.oid%3D1009483731%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%26nbsp%3B%3CFONT%20style%3D%22background-color%3A%20%23ffffff%3B%22%3Ehttps%3A%2F%2Fsupport.hpe.com%2Fhpesc%2Fpublic%2Fhome%2FdriverHome%3Fsp4ts.oid%3D1009483731%3C%2FFONT%3E%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
jbaptista
New Contributor

HPE ML350 G9 + 32GB + 6HD SAS 300GB RAID 5 With Windows 2012 R2 Server

Network Card HP 1gb 4-port 331i

I'm having a big of a problem here, my network performance is a joke on this server, i have read in the web to disable this parameters on the NIC card

Ipv4 checksum offload
largesend offload V2(ipv4)
largesend offload V2(ipv6)
Vm queues
TCP Checksum offload (ipv4)
TCP checksum offload (ipv6)
Udp checksum offload (ipv4)
Udp checksum offload (ipv6)
Done this, also disabled the Digitally sign communications and Digitally encrypt or sign secure channel data, but the problem remains. Transfering data across the local network i don't even get 1mb/s.
On windows 2003, and the workstations, i have no problem getting 10mb/s and more.
 
I have read that the solution goes by changing NIC to another brand. Will this solve my problem?
Any toughts?
 
Best Regards.
 
P.S Working on a 100Mbps network, it's not perfect but it's what i have to work for now. It will be upgrated soon to 1000Mbps.
5 Replies
Solution

Have you asked HP for help? I'd also check that the server has the latest recommended ROM bios, firmware, chipset and driver support pack.

 

 https://support.hpe.com/hpesc/public/home/driverHome?sp4ts.oid=1009483731

 

 

Thanks for the reply.

Already asked HP for help, still waiting for an answer.
I run all possible updates, NIC updates, Windows updates, chipset updates.
I will try to use Smart update tool from HP, maybe a ROM BIOS would help.
Thanks for the tip.
Highlighted

You're welcome. I'd also ask for help with these hardware issues over here in HP forums.

https://community.hpe.com/t5/ProLiant-Servers-ML-DL-SL/bd-p/itrc-264#.XGsdQclYZaQ

 

 

 

Thanks for your tips, it did help.
I run HP SUM and it worked, not sure what was the problem, but it worked.

Thanks for all your help

You're welcome, glad to hear of success.

 

 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies