Home

Upgrade to Server 2019 storage spaces problem - not migrated due to partial or ambiguous match

%3CLINGO-SUB%20id%3D%22lingo-sub-334566%22%20slang%3D%22en-US%22%3EUpgrade%20to%20Server%202019%20storage%20spaces%20problem%20-%20not%20migrated%20due%20to%20partial%20or%20ambiguous%20match%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-334566%22%20slang%3D%22en-US%22%3E%3CP%3EI%20upgraded%20a%20server%20from%202016%20to%202019.%20After%20the%20upgrade%20one%20of%20my%20Storage%20Spaces%20drives%20went%20missing.%20The%20drives%20are%20showing%20in%20Device%20Manger%20but%20aren't%20showing%20Disk%20Management%20and%20the%20Storage%20Pool%20is%20gone.%20At%20first%20I%20thought%20the%20problem%20was%20a%20cheap%20controller%20(4%20Port%20SATA%20in%20home%20test%20server)%20wasn't%20being%20supported%20in%20Server%202019.%20I%20swapped%20out%20with%20a%20LSI%20SATA%20%2F%20SAS%20card%20that%20has%20certified%20drivers.%20Still%20having%20same%20problem.%20All%204%20disks%20are%20showing%20this%20error%20in%20device%20manager%3A%3C%2FP%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%3CSPAN%3EDevice%20SCSI%5CDisk%26amp%3BVen_ATA%26amp%3BProd_INTEL_SSDSA2MH08%5C5%26amp%3B10774fde%26amp%3B0%26amp%3B000400%20was%20not%20migrated%20due%20to%20partial%20or%20ambiguous%20match.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%3CP%3E%3CSPAN%3ELast%20Device%20Instance%20Id%3A%20SCSI%5CDisk%26amp%3BVen_Msft%26amp%3BProd_Virtual_Disk%5C2%26amp%3B1f4adffe%26amp%3B0%26amp%3B000003%3CBR%20%2F%3EClass%20Guid%3A%20%7B4d36e967-e325-11ce-bfc1-08002be10318%7D%3CBR%20%2F%3ELocation%20Path%3A%3CBR%20%2F%3EMigration%20Rank%3A%200xF000FC000000F120%3CBR%20%2F%3EPresent%3A%20false%3CBR%20%2F%3EStatus%3A%200xC0000719%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20doesn't%20seem%20to%20directly%20be%20Storage%20Spaces%20issue%20but%20since%20they%20were%20that%20way%20in%202016%20I%20figure%20it%20might%20be%20related.%20Anyone%20have%20any%20suggestions%3F%3C%2FP%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-334566%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EStorage%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-334593%22%20slang%3D%22en-US%22%3ERe%3A%20Upgrade%20to%20Server%202019%20storage%20spaces%20problem%20-%20not%20migrated%20due%20to%20partial%20or%20ambiguous%20match%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-334593%22%20slang%3D%22en-US%22%3E%3CP%3EOne%20other%20thing%20I%20found%20is%20disks%20are%20listed%20as%20Starting%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20841px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F72692iE884D46ED425B55C%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Disks%20Starting.png%22%20title%3D%22Disks%20Starting.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Brian Hoyt
Contributor

I upgraded a server from 2016 to 2019. After the upgrade one of my Storage Spaces drives went missing. The drives are showing in Device Manger but aren't showing Disk Management and the Storage Pool is gone. At first I thought the problem was a cheap controller (4 Port SATA in home test server) wasn't being supported in Server 2019. I swapped out with a LSI SATA / SAS card that has certified drivers. Still having same problem. All 4 disks are showing this error in device manager:

 
Device SCSI\Disk&Ven_ATA&Prod_INTEL_SSDSA2MH08\5&10774fde&0&000400 was not migrated due to partial or ambiguous match.

Last Device Instance Id: SCSI\Disk&Ven_Msft&Prod_Virtual_Disk\2&1f4adffe&0&000003
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Location Path:
Migration Rank: 0xF000FC000000F120
Present: false
Status: 0xC0000719

 

This doesn't seem to directly be Storage Spaces issue but since they were that way in 2016 I figure it might be related. Anyone have any suggestions?

1 Reply

One other thing I found is disks are listed as Starting?

Disks Starting.png

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies