SOLVED
Home

RDS connections are Not using HTTPS

%3CLINGO-SUB%20id%3D%22lingo-sub-842241%22%20slang%3D%22en-US%22%3ERDS%20connections%20are%20Not%20using%20HTTPS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-842241%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20built%20a%20VDI%20with%203%20Windows%20server%202019%20on%20Hyper-V%20on%20Windows%2010%20pro%20latest%20version.%20testing%20it%20on%20my%20local%20network%2C%20when%20clients%20connect%20to%20the%20RDS%20server%2C%20gateway%20manager%20shows%20the%20connections%20are%20based%20on%20HTTP%20and%20UDP%20only%2C%20no%20word%20about%20HTTPS.%3C%2FP%3E%3CP%3Ei%20have%20my%20own%20enterprise%20CA%20and%20clients%20first%20connect%20through%20an%20SSTP%20VPN%20which%20is%20hosted%20in%20one%20of%20those%20servers%20and%20then%20use%20the%20internal%20DNS%20name%20of%20the%20RDS%20server%20to%20connect%20to%20it.%20the%20reason%20for%20the%20SSTP%20VPN%20is%20to%20first%20secure%20the%20connection%20and%20second%20to%20access%20the%20internal%20DNS%20servers.%3C%2FP%3E%3CP%3Ewithout%20VPN%20the%20client%20can't%20use%20the%20internal%20DNS%20names%20of%20the%20servers.%3C%2FP%3E%3CP%3EI%20have%20an%20external%20domain%20name%20pointed%20to%20my%20VPN%20server%20which%20is%20globally%20resolvable%20and%20clients%20can%20easily%20connect%20to%20my%20VPN%20server%20first%20and%20then%20have%20access%20to%20the%20internal%20DNS%20server.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehere%20is%20in%20default%20gateway%20manager%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20610px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130576i98FA60F230B4ABEC%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-09-07%20150955.png%22%20title%3D%22Annotation%202019-09-07%20150955.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20get%20this%20error%20when%20i%20try%20to%20turn%20of%20UDP%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20517px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130577iF21EDCA6D7FEBC7F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-09-07%20151155.png%22%20title%3D%22Annotation%202019-09-07%20151155.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehere%20is%20how%20the%20connection%20looks%20like%20when%20a%20client%20first%20connects%20to%20the%20SSTP%20VPN%20and%20then%20to%20the%20RDS%20host%20using%20RDP.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20309px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130578iBE2C9F8AF394741A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-09-07%20151017.png%22%20title%3D%22Annotation%202019-09-07%20151017.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEverything%20is%20set%20up%20correctly%20AFAIK%2C%20the%20certificates%20are%20ok%2C%20PKIVIEW%20is%20all%20ok%2C%20the%20connection%20is%20ok.%20i%20just%20don't%20know%20why%20i'm%20not%20seeing%20HTTPS%20connections%20in%20Gateway%20manager.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-842241%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EHyper-V%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENetworking%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-842520%22%20slang%3D%22en-US%22%3ERe%3A%20RDS%20connections%20are%20Not%20using%20HTTPS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-842520%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETry%20adjusting%20the%20following%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EComputer%5CHKEY_LOCAL_MACHINE%5CSOFTWARE%5CMicrosoft%5CWindows%20NT%5CCurrentVersion%5CTerminalServerGateway%5CConfig%5CCore%3C%2FP%3E%3CP%3Eand%20change%20the%20Key%26nbsp%3BIsUdpEnabled%26nbsp%3B%20to%200%26nbsp%3B%20(instead%20of%201)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGive%20that%20a%20try.%20I%20know%20of%20a%20bug%20in%20Server%202019%20where%20UDP%20could%20not%20be%20unchecked%20in%20the%20GUI%20so%20has%20to%20be%20done%20via%20the%20registry.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-842751%22%20slang%3D%22en-US%22%3ERe%3A%20RDS%20connections%20are%20Not%20using%20HTTPS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-842751%22%20slang%3D%22en-US%22%3ENow%20the%20UDP%20is%20gone%20and%20only%20the%20HTTP%20connection%20on%20port%203389%20is%20shown%20in%20gateway%20monitoring.%20still%20no%20HTTPS%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-842765%22%20slang%3D%22en-US%22%3ERe%3A%20RDS%20connections%20are%20Not%20using%20HTTPS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-842765%22%20slang%3D%22en-US%22%3E%3CP%3ESome%20updates%2C%3CBR%20%2F%3EI%20got%20an%20answer%20from%20a%20Microsoft%20expert%20and%20he%20said%20that%3CBR%20%2F%3E%3CBR%20%2F%3E%22%3CSTRONG%3EWith%20an%20RDP%20Gateway%20in%20the%20connection%20path%20it%20will%20end%20up%20RDP%20over%20HTTPS%20on%20port%20443%20and%20the%20Gateway%20will%20NAT%20that%20traffic%20back%20to%203389%20to%20the%20endpoint%20on%20the%20LAN.%3C%2FSTRONG%3E%22%3CBR%20%2F%3E%3CBR%20%2F%3Eso%20that's%20probably%20why%20I'm%20seeing%203389%20HTTP%20on%20the%20gateway%20monitoring%20because%20it%20only%20shows%20the%20endpoint%20and%20not%20what%20is%20happening%20before%20NAT.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20know%20it's%20possible%20to%20verify%20that%20by%20using%20tools%20such%20as%20Wireshark%20or%20Fiddler%20and%20i%20will%20do%20that%20later.%3CBR%20%2F%3E%3CBR%20%2F%3Emy%20RDGateway%20is%20on%20the%20same%20server%20as%20the%20rest%20of%20the%20VDI%20components%2C%20my%20VPN%20server%20is%20the%20only%20one%20behind%20DMZ%2C%20i%20haven't%20opened%20any%20ports%20manually%20in%20the%20firewalls.%20so%20i%20guess%20i'm%20gonna%20be%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EAnother%20option%20that%20can%20be%20used%20with%20success%20is%20Azure%20App%20Proxy%20and%20RDP%20Gateway%20to%20help%20secure%20this%20while%20not%20requiring%20a%20VPN%20with%20Pre%20Auth%20at%20the%20Azure%20AD%20level.%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EDetails%20on%20that%20secure%20method%20of%20publishing%20RDP%20Gateway%20in%20the%20link%20below%3C%2FP%3E%3CP%3E%26nbsp%3B%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fmanage-apps%2Fapplication-proxy-integrate-with-remote-desktop-services%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fmanage-apps%2Fapplication-proxy-integrate-with...%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
HotCakeX
Respected Contributor

I've built a VDI with 3 Windows server 2019 on Hyper-V on Windows 10 pro latest version. testing it on my local network, when clients connect to the RDS server, gateway manager shows the connections are based on HTTP and UDP only, no word about HTTPS.

i have my own enterprise CA and clients first connect through an SSTP VPN which is hosted in one of those servers and then use the internal DNS name of the RDS server to connect to it. the reason for the SSTP VPN is to first secure the connection and second to access the internal DNS servers.

without VPN the client can't use the internal DNS names of the servers.

I have an external domain name pointed to my VPN server which is globally resolvable and clients can easily connect to my VPN server first and then have access to the internal DNS server.

 

 

 

here is in default gateway manager

 

Annotation 2019-09-07 150955.png

 

i get this error when i try to turn of UDP:

 

Annotation 2019-09-07 151155.png

 

here is how the connection looks like when a client first connects to the SSTP VPN and then to the RDS host using RDP.

 

Annotation 2019-09-07 151017.png

 

Everything is set up correctly AFAIK, the certificates are ok, PKIVIEW is all ok, the connection is ok. i just don't know why i'm not seeing HTTPS connections in Gateway manager.

3 Replies

@HotCakeX 

 

Try adjusting the following

 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core

and change the Key IsUdpEnabled  to 0  (instead of 1)

 

Give that a try. I know of a bug in Server 2019 where UDP could not be unchecked in the GUI so has to be done via the registry.

Now the UDP is gone and only the HTTP connection on port 3389 is shown in gateway monitoring. still no HTTPS
Solution

Some updates,
I got an answer from a Microsoft expert and he said that

"With an RDP Gateway in the connection path it will end up RDP over HTTPS on port 443 and the Gateway will NAT that traffic back to 3389 to the endpoint on the LAN."

so that's probably why I'm seeing 3389 HTTP on the gateway monitoring because it only shows the endpoint and not what is happening before NAT.

I know it's possible to verify that by using tools such as Wireshark or Fiddler and i will do that later.

my RDGateway is on the same server as the rest of the VDI components, my VPN server is the only one behind DMZ, i haven't opened any ports manually in the firewalls. so i guess i'm gonna be fine.

 

 

Another option that can be used with success is Azure App Proxy and RDP Gateway to help secure this while not requiring a VPN with Pre Auth at the Azure AD level.

Details on that secure method of publishing RDP Gateway in the link below

  https://docs.microsoft.com/en-us/azure/active-directory/manage-apps/application-proxy-integrate-with...

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies