Home

MS FTP server on Windows 2016 not responding the same way 2008 servers do to Passive requests.

Highlighted
smoaref
Occasional Visitor

Hi There;

 

We have recently been upgrading our Windows Server machines to Windows Sever 2016 with FTP server on IIS 10.0 and noticed that when our current perl scripts (ver. 5.16.3) - running on redhat 7.1 - tries (on a passive connection) to get a nonexistent file from the Windows server, server won't respond with a normal "The file <fname> does not exist on the FTP server" message and instead it says: "Can't use an undefined value as a symbol reference at /usr/share/perl5/Net/FTP/dataconn.pm line 54."

 

- Please note that we are not planning to make any changes to our current ( more than 20 production products ) on redhat so upgrading the perl libraries to ver 5.18.* or even one line changer of making the connection an active connection is not possible.

 

 

Wondering if anybody has the same experience with the new FTP server or if there is any configuration that needs to be tweaked to get this thing to work.

 

 

Regards;

Sean

 

 

1 Reply

I'd reach out to IIS/FTP experts in microsoft official dedicated forums over here.

https://forums.iis.net/

 

 

 

Related Conversations
How to delete specific email ids from MS Excel 2007.
CS Pooja Arora in Excel on
5 Replies
Office365 Groups disable messaging to members
Tim Hobson in Office 365 on
4 Replies
Office 365 E3 or Microsoft 365 E3
Chris Yue in Office 365 on
6 Replies
Flow tab does not load on MS Teams
Mikerosoft in Microsoft Teams on
7 Replies