SOLVED
Home

Getting error "An entry with the same key already exists." when creating a new relying party trust

%3CLINGO-SUB%20id%3D%22lingo-sub-430315%22%20slang%3D%22en-US%22%3EGetting%20error%20%22An%20entry%20with%20the%20same%20key%20already%20exists.%22%20when%20creating%20a%20new%20relying%20party%20trust%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-430315%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20trying%20to%20add%20a%20new%20relying%20party%20trust%20using%20ADFS%203.0.%26nbsp%3B%20Everytime%20I%20add%20the%20metadata%20url%20I%20get%20%22An%20entry%20with%20the%20same%20key%20already%20exists%22.%26nbsp%3B%20I've%20tried%20using%20powershell%20and%20get%20the%20same%20result.%26nbsp%3B%20I%20have%20looked%20in%20the%20event%20viewer%20as%20well%20as%20enabled%20ADFS%20tracing%20and%20am%20getting%20no%20errors%20I%20can%20use%20to%20troubleshoot.%26nbsp%3B%20Is%20there%20a%20different%20log%20somewhere%20that%20would%20lead%20me%20to%20what%20is%20wrong%3F%26nbsp%3B%20I%20am%20suspecting%20the%20xml%20file%20could%20be%20at%20fault%2C%20but%20this%203rd%20party%20has%20others%20using%20this%20metadata%20url%20with%20no%20issues.%26nbsp%3B%20I%20would%20rather%20not%20post%20their%20XML%20file%20if%20possible.%26nbsp%3B%20They%20are%20looking%20into%20the%20issue%20as%20well%20I%20just%20wanted%20to%20know%20if%20there%20was%20a%20another%20spot%20I%20could%20look%20for%20logs.%26nbsp%3B%20Thanks%20a%20lot.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-430315%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EActive%20Directory%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-438140%22%20slang%3D%22en-US%22%3ERe%3A%20Getting%20error%20%22An%20entry%20with%20the%20same%20key%20already%20exists.%22%20when%20creating%20a%20new%20relyin%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-438140%22%20slang%3D%22en-US%22%3EThe%20issue%20ended%20up%20being%20their%20XML%20file.%20They%20had%20index%20entries%20with%20the%20same%20index%20number.%3C%2FLINGO-BODY%3E
Highlighted
brentmattson
Occasional Contributor

I am trying to add a new relying party trust using ADFS 3.0.  Everytime I add the metadata url I get "An entry with the same key already exists".  I've tried using powershell and get the same result.  I have looked in the event viewer as well as enabled ADFS tracing and am getting no errors I can use to troubleshoot.  Is there a different log somewhere that would lead me to what is wrong?  I am suspecting the xml file could be at fault, but this 3rd party has others using this metadata url with no issues.  I would rather not post their XML file if possible.  They are looking into the issue as well I just wanted to know if there was a another spot I could look for logs.  Thanks a lot.

1 Reply
Solution
The issue ended up being their XML file. They had index entries with the same index number.
Related Conversations
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
2 Replies
Early preview of Microsoft Edge group policies
Sean Lyndersay in Discussions on
65 Replies
*Updated 9/3* Syncing in Microsoft Edge Preview Channels
Elliot Kirk in Articles on
202 Replies