SOLVED
Home

CONNECT MSOLSERVICE NOT WORKING

%3CLINGO-SUB%20id%3D%22lingo-sub-434851%22%20slang%3D%22en-US%22%3ECONNECT%20MSOLSERVICE%20NOT%20WORKING%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-434851%22%20slang%3D%22en-US%22%3E%3CP%3EHey%20Folks%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EToday%20I%20found%20interesting%20thing%20that%20Connect-MsolService%20is%20not%20working%20even%20after%20installing%20Microsoft%20Sign-in%20assistant%20and%20Install-Module%20MSOnline%2C%20AzureAD%20AzureRM%20but%20still%20it%20is%20getting%20the%20same%20error%20as%20shown%20in%20the%20given%20snapshot!!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20840px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F108264i4B5A73F6E0895CCA%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22powershell.jpg%22%20title%3D%22powershell.jpg%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EMSOnline%20Cmdlet%20not%20working%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-434851%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWindows%20PowerShell%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-438983%22%20slang%3D%22en-US%22%3ERe%3A%20CONNECT%20MSOLSERVICE%20NOT%20WORKING%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-438983%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDo%20you%20have%20the%20module%20loaded%3F%20Do%20a%20simple%26nbsp%3BGet-Module%20MSOnline%2C%20or%26nbsp%3B%3CFONT%20style%3D%22background-color%3A%20%23ffffff%3B%22%3EGet-Command%20Connect-MsolService%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-444839%22%20slang%3D%22en-US%22%3ERe%3A%20CONNECT%20MSOLSERVICE%20NOT%20WORKING%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-444839%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F136096%22%20target%3D%22_blank%22%3E%40Mitul%20Sinha%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20you%20are%20receiving%20this%20error%20since%20you%20have%20opened%20the%2032%20bit%20version%20(X86)%20of%20Powershell%20console.%20Try%20the%20normal%20Powershell%20console%20(x64)%20to%20resolve%20this%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20835px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F108429i381264B42AC350B3%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22powershell-error.png%22%20title%3D%22powershell-error.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-478117%22%20slang%3D%22en-US%22%3ERe%3A%20CONNECT%20MSOLSERVICE%20NOT%20WORKING%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-478117%22%20slang%3D%22en-US%22%3EGood%20to%20see%20this%20snap!%20Will%20try%20it%20out%20first%20then%20confirm%20it.%20Thanks%20for%20the%20response.%3C%2FLINGO-BODY%3E
Highlighted
Mitul Sinha
Contributor

Hey Folks,

 

Today I found interesting thing that Connect-MsolService is not working even after installing Microsoft Sign-in assistant and Install-Module MSOnline, AzureAD AzureRM but still it is getting the same error as shown in the given snapshot!!

 

powershell.jpgMSOnline Cmdlet not working

3 Replies

 

Do you have the module loaded? Do a simple Get-Module MSOnline, or Get-Command Connect-MsolService

Solution

@Mitul Sinha 

 

Hope you are receiving this error since you have opened the 32 bit version (X86) of Powershell console. Try the normal Powershell console (x64) to resolve this problem.

 

powershell-error.png

Good to see this snap! Will try it out first then confirm it. Thanks for the response.