Home

build 17735 Edge, feedback and Microsoft store don't work

MariAnne Woehrle
Occasional Contributor

Edge, Feedback and Microsoft store cannot access the internet.  Chrome and Internet explorer work.  With edge I can get to our local sites but nothing external.  this has been going on since 17713 - I cannot submit feedback so I can't get any help - does anyone have a fix for this????

3 Replies

Anyone know how to contact Microsoft since the Feedback hub has been broken for me since 17713 I can't supply feedback for the issues with not being able to connect to internet with Edge  / Feedback hub / or Microsoft Store.  Now it is affecting my ability to update my office 365 software.  IE and Chrome and other programs are fine.

I'm experiencing the exact same problem.   So far I've learned that if I do a clean install and do not join the PC to the AD domain, the Edge, the Store, and Feedback all work great.  It's only after joining to the local AD domain and the workstation is restarted (policies applied) that it breaks.   

Might explain why Edge can browse to my website and AMS software since they are in my local intranet but I can't get to any sites outside my firewall.  Seems to be a permission issue

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies