SOLVED
Home

1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's

Steven Rodriguez
Occasional Contributor

1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's

 

This will be the very first question I will ask in the AMA.  I hope you have a better answer than "we are working on it" ready for the thousands of us with this issue and waiting for a fix since September.

 

https://social.technet.microsoft.com/Forums/en-US/08485ba0-f69f-483b-861e-238f161dabee/problem-with-...

221 Replies
Solution
This is a known issue. The fix for this will be included in the cumulative update that will be released today at 10am via http://catalog.update.microsoft.com (manually downloaded). It will also be included in the next Patch Tuesday cumulative update. (Ref OS #14207031, 11D)
The suggestion I received from many employed by MS was to simply format and re-install Windows. This isn't an option, I run a highly customized system with many apps. A full reinstall would be a tremendous effort, the in place update really needs to work.

Thank You very much for addressing my question.  I am happy that this was resolved and am excited to finally be able to try FCU.

@Michael Niehaus

 

I've been watching the Windows Update Catalog website all day, as of this writing (4:43PM) I don't see it.  I'm using the search term "windows 10 cumulative update" and the most recent results are dated as Nov 29th, but they show as being for Build 1709.  I would assume by what you suggested we would be seeing a Cumulative Update dated for today, Nov 30th with Build 1703 in the description.

@Michael Niehaus 

 

Can you tell me what the KB number is for this patch please?

I don't think so, the KB applies to 1709, the patch we are looking for should be applicable to 1703 as we can't update to 1709 because of the NVME SSD issue.

The fix is needed to the Windows 10 1709 installation files, not to Windows 10 1703.

 

If you are using dynamic update, the fix should automatically be injected during the process.  Otherwise, you might need to manually mount the install.wim and inject the update into it, at least until January when we'll be releasing updated media that will contain the fix.

@Michael Niehaus I am not sure what you mean by a "dynamic" update but I am assuming you mean through an automatic mechanism.  I tried the upgrade again using Windows Update, and I get the same BSOD after it tries and fails to update with the "Feature Update to 1709" update.  I also tried the Windows 10 Update Assistant application which re-downloaded the media and also failed with the same BSOD on the first reboot.

 

Either I am doing something wrong, or the patch was not issued by Microsoft.  I have to say this is extremely disappointing.  A solution was implied, and none was given.  Please Help.

Seems to me, what hes basically saying is that the fix that should have came out on the 30th which never did, then the update for the 30th came out on the 5th on Tuesday which still does not contain the fix & now we'd have to wait till January for the "fix" which probably won't come again.

 

Seriously it's very disappointing, everyone out their is complaining and nothing is being done.

 

I built a new pc just 3 months ago and knew win10 would be very troublesome, that i literally bought an ssd just for the OS to to prevent deletion of important files because fresh installs are the only thing that temporarily fix things like this. 

 

It also stopped my antivirus & nvidia drivers from working that i had to delete both apps and reinstall to my other ssd.

These constant promises from Microsoft without a fix is just getting ridiculous already.  I have tried updating to 1709 in every possible way.  From Windows Update, to ISO, Upgrade Assistant, etc.,I have tried them all and nothing works.  Every time you try to reboot you get error 0xc00000bb.  There is no fix from Microsoft out there, and it does not look like there is going to be a fix.

Does Microsoft really want me to go and buy an Apple and be done with this.  I am sick of waiting for a fix for something that is a common problem for people trying to upgrade with a SSD drive.  

Can someone from Microsoft please tell us if there is going to be a fix or not, and what is the timetable ?  I really would like to know a fix is really coming or not. 

@Michael Niehaus A lot of very angry people, Michael.  Can you please bring this to the attention of whomever can provide a solution.

Highlighted

Microsoft seems to treat this like there is a couple of hundred of us here complaining,and no one else has this problem.  Well, in reality I cannot tell you how many people have this problem. I have heard from countless other people that cannot upgrade to 1709. Why in the world is it so difficult to put out a fix after about six weeks of this.  All we are asking is to be able to upgrade to 1709.  

I am at my end with this.  I have tried every method of upgrading.  Other than doing a clean install, which I refuse to do, it is impossible for people with SSD drives with NVMe to upgrade. 

You can also do the workaround, which is to clone the NVME drive to a SATA drive, then boot from SATA, do the 1709 upgrade, then clone back to the NVME.  Many have done this successfully, I just can't be bothered.

You mean you can simply copy 1709 from your SATA to your SSD after upgrading and everything works fine.  Sounds like a lot of work, and it will open up the possibility of many errors.  I just cannot understand why this is such a big fix for Microsoft.  Lots of people a lot less computer efficient than us are having this problem.  I wish they would just issue a fix already. 

Not copy, clone.  As in using a 3rd party tool like Acronis or something else.  The only downside I could see if the hardware change from NVME->SATA->NVME would trigger a hardware ID change and make all installed software unregistered and ask for re-activation.

You see.  You are already coming up with a possible problem.  I cannot believe all this time, and not one engineer at a place like Microsoft can actually come up with a fix for this.  Just unbelievable. 

I've been reviewing this with support engineers.  It appears that there are two separate problems, one that was fixed with the update released on November 30th (affecting a small number of devices with Intel P4500/4600 drives), and a second one that is still being worked on (affecting certain X299 motherboards).  We still have a block in place for the affected devices so that Windows Update doesn't try to upgrade them.

 

For the machines where you are seeing this issue, can you provide the make and model of the machine, or if it is a "build-your-own" device, what model of motherboard is being used?

 

The second issue (X299 motherboards) can also be fixed with a firmware update; the fix we are working on just tries to work around the firmware issue.  We are trying to work with the motherboard makers to have them create a firmware update.

 

Hi Michael, first thank you for following up and not leaving us hanging.

 

Second, Yes, mine is a custom built X299 based system.  The motherboard is the ASUS Prime X299-Deluxe and the SSD is the NVME Samsung 960 Pro M.2 512GB.

 

I have checked with both ASUS and Samsung and neither have posted a recent firmware update to address this issue.

 

PS:  You mentioned a block in place to prevent the installation.  I can tell you, if it is designed to block the 1709 installation via Windows Update, it is not working for me.  Every time I check for updates it tries to download and installed the "Windows Feature Update to 1709".  I've had to temporarily disabled the Windows Update service to prevent this from happening every time.

Yes, the Asus board is the most common one.  It's a pretty subtle issue, only exposed by 1709 due to a slight increase in the boot image size (which is why previous versions worked fine) that results in the boot image being loaded into higher memory due to memory fragmentation on that specific motherboard with that specific firmware.

 

I'll check to make sure the block is correct.

Interesting, thank you for explaining the detail of the problem.

 

We remain hopeful for a fix soon.

I have an ASUS Prime X299-A motherboard with a 512GB Samsung 960 Pro SSD and two SATA drives, as well.   Right now Windows Update has been trying to upgrade me to 1709 for about a month now.  I have my ethernet connection set to metered so it does not download the update.  I have kept my 1703 system updated with manual updates I downloaded and installed myself. 

I have tried with an ISO flash drive, Windows Upgrade Assistant, etc. to upgrade about a dozen times and every time I try to reboot I get the BSOD with error 0xc00000bb.  If you need any other information I will be happy to give it to you.  Thanks. 

That is amazing I have almost the identical system except an ASUS Prime X299-A MOB, and I have the identical problems as you do.  I also have had Windows Update trying to update me for weeks.  I had to change my connection to metered to prevent Windows Update from downloading the update.  

 Hi Michael

 

I tried the 30 November update (KB4051963) right now, but my pc still crashes after the installation reboot.

 

After I tried the Upgrade my PC restarts, the screen stays black for around 2 minutes and then the PC does power off. When I start the PC again, it immediatly boots with Build 1703.

 

Machine: Selfbuild

MB Modell: MSI X99A Gaming Pro Carbon (LINK)

SSD: Samsung SSD 960 Pro nVME

 

Is the X99A also affected with the same problem as X299? Or is the Samsung 960 Pro still not patched?

 

This may also affect other motherboards.  The Asus one is the one that we have seen most.

Could it be that ASUS is just the most popular motherboard ?  I have seen people with MOB's like MSI and Gigabyte with the same problem. 

I'm also having this issue. I have a Samsung 960 pro and asus prime x299 deluxe board.

That seems to be the magic combination with this problem: An ASUS X299 MOB with a Samsung 960 Pro SSD M.2 using NVMe . 

Also having this issue. System specs:

MOB: Asus prime X299-deluxe (FW: 802; running 28 lanes with i7-7800x & quad memory)

SSD: Samsung 960 evo M.2 500GB (NVMe, FW: 3B7QCXE7)

Signed up to add my similar experience, have several friends with largely same spec.

Same issue with 1709, same spec : Asus Prime X299 Deluxe. Samsung 960 Pro 2TB m.2.

 

Also, the 1709 update is also not blocked for me ( has failed 9 times, and is currently waiting for a reboot which I guess would fail). My machine is a standard build by www.scan.co.uk.

 

It's odd that a clean install reported to be be OK, and yet an upgrade is not. 

 

Thanks in advance for any help.

 

Also tried everything possible but a clone & fresh install because i don't see why i'd have to resort to that.

 

Windows upgrade assistant seems to have messed up my pc even more.

 

From  BSOD 0xc00000bb  update failing to Error 0x80242006 every time my pc tries to automatically update itself.

 

Motherboard: MSI GAMING M7 ACK

SSD: Samsung 960 evo + Samsung 960 pro 

 

Also a friend of mine has the same SSD's as myself but with a Gigabyte X299 AORUS Gaming 9 & has the same problems.

 

I have also heard of countless people with different model Motherboards that have this problem.  It is not just ASUS.  Gigabyte and MSI Motherboards all have this problem.  The common thing all of us seem to have that have this problem is the Samsung M.2 NVMe SSD. 

I to have been having this issue with an X99-A MSI board built by Origin with:

MSI Godlike Gaming Carbon

w/ Samsung 960 Evo NVMe and a Samsung 850 SSD

 

The update appeared to have issues and recently seemed to try to auto update itself hosing my install to be stuck on a blank boot screen, no amount of repairing startup fixed it so I went back to a recovery USB from Origin.

 

I seem to agree with the group here that the common denominator seems to be the 960 NVMe but that could just be that its a common NVMe drive. 

 

Considering its already hosed my install and I've gone back to a blank 1703 install I may try some of the workarounds to get to 1709. What's frustrating to me right now is that the Windows Update is stuck wanting to install 1709 so bad that because its failed on restart theres no way I can see to force it to redownload updates or check for new ones. I've gone so far as delete the download files expecting it to check and attempt redownload. Nope, still thinks its there and still thinks it wants me to restart thinking it will install.

 

I attempted to use the Microsoft tool again to download the update on Wednesday and it didn't seem to pull any new updates as it ended in the same error on install.

 

Another odd thing is that for the first time I've had my overclocking profile fail twice after shutting down the PC and on the next boot up the next day it fails, I reload the config and it's fine. All hardware checks out. Just odd. No issues until this 1709 stuff started.

I have the problem as well, and have not noticed any block.

Now I turned the automatic update off, since my PC tried to update at least 10 times, consuming all network bandwidth.

 

This is my config:

Samsung 960 EVO SSD M.2 2280 - 500GB
ASUS PRIME X299-DELUXE

ASUS released an updated bios (1004) for the Prime-X299-deluxe today that fixed the issue for me.

Where do you see that bios revision ? I'm on the asus support website for the X299 deluxe and I'm still seeing the 802.

Never mind I just found it under others in the os selection.

 

I can confirm that this fixes the issue for those with the Asus X299 Deluxe board. I'm now on the 1709 version.

The 1004 BIOS Update DID NOT fix the problem for me.  I just wasted an hour attempting the upgrade using the Windows 10 Update Assistant and it failed with the same BSOD.

 

ASUS Prime X299-Deluxe

Samsung 960 Pro NVME M.2 SSD

Hi Steven,

I'll put in some more detail about how I got my system to update in the hope its of some help to anyone.

After updating bios to 1004 I made some adjustments to bios PCH Storage Configuration and Boot -> CSM before upgrading to FCU1709.

For PCH Storage Cofiguration I set:

SATA Controllers to disabled (the topmost option). I enabled it again once the upgrade was complete.

 

For Boot ->CSM I set it to enabled

Boot Devices Control set to UEFI only

Boot Network and Boot Storage Devices set to ignore

Boot from PCIE expansion devices to UEFI first

 

I updated from USB using a fresh copy built with the Media Creation Tool (FCU 1709).

I started the update from windows.

 

Update went through smoothly. After the update I had to reinstall my antivirus and a few drivers but nothing drastic. Ive read about other experiencing that from the 1709 update but it wasnt a drama to fix. I only noticed something off with a few drivers when stressing my machine with an intensive game after the update.

Seems spot on now. Hope this info helps.

This is not a fix for the layman PC user out there.  These are BIOS tweaks for a very experienced user.  The bottom line is the new BIOS 1004 from ASUS does not fix the 1709 upgrade problem for people, and still nothing from Microsoft.  Microsoft nor ASUS has done a thing to help people upgrade from 1709 if they have a NVMe M.2 SSD drive.  

I have the same issue with the 1709 windows update with an x299 motherboard and a samsung 960 ssd NVME...please fix it ASAP!!!!

I know that the bios update fixed it for me . I want to add for those who might still have the issue after updating to the new bios from asus that I was on the microsoft nvme driver when I did the update. I've done this because of the current firmware issue with the 960 pro. This might help or not I don't know.

Another 2 hours wasted making the attempt.  I uninstalled the Samsung NVME driver, rebooted, ensured the MS NVME drive was in use, performed the upgrade attempt using the Windows 10 upgrade assistant and same BSOD result.  This is getting very tiresome.

Well, it looks like there was nothing in the patch Tuesday cumulative update for December.  So no fix for us trying to upgrade to 1709 goes on and on from Microsoft. 

The Asus 1004 bios fixed it for me. I didn't have to do any bios tweaks that Tim Gall did. I just updated the bios, re-ran the Windows 10 Update Assistant (didn't create USB media), and then the update went through smoothly.

 

My config:

ASUS Prime X299-Deluxe

Samsung 960 Pro (Samsung NVME driver)

 

 

Microsoft released yesterday a new Update called KB4054517.

https://support.microsoft.com/en-us/help/4054517

 

Will try this update, hope it will fix the 0xc00000bb error for nVME drives.

 


@Erkan Isik wrote:

Microsoft released yesterday a new Update called KB4054517.

https://support.microsoft.com/en-us/help/4054517

 

Will try this update, hope it will fix the 0xc00000bb error for nVME drives.

 

 


Please let us know if this works.  Thanks. 

Nope KB4054517 (12.12.2017) also didn't work. Got still the Error 0xc00000bb.

I did try it with the normal Win Updater and with the Upgrade Assistent, both got the error.

 

It really feels like a joke that Microsoft and the Manufacturers didnt patch it already. 1709 was released end of October. Now we have mid December and it's still not fixed...

 

20171213_203337.jpg

Related Conversations
Extentions Synchronization
Deleted in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies