Windows 10 start menu problems and copyprofile

Luis Young
New Contributor

1.  I deploy Windows 10 enterprise in a lab environment where hundreds of unique domain users are logging in and using the computers every monthy.  We've had a problem where after a few weeks the Start Menu (and cortana) will become unresponsive, leaving users without a working Start Menu.  I've seen posts from other users running into the same issue and based on my own troubleshooting I suspect the problem happens after windows updates are applied. Is MS aware of this issue and are there any plans to address it?


2.  When building my image for these lab environments, I like to create a custome default user profile so that anyone who logs in will have the same user experience, for example the same desktop icons in the same order.  In order for this to work, I have to sysprep my gold system twice using the copyprofile flag in the unattend.xml file.  From what I can tell, I have to do this because the copyprofile process doesn't actually take place until the system is booting back up from the first sysprep.  So I have to perform a second sysprep to actually capture the image with customizations made from the first sysprep.  Is there a better way to do this?




15 Replies
My understanding was that copy profile was no longer to be used. When I used it the start menu customizations I put in place did not work, it was one or the other.

1.  We have addressed a few issues in early Windows 10 releases like this, but this shouldn't be happening any more.  This can also happen with older antivirus software packages - they interfere with the start menu (accidentally).


2.  There is no need to sysprep twice to use CopyProfile.  It just needs to be set in the unattend.xml used when deploying the image.  (See for a discussion around that.)  If you manually sysprep and capture, then the unattend.xml that you used with sysprep becomes the one that is embedded in the deployment image, so they are sort of one in the same.  But in MDT or ConfigMgr, they would be separate.

Is there a way to use copy profile and have start menu customizations both work creating a W10 image?

1. It was definitly a problem with the early releases of Windows 10 and I don't think it has been reported again since moving to the Creators Edition, so hopefully it's fixed for good.


2.  I look forward to trying this with my next image, I've been using two syspreps since the Windows 7 days as it's always worked for me, but it never felt right.



You can still use CopyProfile, but it's not required if all you want is a custom start menu layout - you can import that using the PowerShell "Import-StartLayout" command prior to a user logging onto the system, then they will pick up that layout as default.

We had the same experience on Windows 10 machines you describe in #1. We also use Office 365 and download Office 2016 from the portal. We found Uninstalling Office 2016 and Reinstalling cured this issue. Not sure why Office 2016 impacted a Windows 10 update.

I've had success customizing the start menu using a default associations config .xml file and assigning it through Group Policy, but for getting other customizations such as aligning desktop icons along the right side of the screen in a particular order, or even to remove first-use dialogues from some apps (MS Edge and Reader DC for example) I've had to use this two sysprep trick.



I would like to set up some customizations for the look and feel of the image that I haven't been able to do other ways so being able to possibly copy the profile and set the start menu settings both would be great, I will see if it works.

Hi there,

From what I can find online, this was fixed in 1607 but from our own testing where I work, it is DEFINITELY broken again in 1703 - with the same symptoms. We cannot use CopyProfile at all right now for deployment.

Can we expect a fix?

If not, how can we deploy an image with a customized/configured default profile? This is vital to us.


Adding these lines to the SetupComplete script for Sysprep fixed the CopyProfile issues for us in 1703:

Add these to:  %WINDIR%\Setup\Scripts\SetupComplete.cmd

del /F /Q C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
del /F /Q C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache\*.*
del /F /Q C:\Users\Default\AppData\Local\Microsoft\Windows\INetCache\*.*

I can confirm that "copyprofile" is causing issues in the latest Windows 10 release from the Volume Licensing Service Center (SW_DVD9_WIN_ENT_10_1703.1_64BIT_English_MLF_X21-47750.ISO).


I found the same information as Hannah posted above just now but I've yet to try it myself and my symptoms were slightly different in any case. I'll likely forgo the batch file option though in favour of mounting the WIM and removing the content.



The primary issue we've observed isn't with Edge hanging, but rather not handling file downloads correctly. Using the F12 developer tools, we can see the MIME types in the reponse headers are coming through correctly, however, the app insists on treating the resulting file consistently as a TXT file and replaces the final period in the filename (which would normally denote the extension) with an underscore. For example ".msi" becomes "_msi". IE11 doesn't have this issue: it's strictly limited to Edge after being sysprep'd while using copyprofile.




Just a quick follow-up to provide some confirmation and clarification on the solution referenced by Hannah.


Firstly and most importantly, removing the two directories and file mentioned above resolved the faulty download behaviour.


Secondly - and this is only relevant if you're using vanilla WDS and looking to remove these folders and file from the WIM, you need to consider where you're using the CopyProfile=true directive. As we are using it in the WDS answer file, it meant that those same directories and file actually needed to be removed from the \Users\Administrator profile, not the \Users\Default profile.


In any case, this workaround has got the August 1703.1 build back into usable territory. Fingers crossed it's sorted out in the next build and ISO.




I've spent the last 10 hours trying to find out why our newest 1709 image build has been having issues with searching and some start menu functionality with domain accounts. I saw the tons of WebCache errors produced, but I hadn't made the connection mentally that it could be related to the CopyProfile function, since it worked fine with the 1703 build. This turns out to be the appropriate solution (besides MS not breaking this mess repeatedly), and I'm a little flustered I had to dig so deep to find the one person who managed to make sense of something MS has failed to figure out. Thanks a ton for this info. You rock!
I proofed this method works!
However, you need to delete at Administrator profile instead of Default if you are using Audit mode (Ctrl-Shift-F3 traditional method).

Is it possible to set up the admin profile with all the settings (desktop wallpaper, settings, etc.) then exporting and importing into the ntuser.dat default?

Related Conversations