Home

AADSTS500011 The resource principal named was not found in the tenant

%3CLINGO-SUB%20id%3D%22lingo-sub-842162%22%20slang%3D%22en-US%22%3EAADSTS500011%20The%20resource%20principal%20named%20was%20not%20found%20in%20the%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-842162%22%20slang%3D%22en-US%22%3E%3CP%3EAlthough%20it%20is%20less%20obvious%20in%20the%20desktop%20version%20than%20it%20is%20in%20the%20online%20version%20of%20Microsoft%20Teams%2C%20both%20are%20throwing%20authentication%20related%20errors%20when%20you%20have%20sideloaded%20a%20development%20version%20of%20your%20app%2C%20like%20prefetchAuthTokenForApp%20failure%20and%20AADSTS500011%20(the%20latter%20one%20also%20mentioned%20by%20faquino%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FMicrosoft-Teams%2FCreate-new-Microsoft-Teams-App-multitenant%2Fm-p%2F691023%23M33203%22%20target%3D%22_blank%22%20rel%3D%22noopener%22%3Ehere%3C%2FA%3E).%20Not%20sure%20whether%20it%20is%20only%20for%20multi-tenant%20apps%2C%20but%20mine%20is%20at%20least.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20doesn't%20seem%20to%20actually%20block%20me%20from%20following%20the%20authentication%20flow%20to%20get%20an%20idToken%20but%20it%20sure%20doesn't%20look%20nice.%20Is%20it%20an%20expected%20behavior%20that%20will%20automatically%20go%20away%20once%20your%20app%20is%20in%20the%20store%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAttempting%20to%20handle%20adal%20response%3A%20error%3AAADSTS500011%3A%20The%20resource%20principal%20named%20%5BappURL%5D%20was%20not%20found%20in%20the%20tenant%20named%20%5BcurrentTenantID%5D.%20This%20can%20happen%20if%20the%20application%20has%20not%20been%20installed%20by%20the%20administrator%20of%20the%20tenant%20or%20consented%20to%20by%20any%20user%20in%20the%20tenant.%20You%20might%20have%20sent%20your%20authentication%20request%20to%20the%20wrong%20tenant.%2C%20resource%3A%20%5BappURL%5D%2C%20error%20mapped%20to%20action%3AresourceDisabled%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20tenant%20I'm%20testing%20it%20on%20has%20all%20possible%20switches%20set%20to%20Allow%20in%20terms%20of%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fnl-NL%2Fmicrosoftteams%2Fteams-custom-app-policies-and-settings%3FWT.mc_id%3DTeamsAdminCenterCSH%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eapp%20side-loading%3C%2FA%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-842162%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-843323%22%20slang%3D%22en-US%22%3ERe%3A%20AADSTS500011%20The%20resource%20principal%20named%20was%20not%20found%20in%20the%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-843323%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F405102%22%20target%3D%22_blank%22%3E%40salvijansen%3C%2FA%3ECould%20you%20please%20share%20a%20screenshot%20of%20the%20error%20message%20you%20are%20seeing%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-844625%22%20slang%3D%22en-US%22%3ERe%3A%20AADSTS500011%20The%20resource%20principal%20named%20was%20not%20found%20in%20the%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-844625%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F359599%22%20target%3D%22_blank%22%3E%40Gousia_Begum%3C%2FA%3E%26nbsp%3BHi%20Gousia%20Begum%2C%20thanks%20for%20replying!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20925px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130784i6E03FF89E017350F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22aadsts500011.png%22%20title%3D%22aadsts500011.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20configured%20the%20Teams%20manifest%20as%20follows%20using%20the%20App%20Studio.%20I'm%20not%20sure%20what%20is%20meant%20by%20%22resource%20url%20for%20acquiring%20token%22.%20If%20this%20should%20be%20something%20other%20than%20the%20root%20url%20of%20the%20site%2C%20that%20might%20be%20the%20issue.%20The%20%22learn%20more%22%20link%20still%20points%20to%20the%20old%20app%20registration%20site%20so%20not%20able%20to%20get%20any%20input%20there.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130787iAAC47B62348A6363%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22web-app-aad.png%22%20title%3D%22web-app-aad.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20again%20for%20considering%20my%20question.%3C%2FP%3E%3CP%3ESalvi%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-848663%22%20slang%3D%22en-US%22%3ERe%3A%20AADSTS500011%20The%20resource%20principal%20named%20was%20not%20found%20in%20the%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-848663%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20now%20entered%20%3CSTRONG%3E%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%3C%2FA%3E%3C%2FSTRONG%3Einto%20the%20Resource%20URL%20field%20and%20that%20seems%20to%20have%20cleared%20the%20errors.%20I%20am%20however%20still%20wondering%20whether%20some%20more%20information%20would%20be%20available%20regarding%20SSO%20(apart%20from%20that%20one%20page).%3C%2FP%3E%3C%2FLINGO-BODY%3E
salvijansen
Occasional Contributor

Although it is less obvious in the desktop version than it is in the online version of Microsoft Teams, both are throwing authentication related errors when you have sideloaded a development version of your app, like prefetchAuthTokenForApp failure and AADSTS500011 (the latter one also mentioned by faquino here). Not sure whether it is only for multi-tenant apps, but mine is at least.

 

It doesn't seem to actually block me from following the authentication flow to get an idToken but it sure doesn't look nice. Is it an expected behavior that will automatically go away once your app is in the store?

 

Attempting to handle adal response: error:AADSTS500011: The resource principal named [appURL] was not found in the tenant named [currentTenantID]. This can happen if the application has not been installed by the administrator of the tenant or consented to by any user in the tenant. You might have sent your authentication request to the wrong tenant., resource: [appURL], error mapped to action:resourceDisabled

 

The tenant I'm testing it on has all possible switches set to Allow in terms of app side-loading.

3 Replies

@salvijansen Could you please share a screenshot of the error message you are seeing?

@Gousia_Begum Hi Gousia Begum, thanks for replying!

 

aadsts500011.png

 

I've configured the Teams manifest as follows using the App Studio. I'm not sure what is meant by "resource url for acquiring token". If this should be something other than the root url of the site, that might be the issue. The "learn more" link still points to the old app registration site so not able to get any input there.

 

web-app-aad.png

 

Thanks again for considering my question.

Salvi

Highlighted

I've now entered https://graph.microsoft.com into the Resource URL field and that seems to have cleared the errors. I am however still wondering whether some more information would be available regarding SSO (apart from that one page).

Related Conversations
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
PacketMon Components are not loading in WAC 1909
HotCakeX in Windows Admin Center on
2 Replies