Home

Missing Application Request Data for approved requests? Any ideas?

%3CLINGO-SUB%20id%3D%22lingo-sub-802875%22%20slang%3D%22en-US%22%3EMissing%20Application%20Request%20Data%20for%20approved%20requests%3F%20Any%20ideas%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-802875%22%20slang%3D%22en-US%22%3E%3CP%3E%3CFONT%3E%3CSPAN%3EAnyone%20else%20noticing%20ConfigMgr%201902%20deleting%20application%20requests%20data%20with%20approved%20status%3F%20We%20are%20actually%20experiencing%20missing%20approved%20requests%20and%20I'm%20a%20little%20surprised%20cause%20there%20is%20no%20logical%20explanation%20for%20this%20behavior.%3C%2FSPAN%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3E%3CSPAN%3EApplications%20are%20deployed%20to%20user%20collections%20in%20administrator%20approval%20mode%20(install%20for%20system)%20-%20the%20approval%20requests%20are%20processed%20by%20a%20PowerShell%20workflow%20using%20the%20Get%2FApprove%2FDeny-ApplicationRequest%20cmdlets%20by%20certain%20conditions.%20Noting%20special.%3C%2FSPAN%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3EThis%20behavior%20is%20weird%20respective%20the%20documentation%26nbsp%3B%40TechNet%3A%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3E%3CSPAN%20class%3D%22sxs-lookup%22%3E%3CSPAN%3EConfiguration%20Manager%20stores%20the%20information%20about%20the%20application%20approval%20request%20in%20the%20site%20database.%3C%2FSPAN%3E%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22sxs-lookup%22%3E%3CSPAN%3EFor%20requests%20that%20are%20canceled%20or%20denied%2C%20the%20site%20deletes%20the%20request%20history%20after%2030%20days.%3C%2FSPAN%3E%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22sxs-lookup%22%3E%3CSPAN%3EYou%20can%20configure%20this%20deletion%20behavior%20with%20the%20%3CSTRONG%3EDelete%20Aged%20Application%20Request%20Data%3C%2FSTRONG%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fde-de%2Fsccm%2Fcore%2Fservers%2Fmanage%2Fmaintenance-tasks%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Esite%20maintenance%20task%3C%2FA%3E.%3C%2FSPAN%3E%3C%2FSPAN%3E%20%3CSPAN%20class%3D%22sxs-lookup%22%3E%3CSPAN%3EThe%20site%20never%20deletes%20any%20approved%20or%20pending%20application%20requests.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fde-de%2Fsccm%2Fapps%2Fdeploy-use%2Fapp-approval%26nbsp%3B%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fde-de%2Fsccm%2Fapps%2Fdeploy-use%2Fapp-approval%26nbsp%3B%3C%2FA%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3EBest%20%26amp%3B%20Thx%20Chris%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-802875%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApp%20Management%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ECM%20current%20branch%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
christopher-mohr
Regular Visitor

Anyone else noticing ConfigMgr 1902 deleting application requests data with approved status? We are actually experiencing missing approved requests and I'm a little surprised cause there is no logical explanation for this behavior.

 

Applications are deployed to user collections in administrator approval mode (install for system) - the approval requests are processed by a PowerShell workflow using the Get/Approve/Deny-ApplicationRequest cmdlets by certain conditions. Noting special.

 

Any ideas?

 

This behavior is weird respective the documentation @TechNet:

 

Configuration Manager stores the information about the application approval request in the site database. For requests that are canceled or denied, the site deletes the request history after 30 days. You can configure this deletion behavior with the Delete Aged Application Request Data site maintenance task. The site never deletes any approved or pending application requests.

https://docs.microsoft.com/de-de/sccm/apps/deploy-use/app-approval 

 

Best & Thx Chris

 

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
PacketMon Components are not loading in WAC 1909
HotCakeX in Windows Admin Center on
2 Replies