SOLVED
Home

Move-csuser failes to find user in AD

%3CLINGO-SUB%20id%3D%22lingo-sub-816995%22%20slang%3D%22en-US%22%3EMove-csuser%20failes%20to%20find%20user%20in%20AD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-816995%22%20slang%3D%22en-US%22%3E%3CP%3Ethis%20past%20weekend%20I%20updated%20to%20CU10%20for%20skype%202015%20so%20we%20could%20move%20our%20users%20directly%20to%20Teamsonly.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3EMove-CsUser%20-DomainController%20dc.domain.com%20-Identity%20%24user%20-Target%20sipfed.online.lync.com%20-Credential%20%24cred%20-HostedMigrationOverrideUrl%20%24url%20-Confirm%3A%24false%20-MoveToTeams%3C%2FCODE%3E%3C%2FPRE%3E%3CP%3EI'm%20trying%20to%20use%20the%20above%20command%20to%20move%20the%20users.%20I%20get%20an%20error%20201%2C%20can't%20find%20user%20in%20AD%20with%20SIP%20URI%20sip%3Auser%40domain.com%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20get%20use%20get-csuser%20with%20the%20UPN%2CSIP%2C%20and%20full%20name%20and%20it%20will%20find%20and%20display%20all%20the%20information.%20I've%20tested%20with%20two%20different%20accounts%20and%20get%20the%20same%20issue.%20I%20tried%20moving%20one%20through%20the%20GUI%20and%20it%20worked%20great.%20So%20the%20process%20itself%20works%2C%20I%20just%20need%20to%20get%20powershell%20working%20so%20I%20can%20script%20a%20larger%20number%20of%20users%20after%20training.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eall%20the%20online%20references%20to%20the%20201%20error%20seem%20to%20point%20to%20AD%20attributes%20not%20replicating%20to%20Azure%20AD.%20But%20if%20that%20was%20the%20case%20I%20would%20assume%20the%20GUI%20wouldn't%20work%20then.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20tried%20pointing%20at%20a%20different%20DC%20same%20error.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPosting%20it%20here%20because%20the%20users%20are%20still%20on%20Skype%202015.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethanks.jb%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-816995%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeployment%20%26amp%3B%20Operations%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-818117%22%20slang%3D%22en-US%22%3ERe%3A%20Move-csuser%20failes%20to%20find%20user%20in%20AD%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-818117%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F7831%22%20target%3D%22_blank%22%3E%40Jason%20Benway%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CDIV%3E%3CDIV%3E%3CDIV%20class%3D%22public-DraftStyleDefault-block%20public-DraftStyleDefault-ltr%22%3E%3CSPAN%3Efigured%20it%20out.%20the%20-HostedMigrationOverrideUrl%20in%20microsoft's%20documentation%20was%20incorrect%20for%20our%20tenant.%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%3E%3CDIV%20class%3D%22public-DraftStyleDefault-block%20public-DraftStyleDefault-ltr%22%3E%3CSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fskypeforbusiness%2Fhybrid%2Fmove-users-from-on-premises-to-teams%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fskypeforbusiness%2Fhybrid%2Fmove-users-from-on-premises-to-teams%3C%2FA%3E%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E
Highlighted
Jason Benway
Contributor

this past weekend I updated to CU10 for skype 2015 so we could move our users directly to Teamsonly.

 

Move-CsUser -DomainController dc.domain.com -Identity $user -Target sipfed.online.lync.com -Credential $cred -HostedMigrationOverrideUrl $url -Confirm:$false -MoveToTeams

I'm trying to use the above command to move the users. I get an error 201, can't find user in AD with SIP URI sip:user@domain.com

 

I get use get-csuser with the UPN,SIP, and full name and it will find and display all the information. I've tested with two different accounts and get the same issue. I tried moving one through the GUI and it worked great. So the process itself works, I just need to get powershell working so I can script a larger number of users after training.

 

all the online references to the 201 error seem to point to AD attributes not replicating to Azure AD. But if that was the case I would assume the GUI wouldn't work then.

 

I've tried pointing at a different DC same error.

 

Posting it here because the users are still on Skype 2015.

 

thanks.jb

1 Reply
Solution

@Jason Benway 

figured it out. the -HostedMigrationOverrideUrl in microsoft's documentation was incorrect for our tenant.