Launching Skype for Business Gives Prompt "Your Organization is now using Microsoft Teams"

Occasional Contributor

We've just begun using O365 as we'd been using Office 2016 & Skype for Business 2015. We've rolled out O365 to a dozen or so people in the office and have not migrated over to using Teams. Although Teams is installed. My Skype has been working fine until today when working from home when I open Skype and get a prompt that tells me 'Your Organization is now using Microsoft Teams'. Funny thing is I'm the admin and have not migrated us to Teams. Everyone else is working in Skype fine but me.


Skype first opens, while signing in, and I can get to the condensed settings menu very briefly before this 'Teams' message appears. 


Is there a registry setting to force my Skype to actually work as Skype and NOT forcibly redirect me to Teams? I have not resorted to uninstalling Teams at this point. Nor have I done a repair install of O365/Skype for Business.


Is there a work around for this to get me back into Skype so I can communicate with the rest of my company?


The only thing I've been able to find that comes anywhere close to addressing this issue is this. But I can't seem to locate a similar menu for settings anywhere.

13 Replies

you should go to the teams admin center and check the upgrade mode for your user. I would expect it is set to TeamsOnly. Change it as you like (SfBOnly, Islands)



Hi Paul, You are correct. Coexistence Mode = Teams Only under Teams Upgrade. Unfortunately it also says "These settings for your organization have been set by Microsoft and can't be changed.".


The 'Learn More' link to me to the page you linked too as well.


Did a search and came up with this page that walks you through the options. Unfortunately on this page under Org-wide Settings/ Coexistence Mode it also says "These settings for your organization have been set by Microsoft and can't be changed".


Is there a way around this to edit the setting elsewhere in the O365 Admin portal?

I did find this as well...


"Once the updating is completed, we are unable to retrieve to Skype for Business."

That’s bad news. What about the other users in your org? Are they still using SfB in Islands or SfBOnly mode?
What you can try is to open a support ticket and tell them why you still need SfB.

Unfortunately everyone else has the same setting as me. But everyone else is working fine. And I logged into another computer and I was able to log in fine to Skype from that computer. That leads me to believe it's a reg setting somewhere.


I will contact support and see if I can't reverse this setting before it's too late.


Thanks for the input. I'll keep you posted.

I ran across this post where they mentioned using powershell to enable Teams Only in this one instance. 


Is there a powershell to 'disable' Teams Only?

You can try the following depending on which mode you want your user to be:
Grant-CsTeamsUpgradePolicy -PolicyName SfBOnly -Identity
Grant-CsTeamsUpgradePolicy -PolicyName Islands -Identity

HI Paul, I thought I was preparing for the worst with having to jump in to use the PowerShell commands that might affect the entire company. Everyone else is working so I'd rather not rock the boat during our busy time. So...


I simply deleted my SIP profile from %UserProfile%\AppData\Local\Microsoft\Office\16.0\Lync and it appears I'm back up and running.  Although time will tell.


Don't get me wrong. I still want to know exactly WHY my Skype for Business on prem config still functions properly even though in O365 the Teams Upgrade/Coexistence Mode forced 'Teams only'.


So while I may delve into the PowerShell commands you provided that would be a last resort option if this would begin to afflict others.



Hi Paul, I've got the powershell module installed. Trying to get connected to the online Skype for Business server per these commands:

Run PowerShell ISE as Administrator

Set-ExecutionPolicy unrestricted

Import-Module SkypeOnlineConnector

$cred = Get-Credential

$session = New-CsOnlineSession -Credential $cred -Verbose

Import-PSSession -Session $session

I'm not getting a failure when supplying my credentials in 4 above but when I run line 2 I get an error "Unable to connect to the remote server". 

Would you happen to have any recommendations for the proper command or step after Get-Credentials to connect to the online Skype server?


I'm seeing the following failure:



Was able to get connected via PowerShell ISE only to have confirmed that Microsoft forced the upgrade back circa 1 Nov 2018. 


"TeamsUpgradePolicy cannot be set because Microsoft has already upgraded this organization."


No way out via PowerShell.

Ok - that's what already some reported that you can't roll back via PowerShell.
I would suggest you open a support ticket and check if there is a chance.

Hi Paul, I did open a ticket with Microsoft to request the rollback. After providing a 'business case' for rolling back they did just now complete the request, thankfully. So I am now officially on my Island.


Took 7 days but it is done.


Thanks for the input Paul!

That's great news. Good to know it worked.