SRSv2 has been available as an automatic update to all devices for about one week now. has been available over the last 48 hours. Release Notes are as follows:

  • Changes enabling Microsoft to more flexibly manage Windows Updates.
  • No change to end-user experience. Release Notes are as follows:

  • Fix to address error observed on some systems during app launch. 
Senior Member

Do we know when the Microsoft Teams update for SRS will be released? And the associated USB HID Support for Cameras and Audio devices?

Senior Member

Still no RS4 and RS5 support yet right David?

Regular Visitor

Any idea when the deployment kit will be available?


@Andrew Fullagar We're getting very close to release of Teams-enablement on SRSv2.  Keep watching this blog for latest info.


@Nathan Ngo Correct.  RS4 is blocked until we can complete regression testing.


@Joshua Frias I'll update you on status next week.

New Contributor

And once again, an automatic SRS update completely resets the default audio device settings, necessitating I go through every single device manually to fix it.


Haven't any of your developers ever worked in the real world?  Stop making more work for us by updating these "enterprise class" devices like consumer laptops...


@David Osgood Please confirm the application update version where you observed this issue.  I appreciate your feedback.

Senior Member

i have this weird issue, i notice when i use the smartdock to share screen , i have this two black obvious space below . Anyone experience this ? the farend side will just notice this also .


edit : sorry , found the root cause , its the resolution . 

 7-7-2018 1-52-23 PM.jpg


@Andrew Fullagar Just wanted to let you know that has started pushing out to devices via the Store. enables both Skype for Business *and* Teams meetings support on Rooms Systems devices.  Teams is turned off by default once the update is applied.  The admin can enable Teams locally in device settings or via a remote xml push.

Senior Member

@David Groom Thanks. i'll test it out. I assume it has 3rd party USB HID support now? Testing with #Polycom MSR Dock, Trio 8800 running 5.5.4 and EE USB Camera 12 x zoom (keen to see if Dynadock USB extension works to front of room with Teams. SFB works great extending ethernet, 2x hdmi, usb cam to front of room.

Senior Member

question, does this means the room account teams should be enable teams , because i encounter "couldnt sign in to microsoft teams" 


Senior Member

@David Groom Updated to SFB works OK and both Teams and SFB meetings appear on the MSR Dock. Able to join a Teams meeting but the Polycom Trio 8800 (although functional as a conference phone) has no controls like it does in SFB mode. Polycom EE USB Camera does not operate and come online. Are the USB HIDs all suppose to be recognized by the Teams App? Guest Team member invited and joined and can be heard but does not show up on participants list and content does not show up on MSR Dock. Content shared from same tenant shows up OK.


In SFB mode everything works as expected. Polycom Trio 8800 conference phone in USB Optimized works and Polycom EE USB Camera 12 x works as expected and can control it.


When do you think USB peripheral devices will be fully supported as they are in SFB mode? Looks like that is the only thing really holding it back right now and the Guest not showing up.


Otherwise looking good! 

New Contributor

@David Groom this time, but it's happened after updates at least four times over the past year and a half, always after a version update applies.


@David Osgood Thank you for confirming - I'll report your experience back to the team.


@Andrew Fullagar Appreciate your feedback on the experience.  We're working to address some of the issues you describe in our next update.

Regular Visitor

@David Groom Any word on a deployment kit or are we waiting on another update?

Senior Member

@David Groom not all our devices did auto update even i check on the microsoft store . how to force update? 

Senior Member

@David Groom Is there a roadmap of what attachments will be supported in Teams part of SRS when attached in a meeting. Still trying to find a suitable solution for customers to attach Office (incl PPTX, DOC, XLSX etc) or PDF to a meeting and present it without a PC/Laptop/HDMI etc.


Any update on USB HID?

Senior Member

question, is this device reboots everyday? also, is there a way to change the wall paper?



Senior Member

 @rodelmurex there is a custom option for wallpaper.


@Joshua Frias - We just published a new SRSCreateMedia.ps1 (v1.3.1) to docs.microsoft.com (here).  The script will automatically download version of the application upon execution.

Senior Member

@Andrew Fullagar im interested , is there any link or guide.

Senior Member



its in the SRS documentation v2 webpages:

Custom Theme Images


The custom theme image file must be placed in C:\Users\Skype\AppData\Local\Packages\Microsoft.SkypeRoomSystem_8wekyb3d8bbwe\LocalState, just enter the file name and extension in the <CustomThemeImageUrl> variable.

The image file should be exactly 3840X1080 pixels and must be one of the following file formats: jpg, jpeg, png and bmp. If your organization wants a custom image, a graphic designer will find our Custom Theme Photoshop Template useful. It contains further detail on where to place various elements in a theme image and what areas appear on consoles and displays.

The XML configuration file must be updated at device startup to recognize the theme image. Once the new XML file is processed and deleted, the theme graphic file will be deleted from the directory.

Regular Visitor

Here is the actual deployment kit for anyone that wants it. https://go.microsoft.com/fwlink/?linkid=851168

Senior Member

I've run into issues with the latest version of the script, (1.3.1) and would welcome any advice.  Here is my configuration so far:






SW_DVD9_Win_Pro_10_1709.1_64BIT_English_Pro_Ent_EDU_N_MLF_X21-67518.ISO (extracted to c:\1\WinSource)


Using Powershell ISE results in a failure to build the USB stick whilst Powershell, (not ISE), does seem to allow the stick to be created correctly.


Trying to build a device with the newly created USB stick results in an error in the AutoUnattend process line 154 column 12.


Does anyone have an Auutounattend they can send me which is tested and works for this?


Regular Visitor

Hi all.


the latest CreateSrsMedia.ps1 script (v.1.3.2) does not accept my W10ENT-LTSB ISO anymore!?

It was working without issues with previous versions of the script?

I'm using the latest LTSB ISO that is available for download: SW_DVD5_WIN_ENT_LTSB_2016_64BIT_English_MLF_X21-07421.ISO

ISO is mounted as drive E:


It's complaining no Enterprise media is present. Though it identifies the ISO as Enterprise!?

Error while running the script:


"Please enter the path to the root of your Windows install media: e:
The media specified does not appear to contain a Windows 10 Enterprise image.
Double-check that:
  - You are using Windows 10 Enterprise media
  - You have the latest version of this script, and
  - The media is not corrupt.
   Enterprise customers can access Windows 10 Enterprise media from the Volume Licensing Service Center:

Images present on this media are:
  - Windows 10 Enterprise 2016 LTSB
Please enter the path to the root of your Windows install media:



Anyone any ideas?





Occasional Visitor


I have an issue where skype keeps exiting and reopening. Also it won't open the (skype) windows in full screen as it normally does when I start the device.

When I manually open the window I can't press anything (everything is greyed out) and after 30-40 seconds all windows close and opens again after a few seconds, as if skype is trying to start again. I also get an error messsage: "The room display is unplugged. Plug it back in for the best experience."

I have SRS version 3.1.115 and Windows 10 , 1709 Version 16299.611

I used the SP5 Recovery media 1709 build from this site:



I can confirm that this media worked on two other similar devices (they also got version from Windows Updates, but I am not...)



I kinda figured out the error message I had, but then a new one showed up: "Cannot fetch calendar". Read something about editing the host file to point to internal DNS, but i'm using an Office 365 user with Business Premium license.

Everything is still Greyed out and I can't get into settings or do anything... Like, how do I switch to admin account so I can get into windows? Everything is just in a loop.

Hi, @David Groom I see that the behavior of SRS is not the same as S4B regarding USB HID call control. The scenario is if you have an active call and you put it on hold. SRS: Sends an output report with Hookoff set to 1 and Hold set to 1 (Active Call + Held Call). S4B: Sends an output report with Hookoff set to 0 and Hold set to 1 (Held Call). MS Teams: I see the same behavior on Teams as on S4B, so I assume its a bug in SRS? Thanks Rameez

Hi, @RameezHS. I've reported your findings to the internal team.