Home

"Hidden" columns in SharePoint list aren't being hidden from the form?

%3CLINGO-SUB%20id%3D%22lingo-sub-568139%22%20slang%3D%22en-US%22%3E%22Hidden%22%20columns%20in%20SharePoint%20list%20aren't%20being%20hidden%20from%20the%20form%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-568139%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20list%20in%20SharePoint%20Online%20where%20users%20can%20create%20new%20list%20items%20by%20filling%20in%20various%20details%20within%20a%20form%20(using%20the%20modern%20experience).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20list%20uses%20some%20workflows%20which%20required%20me%20to%20create%20some%20hidden%20columns.%20When%20the%20user%20creates%20a%20new%20list%20item%2C%20I%20want%20these%20columns%20to%20not%20be%20visible%20on%20the%20form.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'd%20previously%20configured%20the%20columns%20to%20be%20set%20as%20%22hidden%22%20which%20worked%20fine%20up%20until%20recently.%20Now%2C%20these%20columns%20are%20displaying%20in%20my%20form%20despite%20being%20set%20to%20hidden.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F113322i3C89A3FE1C5257BD%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Capture.PNG%22%20title%3D%22Capture.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20529px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F113323iA7F821CE501416C1%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22capture2.PNG%22%20title%3D%22capture2.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20terms%20of%20solutions%20I%20can%20see%20that%20the%20columns%20are%20successfully%20hidden%20in%20the%20classic%20experience.%20However%2C%20when%20showing%20this%20site%20to%20staff%20I've%20always%20used%20the%20modern%20experience%2C%20using%20classic%20would%20only%20confuse%20people%20and%20also%20looks%20very%20dated.%20It%20was%20also%20working%20fine%20in%20the%20modern%20experience%20before.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20other%20option%20is%20to%20use%20a%20PowerApp.%20However%2C%20the%20form%20has%20some%20append-only%20comments%2C%20something%20PowerApps%20does%20not%20display%20correctly%20or%20support%20currently.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20would%20be%20great!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-568139%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ecolumn%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EForm%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Ehidden%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EList%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-568387%22%20slang%3D%22en-US%22%3ERe%3A%20%22Hidden%22%20columns%20in%20SharePoint%20list%20aren't%20being%20hidden%20from%20the%20form%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-568387%22%20slang%3D%22en-US%22%3EIt%20seems%20to%20be%20a%20bug%2C%20this%20is%20totally%20unexpected.%20Just%20open%20a%20support%20case%20to%20notify%20about%20the%20issue%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-568804%22%20slang%3D%22en-US%22%3ERe%3A%20%22Hidden%22%20columns%20in%20SharePoint%20list%20aren't%20being%20hidden%20from%20the%20form%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-568804%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20here%2C%20it's%20a%20nightmare.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-573013%22%20slang%3D%22en-US%22%3ERE%3A%20%22Hidden%22%20columns%20in%20SharePoint%20list%20aren't%20being%20hidden%20from%20the%20form%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-573013%22%20slang%3D%22en-US%22%3EIt%20seems%20that%20they%20resolved%20the%20issue.%3C%2FLINGO-BODY%3E
Highlighted
Toby McDaid
Contributor

I have a list in SharePoint Online where users can create new list items by filling in various details within a form (using the modern experience).

 

The list uses some workflows which required me to create some hidden columns. When the user creates a new list item, I want these columns to not be visible on the form.

 

I'd previously configured the columns to be set as "hidden" which worked fine up until recently. Now, these columns are displaying in my form despite being set to hidden.

 

Capture.PNG

capture2.PNG

 

In terms of solutions I can see that the columns are successfully hidden in the classic experience. However, when showing this site to staff I've always used the modern experience, using classic would only confuse people and also looks very dated. It was also working fine in the modern experience before.

 

The other option is to use a PowerApp. However, the form has some append-only comments, something PowerApps does not display correctly or support currently. 

 

Any help would be great!

3 Replies
It seems to be a bug, this is totally unexpected. Just open a support case to notify about the issue

Same here, it's a nightmare.

It seems that they resolved the issue.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies