Home

Why the "Site Pages" filtering is not showing the custom properties added to the content type

%3CLINGO-SUB%20id%3D%22lingo-sub-644232%22%20slang%3D%22en-US%22%3EWhy%20the%20%22Site%20Pages%22%20filtering%20is%20not%20showing%20the%20custom%20properties%20added%20to%20the%20content%20type%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-644232%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20working%20on%20a%20new%20communication%20site%2C%20and%20i%20have%20created%26nbsp%3B%20a%20new%20content%20type%20which%20have%20the%20built-in%20%22Site%20Pages%22%20content%20type%20as%20its%20parent%2C%20and%20i%20added%20this%20new%20content%20type%20inside%20the%20%22Site%20Pages%22%20list.%20and%20inside%20the%20custom%20content%20type%20i%20added%20three%20sites%20columns%20of%20type%20Managed%20Metadata%20which%20are%20linked%20to%203%20term%20stores.%20and%20i%20set%20the%203%20managed%20metadata%20columns%20as%20required.%20i%20added%202%20modern%20pages%20and%20i%20assign%20them%20values%20for%20the%20managed%20metadata%20properties.%20but%20when%20i%20went%20to%20the%20AllPages.aspx%20view%20%26gt%3B%26gt%3B%20click%20on%20the%20filter%20icon%2C%20i%20only%20got%20those%20fields%20for%20filtering%3A-%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F115940i1BD95BF634912E44%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22filteringg.png%22%20title%3D%22filteringg.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3Eso%20i%20am%20not%20sure%20why%20my%20managed%20metadata%20columns%20are%20not%20showing%20inside%20the%20filtering%20panel%3F%3C%2FSTRONG%3E%20is%20it%20a%20matter%20of%20time%3F%20as%20i%20have%20created%20the%20site%20around%202%20hours%20ago%3F%20or%20there%20are%20some%20settings%20i%20need%20to%20follow%3F%20of%20course%20i%20want%20my%20chnage%20to%20get%20reflected%20for%20all%20users.%20as%20seems%20i%20can%20click%20on%20the%20view%20field%20%26gt%3B%26gt%3B%20click%20on%20%22filter%20by%22%20%26gt%3B%26gt%3B%20but%20this%20will%20get%20cleared%20if%20i%20refresh%20the%20page%2C%20or%20other%20user%20access%20the%20filtering%20panel..%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-644232%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-644407%22%20slang%3D%22en-US%22%3ERe%3A%20Why%20the%20%22Site%20Pages%22%20filtering%20is%20not%20showing%20the%20custom%20properties%20added%20to%20the%20conte%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-644407%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F233354%22%20target%3D%22_blank%22%3E%40john%20john%3C%2FA%3E%26nbsp%3BYou%20need%20to%20click%20the%20column%20name%20from%20the%20List%20view%20and%20under%20%22%3CSTRONG%3EColumn%20Settings%3C%2FSTRONG%3E%22%20--%26gt%3B%20there%20is%20option%20%22%3CSTRONG%3EPin%20to%20filters%20pane%3C%2FSTRONG%3E%22.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20606px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F115942i6BE2A6D2C245C2F1%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Capture.PNG%22%20title%3D%22Capture.PNG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
john john
Super Contributor

I am working on a new communication site, and i have created  a new content type which have the built-in "Site Pages" content type as its parent, and i added this new content type inside the "Site Pages" list. and inside the custom content type i added three sites columns of type Managed Metadata which are linked to 3 term stores. and i set the 3 managed metadata columns as required. i added 2 modern pages and i assign them values for the managed metadata properties. but when i went to the AllPages.aspx view >> click on the filter icon, i only got those fields for filtering:-

filteringg.png

 

so i am not sure why my managed metadata columns are not showing inside the filtering panel? is it a matter of time? as i have created the site around 2 hours ago? or there are some settings i need to follow? of course i want my chnage to get reflected for all users. as seems i can click on the view field >> click on "filter by" >> but this will get cleared if i refresh the page, or other user access the filtering panel..

1 Reply

@john john You need to click the column name from the List view and under "Column Settings" --> there is option "Pin to filters pane". 

Capture.PNG

 

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies