Home

Shipped to First Release: Discovering the SharePoint mobile apps

Highlighted
Vidya Srinivasan
Microsoft

Today, we shipped the first of many features to help people get even more out of SharePoint by finding and downloading the SharePoint mobile apps! Your SharePoint Home experience will now feature a “Get the mobile app” button at the bottom of the page. Selecting the button will open a new tab with information about the apps across iOS, Android, and the Windows 10 platforms. Coming soon, users will also be able to email or use sms to send themselves an app invite.

 

The SharePoint mobile apps work with SharePoint Online in Office 365, SharePoint Server (2013 and 2016) on-premises and your hybrid environment. This feature is currently shipped to First Release and will be expanded to the rest of Production in the next few weeks.

SPhome_mobileUpsell_FR experience-Simulated FINAL.png

We’re eager to hear your feedback and use it to continuously provide the best SharePoint Home experience. Send us inputs via comments in this thread, posts and votes to SharePoint UserVoice, or through the feedback option on SharePoint Home itself.

31 Replies

How will this integrate with Intune MAM policies?
Will these actions show up in the security center audit logs?

Also can you fix the mobile apps so they can see document libraries for sites created from a template can actually be found. I.e. item objects with id's starting 8000. As the mobile apps are pretty useless to us as user cannot see their content.

This also goes for the web copy to functionality. None of our site libraries except default out of the box ones can be found.

Third party apps appear to have no problem with finding these. So it must be possible.

Thanks

Hi Dean, checking this with my team. Will get back with more details soon.

Thanks for the feedback Philip. I'm adding @Nate Clinton and @Lincoln DeMaris who own the mobile apps and document libraries. They'll be able to share more details on your ask.

Hi Philip.. can you provide a bit more info about the issues you are seeing?  The steps you take to reproduce the issue, plus screenshots would be great.

 

Thanks!
Nate

I'm away from my office for the next few days. Howeverer here is the process I have been through. 

 

I open up a site created by our standard template I can see all the libraries etc and work with them as normal. 

 

I go to the Sharepoint app on my device find the same site none of the libraries appear 

 

I see the activity feed and files views are populated.

If I go under lists I see only one item which is tasks.

 

Under Sitenavigation I see all the site structure as expected

If I navigate into any library I get No data available,something went wrong.

 

Now if I flip back to lists, that library will appear on the list then disappear 

 

If I then go back to the site. Create an out of the box library. Populate it with some content. 

Go back to the app. Navigate to the site, open the site navigation, open the new library and everything works as expected. 

 

I am seeing similar behaviour with the copy to function in the OneDrive for Business web interface. The libraries their simply do not show up unless they were out of the box created libraries. 

 

Our Developer tells me that minimal changes were done to modify the libraries. Added a few content  types and set versioning levels. These were done back on 2013 Sharepoint before we migrated to Sharepoint online.

 

 

I tried a few things like matching the settings of an out of the box library on our templated libraries and vice versa and still the same result. 

 

I had a look through the objects using the Sharepoint browser tool https://spcb.codeplex.com/

It showed our libraries were of a different type name of the standard and were of an id in the range of 8000 where stadnard document libraries are type 101

 

Sorry no screen shot available at the moment. 

 

 

I am not finding "Get my mob apps" options.

 

Could you please post some screen shot of it?

 

Thanks,

Gopi

The blue button at the bottom-right of SharePoint Home in the screenshot above is the intended experience Gopi. We have only shipped it to First Release tenants as of now and will be expanding in the next few days.

Hi Dean.  Right now the feature isn't integrated with MAM policies.  For the audit logs, those actions aren't included.  Are there specific things you'd like to see in the logs?  @Vidya Srinivasan

We are taking a look at this Philip to see if we can reproduce on our end. Thanks for the info!
Data such as App installation, app activity, update/version information, and device type could be valuable.
Gotcha. That's not likely something that would be logged by this particular feature, but it's something that we can add to our backlog for future consideration. Thanks Dean!

Hi, we have multiple customers with On-Premise installation of SharePoint 2013 and SharePoint 2016 with ADFS.

 

We are not able to use the SharePoint mobile apps to connect to these installations. Is it right that you do not support SharePoint installations with ADFS and the SharePoint mobile app or the OneDrive App ?

Hi Nate,

I ran into the same issue as Philip on the OneDrive part (Copy To not possible on particular sites) at one of our customers. Sites that weren't based on the Teamsite template showed empty libraries. I haven't tested this app yet, but maybe this can help your team.

For my customer we were using Publishing sites (for some unknown reason). As soon as we migrated those sites over to the Teamsite template, it all starting working.

Thanks Quincy.  We are taking a look at the SharePoint pieces right now.  For the OneDrive piece, adding @Ahmed Gharib

 

Thanks!

Nate

 

Hi Dominik... that's correct, we currently don't support ADFS for on-prem 2013/2016

Thanks
Nate

Hi Quincy,

 

Are you referring to OneDrive for Business on the Web?

 

-Ahmed

Yes, onedrive for business web interface displays the same behaviour.

Copy to just does not find any of the libraries created from a template site.
Thanks I really appreciate that.

@Quincy Thomas and @Philip Worrell we updated the OneDrive website with a fix for this about a month ago. You should be able to copy to any site that has a document library now.

 

-Ahmed

Still does not work.

If we create standard out of the box doc libraries yes that works. If however you have a site template created with configured settings these do not show up at all.

Using the sharepoint online client browser app I can compare the object of a document library that does show up and one that doesn't.

 

I'm seeing only the following differences

 

Library that does not appear

Base template is 80000
Base type is still DocumentLibrary

Content types enabled is True
Major Version limit 10

Object version 56

 

On a default library

Base template is 101

Content types enabled is False

Major Version limit is 500

Object version is 16

 

One other question, if the site does not have a default documents library. Does that cause a problem?

I know it does with Microsoft teams as it expects the library.

 

If I add an out of the box library to the site it appears without a problem.

 

 

 

Microsoft recommends using ADFS for SharePoint 2013 and SharePoint 2016 and the mobile Apps will not work.

 

Is it on your schedule to support ADFS with your mobile Apps in the future ?

Hi Dominik... we do have it on our backlog, but I don't have a timeline currently. 

 

Thanks!
Nate

 

@Clement Yau

Hi Philip,

Sorry, I may have misunderstood. Does the Library not show up or do the sites not show up? Also, no we don't depend on the default document library, we'll automatically jump there if it's the only one available, but it's not required.

-Ahmed
The libraries do not show up. Unless they are libraries that are created using the default document library app.

So if I take a site where no libraries are showing up and I add a document library app. That new one will show up but none of the existing template created libraries will display.

The sites themselves show up ok regardless.
On the subject of the SharePoint apps, the new app-to-app integration with Yammer is great. Can we expect something similar for Teams?
Definitely thinking going on around that space. Not sure on the timing or the specific features... but stay tuned :-)

Try to add the library to the quicklaunch navigation by opening the Library settings -> Title, description navigation -> Display this document library on the Quick Launch -> Yes.

 

Adding the library to the navigation by manually adding it as a link to the quicklaunch doesn't work. I believe if you add it using the library settings, it works :-)

 

I think if you do it like this, the library is visible in the SharePoint Online mobile app, and also on the Copy-To functionality from OneDrive for Business. But please let me know if this works.

Tried that. It does not appear to work.

At least not on our environment.
Creating new out of box libraries in the same sites work.

Thanks for the info.