Home

Sharing with everyone available but sharing within organization is disabled

Highlighted
bart vermeersch
Super Contributor

 

I understand their are a zillion places where sharing is configured, but I can't find how this is possible:

 

Creating a "link for everyone" is possible, but it is not possible to share within the organisation?

 

SHARING.png

26 Replies

I noticed this, too, and I'm glad someone brought it up. I suspect that this occurs in sites that are shared with "everyone," as I've only noticed in sites where I've done that. Haven't gotten around to testing this further to confirm, though.

Hi @bart vermeersch,

 

I just checked within a document library and the People in Organisation is available. Then I created a custom list and the link is disabled. It seems to depend on the type of list/library you have for this option to be enabled. 

@Pieter Veenstra, interesting observation. Bart's screenshot indicates a document library, and that's been my experience as well; not sure what that means for when this pops up.

In my case it's a siteassets library.

 

Odd... let me investigate and I'll get back to you all. Thanks!

 

Stephen Rice

OneDrive Program Manager II

@bart vermeersch,

 

Can you give me some more details on how the site is set-up and what exactly you are sharing? Are you trying to share the entire Site Assets folder or just some items inside of it? When I open up the Site Assets library, the "Share" button is greyed out so I'm not sure how you're getting to the dialogue. Thanks!

 

Stephen Rice

OneDrive Program Manager II

Hello @Stephen Rice thanks for looking into it!

 

The Share button is shown (and enabled) as soon as we select a file (or folder).

 

It is a folder we wanted to share within the siteassets in the root site of our tenant

https://tenant.sharepoint.com/SiteAssets/

I checked the behavior in another library of that site and it is identical.

 

The group Everyone has already read access to the library, so the link for people with existing access will work as well, maybe that is the reason the option is grayed out?

 

If that's the case, the information is in the information popup is incorrect (your organisation is preventing you from selecting this option) and the reason is not that intuitive for the user trying to create a link for the entire organisation?

 

Hi @bart vermeersch,

 

Thanks for the additional details. Can you check one more thing for me? Using the SharePoint Online Management Shell, it is possible to disable only organization links on a single site collection. The parameter is "DisableCompanyWideSharingLinks" in Get/Set-SPOSite. Can you check the value for that site? Thanks!

 

Stephen Rice

OneDrive Program Manager II

 

 

@Stephen Rice, I would really encourage you to take a look at the effect "everyone" has on this situation. Both bart and I have reported that this circumstance happens in libraries where "everyone" has already been granted access to the library. My assumption is, because "everyone" is there, the ability to create organization links is turned off since they do no more than a link made for those with existing permissions would do.

Hi Stephen, I reproduced this with a clean teamsite this afternoon.
I just create a new doc library and a custom list and I got a different sharing experience. See: https://veenstra.me.uk/2017/10/30/sharepoint-online-sharing-list-items-vs-documents/

@Pieter Veenstra, is "Everyone" used in permissions to this site you spun up?

I tried it with a clean private team site and a clean public team site both didn't make a difference. Libraries and list were showing the different behaviour. Unless I missed a setting as far as I know there is no setting like this specific for lists or specific for libraries.

Info from get-sposite

 

LastContentModifiedDate                  : 30/10/2017 21:35:06
Status                                   : Active
ResourceUsageCurrent                     : 0
ResourceUsageAverage                     : 0
StorageUsageCurrent                      : 43
LockIssue                                :
WebsCount                                : 3
CompatibilityLevel                       : 15
DisableSharingForNonOwnersStatus         :
LocaleId                                 : 2067
LockState                                : Unlock
Owner                                    : s-1-5-21-2299809472-3029442445-1811343435-3607576
StorageQuota                             : 1048576
StorageQuotaWarningLevel                 : 838861
ResourceQuota                            : 40000000
ResourceQuotaWarningLevel                : 30000000
Template                                 : STS#0
AllowSelfServiceUpgrade                  : True
DenyAddAndCustomizePages                 : Disabled
PWAEnabled                               : Unknown
SharingCapability                        : ExternalUserAndGuestSharing
SandboxedCodeActivationCapability        : Disabled
DisableCompanyWideSharingLinks           : NotDisabled
DisableAppViews                          : NotDisabled
DisableFlows                             : NotDisabled
StorageQuotaType                         :
ShowPeoplePickerSuggestionsForGuestUsers : False
SharingDomainRestrictionMode             : None
SharingAllowedDomainList                 :
SharingBlockedDomainList                 :

 

 

I'm having the same problem. All of a sudden users can't share anonymous links, even though every settings is set to enable it.

Hey all,

 

I just tried to repro this myself and wasn't able to get it to work. How are you adding the "Everyone" group to the site? Here is my set up:

 

image.png

 

 

All, just asking a couple of 'dumb questions'.

Does this setting have anything to do (or could be a conflict) with whether the site was created from the SP Admin portal or via the SharePoint portal (Create site)? And, if it was created from the SP Admin portal, does it have anything to do with the general Sharing settings or the Sharing settings on the individual site?

I can't replicate this issue. We allow (a) for Sharing, 'Allow users to invite and share with authenticated external users', and for individual sites where sharing is allowed, 'Allow external users who accept sharing invitations and sign in as authenticated users'

In our case it's our root tenant site (which was provisioned automaticaly).

 

Our users have no access on the site itself, only on the libraries (images and pages).

@bart vermeersch

So, if I understand well, you have modified the standard permissions of the root site collection of the tenant (i.e. "tenantname.sharepoint .com").

And you have broken inheritance for a bunch of document libraries under the root site and implemented additional permissions for such doclibs.

Correct?

@Stephen Rice

Could perhaps this be the reason for the odd behavior of sharing in such doclibs?

Just an idea...

Thanks for the additional details. Let me make sure I have this straight...

 

You have site collection Foo.

You shared Foo with "Everyone". 

Question: Is anyone in the Foo members group?

You have one or more document libraries in the site.

These document libraries have broken inheritance.

Question: Are they inheriting the Foo members group or do they start as empty?

You permission individual users to the document library. 

They have permission to the site via the Everyone group but only to the site via the direct permission.

When these users attempt to share, anonymous links are disabled.

 

Is this correct? Thanks!

 

Stephen Rice

Thanks Bart. Wherever possible, we do the following on our sites:

  • Allow 'everyone (except external users) read only access
  • Restrict only what needs to be restricted; this includes changing the Members to 'read only' if we don't want changes made
  • Keep an eye on the audit trails

We follow this model after many years of trying to fix up customised permissions on libraries and lists (and some pages), and even folders and individual documents, which became a nightmare to manage.

 

On our root site (name.sharepoint.com), we allow 'everyone (except external users)' read only access to the content as we use that site as a general 'portal' site to point users to where they may want to go to, e.g., their OneDrive, their SharePoint, their O365 etc. We did think to use it as a replacement intranet but changed this strategy once we saw the potential complexity involved.

I just came accross this post because we have the same issue. Since there have not been any posts, is there a solution??

I actually have a ticket in with Microsoft on this. Hopefully I remember to come back to this post when I get the answer!

What you are seeing is actually by design. If you take a peek at the Microsoft link below on sharing list items, you will see that "People in your org" is disabled. If you think about it...how often do you really share actual list items and furthermore how frequently would you ever share a list item with your whole org?

 

Sharing List Items

 

Check if "Limited-access user permission lockdown mode"  site collection feature is activated or not.

If activated try de-activating and check if it works for you, in case you still have the same issue.

@Stefaan De Vreese @bart vermeersch

Related Conversations
Shared Computers and Teams use
psneathen in Microsoft Teams on
8 Replies
Android Screen Sharing?
Ergin Yıldız in Microsoft Teams on
3 Replies
External Sharing with Stream or Video
Jennifer Seitsinger in Microsoft Stream Forum on
58 Replies
Embedding on SharePoint
Audrie Gordon in Microsoft Stream Forum on
46 Replies
Cutomizing SharePoint Online Modern Page
Vikas Dhingra in SharePoint on
4 Replies