Home

Office365 Profile Photos Disappearing

%3CLINGO-SUB%20id%3D%22lingo-sub-921417%22%20slang%3D%22en-US%22%3EOffice365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-921417%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20added%20profile%20photos%20to%20all%20users%20O365%20Profiles%20in%20both%20Azure%20AD%20and%20the%20Office%20Admin%20Centre%20and%20these%20were%20not%20pulling%20through%20to%20the%20People%20webpart%20in%20SharePoint%20Online.%20After%20painstakingly%20going%20through%20each%20user%20profile%20in%20the%20SharePoint%20Admin%20portal%2C%20the%20photos%20seemed%20to%20appear.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20seemed%20fine%20for%20about%20a%20week%20and%20then%20all%20of%20a%20sudden%20people's%20photos%20started%20disappearing%20from%20Delve%20and%20the%20SharePoint%20people%20webpart!%20Users%20confirmed%20that%20they%20did%20not%20manually%20delete%20the%20photo%20themselves.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhy%20is%20this%20happening%20and%20how%20do%20we%20stop%20it%20happening%20to%20anymore%20users%3F!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-921417%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EO365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPeople%20Webpart%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EProfile%20Photos%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EProfiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924481%22%20slang%3D%22en-US%22%3ERe%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924481%22%20slang%3D%22en-US%22%3EMy%20bet%20would%20be%20ADSync.%20There%20is%20no%20reason%20for%20the%20pictures%20to%20disappear%20from%20AAD%20unless%20something%20is%20overwriting%20it.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924483%22%20slang%3D%22en-US%22%3ERe%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924483%22%20slang%3D%22en-US%22%3EThanks%2C%20how%20would%20I%20go%20about%20diagnosing%2Fresolving%20this%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924497%22%20slang%3D%22en-US%22%3ERE%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924497%22%20slang%3D%22en-US%22%3EProfile%20photos%20has%20been%20an%20issue%20syncing%20for%20awhile.%20Here%20is%20another%20conversation%20thread%20about%20this%20issue%20-%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint%2FSyncing-Profile-Pictures-with-Office-365-and-Active-Directory%2Fm-p%2F644726%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint%2FSyncing-Profile-Pictures-with-Office-365-and-Active-Directory%2Fm-p%2F644726%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924499%22%20slang%3D%22en-US%22%3ERe%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924499%22%20slang%3D%22en-US%22%3ECorrection%201%3A%20when%20I%20said%20ADSync%20I%20meant%20Azure%20AD%20Connect.%20Are%20you%20syncing%20Profile%20pictures%20from%20AD%3F%20If%20i%20have%20my%20facts%20corrects%2C%20you%20need%20to%20look%20under%20Azure%20AD%20Attributes%20in%20you%20Azure%20AD%20Connect%20client%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924502%22%20slang%3D%22en-US%22%3ERE%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924502%22%20slang%3D%22en-US%22%3EThank%20you%2C%20but%20that%20appears%20to%20be%20referring%20to%20on%20prem%20and%20we%20are%20completely%20online%20for%20Azure%20AD%20and%20O365.%20We%20have%20no%20on%20prem%20setup.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924506%22%20slang%3D%22en-US%22%3ERe%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924506%22%20slang%3D%22en-US%22%3EThanks%2C%20as%20just%20mentioned%20below%2C%20we%20have%20an%20online%20only%20tenant%20and%20no%20on%20prem%20configuration.%3CBR%20%2F%3E%3CBR%20%2F%3EAre%20you%20able%20to%20suggest%20anything%20to%20check%20for%20an%20Online%20instance%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924512%22%20slang%3D%22en-US%22%3ERe%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924512%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F414226%22%20target%3D%22_blank%22%3E%40NV_01%3C%2FA%3E%26nbsp%3BIf%20thats%20not%20the%20case%20then%2C%20unfortunately%20as%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F388224%22%20target%3D%22_blank%22%3E%40SusanMc%3C%2FA%3E's%20post%20says%2C%20its%20an%20internal%20O365%20sync%20issue.%20I%20have%20seen%20it%20before%20as%20well%20and%20wrote%20similar%20code%20across%20multiple%20O365%20services%20as%20the%20post%20describes.%20Re-sync%20the%20photos%20and%20periodically%20checking%20for%20it%20is%20your%20only%20bet%20for%20now.%20Things%20will%20improve%20though%20now%20that%20the%20gab%20between%20Exchange%20and%20SharePoint%20is%20shrinking.%3C%2FP%3E%3CP%3EAlso%2C%20there%20are%203rd%20party%20tools%20out%20there%20that%20make%20sure%20these%20photo's%20are%20homogeneous%20across%20all%20services.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-924515%22%20slang%3D%22en-US%22%3ERe%3A%20Office365%20Profile%20Photos%20Disappearing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-924515%22%20slang%3D%22en-US%22%3EOK%2C%20thank%20you%20for%20your%20prompt%20responses.%20I%20feared%20that%20may%20be%20the%20case%20in%20that%20there%20are%20known%20sync%20issues!%3CBR%20%2F%3E%3CBR%20%2F%3EBest%20Regards.%3C%2FLINGO-BODY%3E
Highlighted
NV_01
Occasional Contributor

Hi,

 

We have added profile photos to all users O365 Profiles in both Azure AD and the Office Admin Centre and these were not pulling through to the People webpart in SharePoint Online. After painstakingly going through each user profile in the SharePoint Admin portal, the photos seemed to appear.

 

All seemed fine for about a week and then all of a sudden people's photos started disappearing from Delve and the SharePoint people webpart! Users confirmed that they did not manually delete the photo themselves.

 

Why is this happening and how do we stop it happening to anymore users?!

 

Thanks.

8 Replies
My bet would be ADSync. There is no reason for the pictures to disappear from AAD unless something is overwriting it.
Thanks, how would I go about diagnosing/resolving this?
Profile photos has been an issue syncing for awhile. Here is another conversation thread about this issue - https://techcommunity.microsoft.com/t5/SharePoint/Syncing-Profile-Pictures-with-Office-365-and-Activ...
Correction 1: when I said ADSync I meant Azure AD Connect. Are you syncing Profile pictures from AD? If i have my facts corrects, you need to look under Azure AD Attributes in you Azure AD Connect client
Thank you, but that appears to be referring to on prem and we are completely online for Azure AD and O365. We have no on prem setup.
Thanks, as just mentioned below, we have an online only tenant and no on prem configuration.

Are you able to suggest anything to check for an Online instance?

@NV_01 If thats not the case then, unfortunately as @SusanMc's post says, its an internal O365 sync issue. I have seen it before as well and wrote similar code across multiple O365 services as the post describes. Re-sync the photos and periodically checking for it is your only bet for now. Things will improve though now that the gab between Exchange and SharePoint is shrinking.

Also, there are 3rd party tools out there that make sure these photo's are homogeneous across all services. 

OK, thank you for your prompt responses. I feared that may be the case in that there are known sync issues!

Best Regards.
Related Conversations
Extentions Synchronization
ChirmyRam in Discussions on
3 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies