Home

Modern attachments not setting permissions

Richard Rodgers
Contributor

I have a problem that has only appeared recently with setting permissions on modern attachments from Outlook (with links to files on either SharePoint or OneDrive).

 

From Outlook I click "Attach file", choose a recent file from SharePoint or OneDrive, and select "Share link". The file gets "attached" and has the permissions "Recipients can edit".

 

However, sending the email does not change the permissions on the file. And strangely the recipient receives 2 emails:

1. The email I'd expect them to receive - with the "attachment" shown

2. A second email with subject "<user> wants to share the file <filename> with you" with a body of "To view <filename>, sign in or create an account"

Clicking on the attachment in the first email gives access denied.

Clicking on the link in the second email does let the user access the file and then adds their permissions to the file.

 

The strange thing is that this was working as expected for me a couple of weeks ago - only the first email was sent, the permissions were set accordingly and the recipient could access the file successfully.

This still seems to work successfully for my colleagues - when they do the same thing only a single email is sent and the permissions are set correctly. We are all on the same version (1803 - 9126.2356). We are all on Exchange 2016 on prem.

 

Any ideas what might be causing the problem here?

Related Conversations
Company Logo looks terrible on Modern Site Pages
Deleted in SharePoint on
24 Replies
employee directory
matthieu2906 in SharePoint on
5 Replies
Alerts on Comments in Modern Pages?
Rob Bowman in SharePoint on
49 Replies
Background color overlay on modern page logo
dmowry in SharePoint on
10 Replies