Home

Crawled properties not appearing under Search schema for Site columns

%3CLINGO-SUB%20id%3D%22lingo-sub-290045%22%20slang%3D%22en-US%22%3ECrawled%20properties%20not%20appearing%20under%20Search%20schema%20for%20Site%20columns%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-290045%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20created%20couple%20of%20site%20columns%20using%20PowerShell%20(CSOM)%20script%20in%20SP%20online%20site.%20I%20have%20added%20all%20these%20columns%20to%20libraries%20using%20PowerShell%20(CSOM).%20Later%20I%20have%20migrated%20hundreds%20of%20documents%20to%20different%20libraries%20which%20contains%20these%20site%20columns.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20want%20to%20implement%20search%20refiners.%20So%20I%20wanted%20to%20add%20few%20of%20the%20created%20site%20columns%20to%20RefinableString%20properties.%20When%20I%20am%20trying%20to%20add%20the%20crawled%20properties%20to%20the%20Refinablestrings%2C%20I%20am%20not%20able%20to%20identify%20crawled%20properties%20for%20created%20site%20columns.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20created%20site%20columns%20two%20days%20before%20and%20migrated%20data%2024hrs%20ago.%20I%20think%20this%20time%20is%20sufficient%20for%20crawling.%26nbsp%3B%3C%2FP%3E%3CP%3EAm%20I%20doing%20something%20wrong%20here%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-290045%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECrawled%20Properties%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Esearch%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESite%20Columns%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-290179%22%20slang%3D%22en-US%22%3ERe%3A%20Crawled%20properties%20not%20appearing%20under%20Search%20schema%20for%20Site%20columns%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-290179%22%20slang%3D%22en-US%22%3EThis%20looks%20good.%20Let%20me%20give%20a%20try%20with%20this%20solution.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-290124%22%20slang%3D%22en-US%22%3ERe%3A%20Crawled%20properties%20not%20appearing%20under%20Search%20schema%20for%20Site%20columns%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-290124%22%20slang%3D%22en-US%22%3EIs%20this%20a%20modern%20team%20site%3F%20If%20so%2C%20take%20a%20look%20at%20%3CA%20href%3D%22https%3A%2F%2Fthesharepointfarm.com%2F2018%2F11%2Fcrawled-properties-not-created-from-site-columns-in-modern-sites%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fthesharepointfarm.com%2F2018%2F11%2Fcrawled-properties-not-created-from-site-columns-in-modern-sites%2F%3C%2FA%3E.%3C%2FLINGO-BODY%3E
Mihir Yelamanchili
Contributor

I have created couple of site columns using PowerShell (CSOM) script in SP online site. I have added all these columns to libraries using PowerShell (CSOM). Later I have migrated hundreds of documents to different libraries which contains these site columns. 

I want to implement search refiners. So I wanted to add few of the created site columns to RefinableString properties. When I am trying to add the crawled properties to the Refinablestrings, I am not able to identify crawled properties for created site columns. 

I have created site columns two days before and migrated data 24hrs ago. I think this time is sufficient for crawling. 

Am I doing something wrong here?

2 Replies
This looks good. Let me give a try with this solution.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies