Cannot Release Lock on SharePoint Online File

Brent Ellis
Valued Contributor

SharePoint thinks a user still has a lock on.  I can't adminsitratively do anything with the file online.  This has been going on for almost a day.


We've cleared cache, closed Excel on his computer, cleared out some local cashe directories, rebooted, etc.


Nothing is clearing up this lock.


All I want to do is delete the file at this point, and I can't even do that.


What are my options as a Global Admin?

66 Replies

Do you mean that the file is stuck on checked out state?

No checked out, "locked  by user"


Kinda like they opened it in Excel and still have it open so no one can else can open/save it.

Ugh, it self resolves itself shortly after posting on here...

I've seen a few reports of something that sounds like this this in our tenant this week, mostly from Mac users. The error message appears in the MS Upload center when the person is trying to save a file they've been editeing. It says "The file ... is locked for shared use by <the same user> [membership]. The files are not large, e.g., a 45 KB Word doc. Haven't found a cure, yet.




This has been a known "issue" of SharePoint for years...sometimes you get this "insane" problem of having files locked and nobody is actually editing them...just wait some times and SharePoint will release back to you :-)

This is a very frustrating known issue in SP Online, and I can't really understand why we don't get an admin-tool (via PS, for example) to manage it.

My greatest concern is, what I've experienced many times, that the 10 minute timeframe MS promise for auto-unlock is simply not true and it took much-much longer to get access back to the file. Also the workaround they suggest here haven't ever worked for me. So my user (and admin) experience is that whenever this issue occurs, I have no other tools to fix it than waiting, and I have to tell the same to my users.


I now have a locked file (Word DOCX) that has remained locked for a few day. The funny thing is the user that locked it is me! I cannot edit, save, delete or anything. I have resorted to downloading an offline copy to do my work. Other complicating factors. MS Teams is overlayed on SharePoint, the MS Upload Center has run a few times and the cache is clear. Oh, and I have tried resolving this in both Teams and SharePoint itself. I remember this sort of problem back in the days of SP 2003 and SharePoint Designer was a big help in those days, sure do wish we still had that. I'll be watching this thread for solutions. ~ Doug



I just unlocked the file in question.  To reiterate from before, I received messages that somehow the system thought I was personally responsible for the lock out and I was unable to control this file.  As mentioned, I am in an working environment of SharePoint / Teams.  I had assumed that Teams was a collaboration tool layered on to SharePoint and that somehow SharePoint would have ultimate control over the file pemissions.  Apparently not!

The fix in my case was to confirm I was unable to make changes from within SharePoint and then go back to Teams.  Use the option "Open in Word" and not "Open in Word Online" or "Open in SharePoint".  Once I had it open in Word, I went to "File > Info > Manage Document", cycled through Check out and Check In successfully. and then saved.

What this tells me is that somehow the MS Teams application is also managing check outs.  One other possibility I am not able to confirm is that OneDrive for Business is somehow involved when storing the offline temproary file.

I still plan to watch this thread.  Best of luck, ~ Doug


I have the same problem on a wordfile. SP Online, Library has major versions enabled but no check-out required. I'm getting "the file is locked for shared use by....myself".


I opened the document in word browser and wrote some stuff. It saved and I navigated back, when I try to change a property in a choice column, I get that error message. 


I think it is a very misleading error message because I thought that co-authoring would also not work when I read "locked for shared use..". But co-authoring works, no problem. 


Solution for me is to open document in client and close it. Then I can change properties without any problems. 


Don't like this....






We have the same issue but in our case, its Sharepoint 2013, On-premise.

User has opened a doc in a library, made changes to word doc, tried to save and close.

The document is not able to be checked back in by domainname\user.

We then notice that the file is in th Upload Centre as "Upload failed" ..  and says check out for editing by the above user.

The impact is that other users have gon in and made changes after, so versioning is turned on which means the file has been overwritten. We resolve this by comparing the document with the current versions in SP.  

We have tried all of the usual fixes, like clearing the cache etc.,

We have also noticed that even though Microsoft say that the file is locked after closing for 10 mins, in one instance it took more than 30 minutes, but most cases not at all.




You sir have saved me from having a headache on a Monday!


Thank you.


Joseph Rothwell

perfect, worked like a champ!
I still have this issue just recently actually. It is locked by me, but I can manage to view it once in a while and close out - I do see other users on it as well (in Word client and Word Online). I'd like to just delete this file from our SharePoint Online document library altogether, but it keeps saying I can't because it's locked. :(

Any other solution you can think of is helpful. Thanks!
Same issues here with several users. Upload Center seems to be out of control. There is clearly something wrong. I found this old post Anyone here having experience with virus scanner software interfering?

I have same problem for Office 365 group site. in my case:

- Creating file online example 'WORD' and save from browser itself.

- Share file with someone within organization

- copy file to other folder in same site

and then I have use case to remove file.


I am getting error message the file is locked by other user and can't delete it.


Please let me know if someone got exact solution of this issues. 

Hello All


This was the solution that we came up with, that has now resolved all of our issues.


  1. Make sure the "webclient service" on client side is running 
  2. Find registry key: HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters on their machines.
  3. Find value: SupportLocking(if no, please add), set its value to 0, want to just disable lock feature.

This disables the locking feature via the registry and does not impact any other services.

I would suggest that you test it one 1 machine first to see if it resolves the issue prior to pushing it out to all production machines.





didn't work for me.


Upon further investigation, the 'file lock' happening for one user only not for others. I am administrator of Office 365 and not happening for me, also checked with one of my colleague who has contribute permission on site and no file lock for him.


another solution?  

Is the user in question using Microsoft Teams?


If so, this fixed the problem for me. 


"The fix in my case was to confirm I was unable to make changes from within SharePoint and then go back to Teams.  Use the option "Open in Word" and not "Open in Word Online" or "Open in SharePoint".  Once I had it open in Word, I went to "File > Info > Manage Document", cycled through Check out and Check In successfully. and then saved."

No - none of our users are on Microsoft Teams

Just adding more info on this, I am uploading file 'word document on SharePoint online using Office 365 group sites, Not Microsoft team.

Yes!! That worked for me.   I've had it several times now where I can't change some attribute values on the document (PowerPoint in this case) because it is locked for editing by me!!

Opening the document in PowerPoint, checking it out and back in removed this lock and I was able to edit the attribute value in SharePoint.

This is what worked for me. After syncing the library and finding the lock symbol on all the files in the library displayed in my File Explorer, this is what I did:

  1. Remove all required column status from all fields. Be sure to include the default Title field. You might have to drill into the Document and/or Item Content Types to get to it. (I have found that it seems to be set as a required field by default in the standard Document content type)
  2. Enable version control inclusive of drafts, be sure it is set for 'anyone who can read'. Save. Then return and disable it. 
  3. Enable Content Approval and save. Then return and disable it.

The key one, for whatever reason, was #3. When I did that, a message box popped up on my monitor saying something like 'you can now edit your files in OneDrive'. When I checked my File Explorer, the locks were gone. I verified today that other users who are syncing this library to their File Explorer are also now able to edit the files (the lock was gone for them, too).


Below is my original post.... LOL.... I was pretty excited to see that this worked. I hope it does for you, too.


Out of desperation, I enabled Content Approval and then disabled Content Approval and.....

Low and behold I got a pop up from ODB saying 'You can now edit your files'. I opened my File Explorer....yes...wait for it....and the LOCK WAS GONE!  OMG, I spent hours on this to find that it was one check box for a feature I'd never enabled for the library. Why it was affecting its performance, I haven't a clue, but it worked. WHEW!

I had the same issue and this worked for me:


Close Excel

Open the document library where the file is located. Select the file and delete.

Go to the recycle bin and restore the file. 

Open the file again and nos I can edit.

It looks like there are different solutions or should I say workarounds for the same problem.


Wouldn't it be nice if Microsoft came out with a clear and concise and permanent solution!?


I can understand that sometimes a file is locked by a different user for, what I think, are obvious reasons.


What I do not understand is that the file is locked by myself for editing.  Yet when I try to access it for this exact purpose SharePoint won't let me.


Having to wait for a short period for the file to unlock is just not good enough and that doesn't always work anyway.


Locks is a complex topic and technically a client or network issue. SharePoint supports co-authoring locks unless you have Check In/Out enabled on the library. Client side locks will occur if Office cannot negotiate a co-author lock falling back to an exclusive lock. As others have pointed out, the upload center can contribute to locking and is one of the first things you should check. You can trace the calls via Fiddler on the client.


This is the technical explanation from PSS:


When a user attempts to open an Office file hosted on SharePoint in the Office client, there is an expected set of network calls we should be seeing unless there is a problem. Once a user clicks that Office file to open in client, code on the SharePoint page and (if using Internet Explorer) the Office 365 browser addon sends a command to initialize the client application (Word, Excel, PowerPoint). Once the Office client application starts launching, Office will start a HTTP conversation with SharePoint. If the Office call is already authenticated, the Office will be returned the file content. However, if not already authenticated, which is usually expected to be the case, Office will negotiate for Authentication with SharePoint. This process happens through two networking calls called OPTIONS calls. The first OPTIONS call is anonymous and expected to be rejected by SharePoint as to establish what types of authentication SharePoint will accept. The second options call will include the requested authentication information to SharePoint. If SharePoint accepts the second options, call, it will return a METHOD call, identifying what network verbs can be used to communicate with it (OPTIONS, GET, LOCK, PROPFIND, and POST are all examples of verbs for this process). Once the verbs are established the Office client will make a POST network call that requests the metadata for the file, adds the user’s session lock state (coauthor lock or exclusive lock) and to request to open the file from the CellStorage web service in SharePoint. If the Office client has never accessed the document before, the entire document will be downloaded from SharePoint and cached in the Office Document Cache. If the Office client has opened the file before, then it is already cached and only the changes will be downloaded. At this point, the Office file will open in the Office client. This entire process happens between a few milliseconds to a few seconds.



I just went through this whole situation with a user who had created a file last night, edited it and shared it with two other employees who also edited the file last night.

This morning no one could edit the file due to multiple locks.

When trying to delete it said user had the file locked for offline editing.

When opening the file in local Word, the file showed it was being edited offline by said user on 4 different devices.

I found that there is a document cache in the Upload Center.

Once we logged the user in to every device they use and deleted the troublesome file from his Upload Center document cache, the file was able to be deleted.

I hope that helps someone.


For Microsoft Teams MS aknowledged a global issue with the Teams vs SharePoint vs OneDrive vs security services integration. Development team is looking at it. Solution can only be expected at a new update what can take still months. (On Office365)

First time I encountered this, I realized I had the file open in a different browser tab which was minimized and out-of-view. So, my mistake, I really did have the file locked for use by me.

I seems that i have the exact same problem as you describe. 

Sees like I have the exact same issue as you describe here.

When someone opens an Office file in the Office Online feature --> the file is locked!

Very nasty when supporting automated processes...


Its very ugly: ScreenHunter_03 Aug. 22 12.14.jpg

Its very user unfriendly: ScreenHunter_04 Aug. 22 12.31.jpg


Maybe an idea to support =

Doug, thank you so much! The check out check in and open the file in the actual program and not the online version really worked. =)
Over a year later, your investigative work still helps users, thanks Doug.

I am also experiencing this issue,, and the page you sent cannot be found.   Please advise the suggested fix for this problem...  thank you.

Also having this issue here, on and off.

It was a suspected issue with Chrome a few months ago, so we updated Chrome and that seem to resolve the problem, but it is back again.

Very off-putting for new users of SharePoint.

It seems we are waiting on a major update, hopefully autumn this year.

As I understood MS is working on the full integration of SharePoint, OneDrive and Teams regarding file handling. The bug in Teams on locking files when doing online or in Teams editing is also a result from this not being properly integrated yet. Also complete security management is involved. Let's hope MS is not overstepping its capabilities here and will find a solution soon. This locking issue is really blocking global adoption and deployment from as well classic SharePoint as Teams.


Thanks a lot Doug. This issue was driving me nuts today. Thanks to your post I am sane again. 

This would be nice if I could actually download Word. I'm using an Education Office 365 email for my documents and I can't exactly find a way to actually download apps themselves. I guess I'm going to be stuck with a broken Word document forever.

The solution I found was to Restore the locked out file to a previous version. That essentially kicks the user (who the file thinks is editing) out and allows you to then rename/ delete/ move etc the file again.


This is a persistent issue with something fundamental to Office 365 and seriously needs looking in to by @Office Microsoft !!

I just discovered a strange variation of this issue:

When clicking a document, Word Online will open the document in a new browser tab.

If you close that tab before Word Online has completed loading, a document lock has already been set.

But not released. Even if you open the same document with the same user again.

Users are able to edit the document, because of the co-authoring feature.

But you cannot rename / delete or restore versions.

You will get the error "The file ... is locked for shared use by <the last user who edited the document>"

Until the lost lock has been kicked by some cloud-service job. Normally means next morning...


Thanks for the fix, I will try this next time! Be nice for a permanent fix by Microsoft though........
To add to Trevor's post, any time a file is opened from SharePoint, regardless of using Office Online or the Office client, a lock state will be set. If we're only looking at opening files using the Office client, and file check out is not required in the SharePoint doc library, then the lock state is determined by the end user's Office client. If the user has Office 365 Pro Plus Click to Run, and is on the Monthly update channel, then the user will always set a co-authoring lock unless checking out a file. If on say, the Office 365 Pro Plus MSI client, then any time a user opens an Excel file from SharePoint, the lock state will ALWAYS be an exclusive lock since Office 2016 / Office 365 Pro Plus MSI cannot co-author with Excel files in the client. Because a lock state will always be applied when opening files, if a file has an exclusive lock set and SharePoint is never told the end user is done editing said file, the file lock will remain until the lock either expires or SharePoint is told the user who set the lock is done with the file. Regardless of lock type (Co-authoring or Exclusive), If a lock is applied to a file, it cannot be renamed, moved, or deleted. However It can still be copied or downloaded locally. If the Office client crashes while saving the file, or the internet connection drops, the pending file information will show up in the MS upload center where it can be pushed back to SharePoint, thus releasing the lock.

try this,


Open the file in office client in read only mode. As soon as it opened in the office client, then check it out.

I particularly love this error combination.

2018-10-30 11_53_57-Table Test.xlsx.png

Excel says I'm the only one here, but I can't make changes since I'm not alone...

This is funny but also frustrating!
We're getting the locked out issue again today, by restoring a previous version and then restoring the correct version, this resolves the problem.

Microsoft needs to fix this permanently though.

Doesn't work for me. 


I'm on a Mac. Using Chrome. A file I opened and edited is still locked by me. No one else has worked on it. I closed the browser. I shut Word. There is no unlock option. Does someone have step-by-step instructions to close a file that a ghost of myself has locked? 

The Word file in OneDrive/sharepoint doesn't open in a new browser. It is locked by the ghost of me. I can't unlock it. I'm stymied.

Can't thank you enough for this reply. Great job!

This problem is a result of Office Client setting a 'lock'.. that isn't a SharePoint check-out lock, and a network glitch misses clearing the lock. SharePoint usually notices within 15 or 20 minutes.. but not always.
I found a way to release this lock on-premises using PowerShell. I would think there is a PnP version that does the same on SPO.

I neglected to document where I plagiarized this from, so I cannot credit the original author

#this script overrides a file lock that occasionally occurs when a file is opened in the client, but is closed unexpectantly.
# locks are supposed to expire after 10 minutes, but that doesn't always happen
# in this case, the file looks like it is checked in, but is locked for editing

$url = "https://WEBSITE/URL/HERE"

$fileurl = "https://WEBSITE/URL/HERE/LockedFileName.xlsx"

$web = Get-SPWeb $url
if($web -ne $null)
    $item = $web.GetListItem($fileurl)

    if($item -ne $null)
        Write-Host "Found file " $item.Title


        $userId = $item.File.LockedByUser.ID
        $user = $web.AllUsers.GetById($userId)

        $impSite = New-Object Microsoft.SharePoint.SPSite($web.Url, $user.UserToken);
        $impWeb = $impSite.OpenWeb();
        $impItem = $impWeb.GetListItem($fileurl)