Home

Bug in Communication site Document Library webpart toolbar - Copy Link brings up Send Link screen

Lisa Proctor
Occasional Contributor

I've been able to duplicate this behavior on several SharePoint communication - you expose a Document Library on a comm site page using the Document Library webpart.  Then if you click to select a document shown in that Document Library webpart and click Copy Link instead of getting the Copy Link pop-up, you get the Send Link screen.  This does not happen if you access the Document Library via Site Contents...thus the issue is with the Document Library webpart's toolbar.  Anyone else seeing the same?

3 Replies

I get the same share dialogue for both which I imagine is by design as they both contain the Copy Link button. This makes sense to me as you need to build the share link by adding users and specifying scope at this stage prior to hitting Copy Link - iysim ?

 

Ian

 

Hi Ian,

 

Thanks for your reply.  This still doesn't make sense to me.  Why would the "Copy Link" button give you a "Copy Link" pop-up when the document library is accessed from Site Contents, but the "Copy Link" button give you a "Send Link" pop-up when using the Document Library webpart's toolbar (viewing the EXACT same library)?  You should get what you click on and not have two differing behaviors when there's no rhyme or reason for it.

 

This differing behavior occurs on communication sites that have unique/limited security as well as those that have already been shared with all associates in my organization. 

 

 

Cheers,

LP

Ah ok, I'm seeing that also. Apologies, was away for a while so just getting back to this. You essentially get the full "Share" Dialogue in the webpart rather than the simpler "Copy Link" dialogue from the full library view

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
Edge insider Dev bypasses IE mode website list
HotCakeX in Enterprise on
4 Replies