Home

Missing teams channels in Flow step

Highlighted
DataFailure
New Contributor

I'm building a Flow that uses the 'Post a message (Preview)' step and when I select the channel drop down not all of the channels of that team are appearing in the list. The account I am using to build the Flow is a dedicated account for running Flows used by my team, this dedicated account is also one of the owners of Teams. 

 

I've tried to use the 'enter custom value' option in the channel drop down and have pasted in the URL taken from the 'get link to channel' menu in teams - but this has not worked either. In a different Flow I built two days ago that also uses the 'Post a message (Preview)' step one of the channel names has turned into an alphanumeric string ending in @thread.skype and that Flow is now failing at this step. 

 

Weirdly, if I use my personal account, rather than the dedicated account to try and create a Flow that uses the 'Post a message (Preview)' step all the channels appear for the Teams that I'm looking for. Both accounts are owners in Teams.  

 

All the flows are constructed in an identical manner. The issue seems to be around the dedicated account but I'm at a loss for what it could be or how to fix it. Does anyone have any ideas as how to make the missing channel appear, or have you run into a similar issue?

 

*Edited to include more information. 

 

 

 

1 Reply
Only thing I can think of is log in as that user into Teams. Make sure you visit and maybe even make sure the channel is “show” in channel list. Then go back and Check. I’m going to assuming this is a larger team and you aren’t selecting a team with the same name that maybe one account is in and not the other and vise versa ?
Related Conversations
RSAT Download
Calvin Wong in Windows Server Insiders on
10 Replies
Filtering Button missing
Reddiplex Admin in Outlook Customer Manager on
2 Replies
MS Forms for Quiz missing field and buttons
Kirill Karmi in Microsoft Forms on
10 Replies