Home

Camera Roll Sync only runs for a short time

Highlighted
Ivan Wilson
Contributor

I've enabled Camera Roll Sync to my OneDrive for Business account from my iPhone two weeks ago. In that time it has uploaded 1,300 photos which looks like 50% of the total.

 

I've noticed that the sync runs while my phone is unlocked and the app open, but stops syncing once the phone locks or another app is open. The behavior is the same regardless of whether the phone is plugged in or not. 

 

This behavior is probably fine once the initial load is complete, but it makes it difficult to complete the initial load. Is there an option to allow sync to continue in the background even when the phone is locked?

 

I've changed my phone settings to never unlock and have left the app open to try to get everything synced. This seems to be working, but it would be nice if there was an option to allow OneDrive for Business to sync even if the phone is locked. 

 

 

11 Replies

Which OS? iOS has an option to sync in the background but requires location services to always be running etc. But this should also work for photo sync as well when you enable it. 

iOS 12.0.1. OneDrive is configured to always allow location access.

Assume you have upload in background turned on in the OneDrive camera upload settings?
This feature has been a little on/off for me Sometimes it works fluently and other times it starts uploading As soon as I enter the app..and all settings were all the same
I’ve purposely turn that off to preserve battery so wouldn’t know lol. But if it’s on and not working shake your phone and put in a feedback / bug report!
Yup! Done that a few times :)

Are you using this with 365 business account as the camera upload is still cannot be enabled from business.  When I am logged into personal is works with no issues at all.  

I’m currently using this on my business account! I have not yet experience on any issues but it seems to work well! On my personal I had some issues now and then as described earlier
Interesting and glad you have it working in business. I think many of our staff would use it if we had it enabled. Maybe there is some other admin setting in our 365 account that needs to be set.
Need to make sure the app is up to date and under Settings > Camera Upload, should be the option to be enabled. Pretty sure this is 100% rolled out.
Yes, I do believe it is! I Do use it with the test pilot program so can’t be sure