Home

Outlook on the Web loading wrong display names - Office365

%3CLINGO-SUB%20id%3D%22lingo-sub-267771%22%20slang%3D%22en-US%22%3EOutlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267771%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3EWeird%20issue%20we're%20experiencing%20in%20our%20organization.%20OWA%20seems%20to%20display%20former%20employee%20name%20whenever%20i%20select%20the%20destination%20email%2Fname%20on%20the%20auto%20completion%20list.%20Now%2C%20on%20the%20auto%20completion%20list%20i'm%20seeing%20the%20correct%20name%2C%20it%20only%20changes%20to%20the%20wrong%20display%20name%20after%20after%20selecting%20it.%20Everything's%20correct%20when%20i%20double%20click%20the%20name%20for%20more%20details%20and%20emails%20sent%20will%20go%20to%20the%20right%20mailbox%20as%20well.%20It's%20only%20the%20display%20name%20that's%20incorrect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-267771%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDisplay%20Name%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOutlook%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOWA%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-356440%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-356440%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20had%20the%20exact%20same%20problem.%26nbsp%3B%20It%20happens%20with%20me%20using%20Outlook%20on%20my%20desktop.%26nbsp%3B%20It%20has%20happened%20with%20three%20people%20I%20have%20sent%20emails%20to%20in%20the%20past%20year.%26nbsp%3B%20I%20will%20type%20in%20the%20email%20address%20I%20want%20to%20send%20it%20to.%26nbsp%3B%20Not%20auto%20loaded%2C%20but%20actually%20typing%20the%20full%20email.%26nbsp%3B%20That%20email%20address%20shows%20up%20in%20the%20To%3A%20box%20just%20fine.%26nbsp%3B%20I%20hit%20send%20and%20it%20sends%20it%20to%20another%20email%20address%20for%20that%20person.%26nbsp%3B%20I%20see%20this%20because%20I%20go%20to%20my%20sent%20folder%20and%20I%20see%20it%20was%20sent%20to%20their%20other%20email%20address%20and%20not%20the%20one%20I%20typed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20extremely%20frustrating.%26nbsp%3B%20I%20have%20had%20to%20go%20in%20and%20delete%20all%20their%20email%20addresses%20from%20their%20contact%20information%20and%20retype%20the%20email%20addresses.%26nbsp%3B%20That%20sometimes%20fixes%20the%20problem%20but%20then%20the%20problem%20will%20occur%20again%20with%20another%20person.%26nbsp%3B%20This%20is%20a%20major%20problem%20that%20Microsoft%20needs%20to%20resolve.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-287265%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-287265%22%20slang%3D%22en-US%22%3E%3CP%3EHaving%20exactly%20the%20same%20issues.%26nbsp%3B%20Running%20suggested%20PS%20fix%20did%20not%20work%20for%20us%20either.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-275194%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-275194%22%20slang%3D%22en-US%22%3E%3CP%3EStill%20facing%20this%20issue...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-269142%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-269142%22%20slang%3D%22en-US%22%3E%3CP%3EYes%20indeed.%20Any%20other%20suggestions%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-268774%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-268774%22%20slang%3D%22en-US%22%3E%3CP%3EI%20wasn't%20sure%20it%20will%20work%2C%20but%20I%20thought%20it%20might.%20Anyway%2C%20if%20it%20was%20going%20to%20work%2C%20only%20logging%20off%20from%20OWA%20and%20logging%20back%20in%20should%20have%20been%20enough%2C%20no%20waiting%20time%20needed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-268772%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-268772%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20doesn't%20seem%20to%20work%20as%20it%20still%20display%20old%20names...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-268743%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-268743%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20just%20ran%20the%20commands%2C%20display%20names%20are%20still%20showing%20old%20employee%20names.%20Maybe%20it'll%20take%20some%20time%20before%20it%20takes%20effect%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-267850%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267850%22%20slang%3D%22en-US%22%3E%3CP%3ERun%20this%20in%20PowerShell%20and%20then%20start%20OWA%3A%3C%2FP%3E%0A%3CP%3E%3CFONT%3ERemove-MailboxUserConfiguration%20-Mailbox%20%3CAFFECTED_MBX%3E%20-Identity%20Configuration%5CIPM.Configuration.OWA.UserOptions%3C%2FAFFECTED_MBX%3E%3C%2FFONT%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CFONT%3ELet%20us%20know%20if%20it%20worked.%3C%2FFONT%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-267845%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267845%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20already%20tried%20that%2C%20it%20displays%20correctly%20for%20a%20moment%20then%20back%20at%20it%20again%20with%20the%20former%20employee%20name.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-267831%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267831%22%20slang%3D%22en-US%22%3ETry%20some%20of%20the%20things%20and%20see%20if%20that%20helps%20you%3F%20Please%20post%20back%20and%20let%20me%20know!!%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.lifewire.com%2Fdelete-address-from-auto-list-outlook-1173778%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.lifewire.com%2Fdelete-address-from-auto-list-outlook-1173778%3C%2FA%3E%3CBR%20%2F%3EFor%20deleting%20all%20in%20owa%20-%20go%20to%20the%20people%20tile%20in%20office%20365%20and%20then%20suggested%20contacts%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-267830%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20on%20the%20Web%20loading%20wrong%20display%20names%20-%20Office365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-267830%22%20slang%3D%22en-US%22%3ETry%20some%20of%20the%20things%20and%20see%20if%20that%20helps%20you%3F%20Please%20post%20back%20and%20let%20me%20know!!%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.lifewire.com%2Fdelete-address-from-auto-list-outlook-1173778%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.lifewire.com%2Fdelete-address-from-auto-list-outlook-1173778%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E
Highlighted
Zakaria DERDER
Occasional Contributor

Hello,

Weird issue we're experiencing in our organization. OWA seems to display former employee name whenever i select the destination email/name on the auto completion list. Now, on the auto completion list i'm seeing the correct name, it only changes to the wrong display name after after selecting it. Everything's correct when i double click the name for more details and emails sent will go to the right mailbox as well. It's only the display name that's incorrect.

 

 

Cheers.

11 Replies
Try some of the things and see if that helps you? Please post back and let me know!!
https://www.lifewire.com/delete-address-from-auto-list-outlook-1173778

Adam
Try some of the things and see if that helps you? Please post back and let me know!!
https://www.lifewire.com/delete-address-from-auto-list-outlook-1173778
For deleting all in owa - go to the people tile in office 365 and then suggested contacts

Adam

I've already tried that, it displays correctly for a moment then back at it again with the former employee name.

Run this in PowerShell and then start OWA:

Remove-MailboxUserConfiguration -Mailbox <affected_mbx> -Identity Configuration\IPM.Configuration.OWA.UserOptions

 

Let us know if it worked.

 

Hello,

 

I just ran the commands, display names are still showing old employee names. Maybe it'll take some time before it takes effect?

It doesn't seem to work as it still display old names...

I wasn't sure it will work, but I thought it might. Anyway, if it was going to work, only logging off from OWA and logging back in should have been enough, no waiting time needed.

Yes indeed. Any other suggestions?

Still facing this issue...

Having exactly the same issues.  Running suggested PS fix did not work for us either.

I have had the exact same problem.  It happens with me using Outlook on my desktop.  It has happened with three people I have sent emails to in the past year.  I will type in the email address I want to send it to.  Not auto loaded, but actually typing the full email.  That email address shows up in the To: box just fine.  I hit send and it sends it to another email address for that person.  I see this because I go to my sent folder and I see it was sent to their other email address and not the one I typed.

 

This is extremely frustrating.  I have had to go in and delete all their email addresses from their contact information and retype the email addresses.  That sometimes fixes the problem but then the problem will occur again with another person.  This is a major problem that Microsoft needs to resolve.

Related Conversations
Does share calendar option works for shared calendar?
Carlos Gomez in Outlook on
10 Replies
Lost delete icon on mailbox list
Omar Armas in Outlook on
2 Replies
Save As / Export Email (msg file) in OWA
Michael T. DePouw Spottedmahn in Outlook on
4 Replies
Outlook contact to Android contact list
Deleted in Outlook on
14 Replies