SOLVED
Home

Modern experience stopped working today (7th March 2018)

Highlighted
Skanda Ramana Suryanarayana
Contributor

Modern experience stopped working today (7th March 2018)

Dear All,

 

As of today morning, we have started to face issues on a lot of document libraries on our tenant that make use of the modern experience.

We have classic sites created that make use of the modern experience and they have been working fine for a very long time now (1.5 years +)until today morning.

When we try to open the library today - in the modern experience we see either a ice cream  / flat tyre / rocket / bicycle with the message "something went wrong". However when we switch to classic view it works fine.  This is happening even on libraries that have 1 or 2 documents in them.

Our setup consists of Content type hub which has 4 major document content types which is pushed to all site collections & their doc libraries.

The content type has 15 Managed metadata columns, 4 single line of text, 2 date and time, The library adds 3 other columns like created by, modified by and document checked out to so the library has a total of 21 columns.

All the default views of the library have only 3 to 4 columns configured but inspite of this the library does not open in modern experience.

The only way has been to either switch to classic experience which works fine or remove the content types from the library which also works however this is not something we want to do.

 

We have opened a MSFT ticket and the support engineer has sent a link this -https://blogs.msdn.microsoft.com/spses/2013/12/02/sharepoint-20102013-list-view-lookup-threshold-unc... - the explanation is that we cant have more that 10 columns of lookup type in a content type even though the view shows less than 4 columns.

This does not make sense, all of this was working fine until yesterday so obviously something has changed today / yesterday night which has caused this.

 

The tenant I'm referring to is hosted in the Amsterdam data centre.

Have any of you seen this before?

 

 

17 Replies

Re: Modern experience stopped working today (7th March 2018)

Well, if this is a problem of the new experience (seems so) there is nothing we can do....only expect the team gets notified about the problem and fixes it accordingly. Tagging here @Lincoln DeMaris @Chris McNulty

Re: Modern experience stopped working today (7th March 2018)

Thank you for bringing this to my attention.  There have been no intentional changes recently in how lookup throttling is applied.  If this is a regression, and if this is modern-only, there is something strange going on that we'd like to understand.  I'd like to get an engineer on my end to chat with the support folks that diagnosed this.  Please connect the folks on this case with me over email and we'll take a look.  Please note that I am not guaranteeing that I'll be able to bring this to a satisfying resolution.  

Re: Modern experience stopped working today (7th March 2018)

We are having the same issue with content types. They work/open when you use the NEW drop-down in classic experience but in modern, you see "Something went wrong message".

Re: Modern experience stopped working today (7th March 2018)

@Lincoln DeMaris it seems we are not alone. was the team able to find anything based on the fiddler trace and also the live library to which access was provided?

Re: Modern experience stopped working today (7th March 2018)

We are working on it.  No need to ping us for updates, we'll get back to you when we have more.

Re: Modern experience stopped working today (7th March 2018)

Dan, that doesn't sound good.  Are you working with support on this?

Re: Modern experience stopped working today (7th March 2018)

Here's the situation for us and what I found after some troubleshooting.


We have 3 content types (word template, excel template, and powerpoint template) that are able to be selected from the Library New button/icon. All of the content types work properly only when IE 11 is in compatibility mode and the library is in Classic Experience mode. When we are in compatibility mode and the library is in modern mode, only the excel and word content types launch properly - the PPT type throw errors like "this action cannot be performed because Office doesn't recognize the command that was given"  Finally, when not in compatibility mode, both Excel and PPT types have the same error mentioned in the previous sentence and the Word content type attempts to create generic document but then throw an error like: Sorry, something went wrong cannot create file.

Re: Modern experience stopped working today (7th March 2018)

Dan, do you have an open support case on this already?

 

Please send me the details on that over private message.

Re: Modern experience stopped working today (7th March 2018)

updating this for the benefit of others, as of today early morning, partial functionality has been restored -

a) The document libraries open now with the modern experience like they used to before 

b) We face the same error if we click on "Files that need attention"

 

will update the thread once I have more details

Re: Modern experience stopped working today (7th March 2018)

Okay, so today, only the .potx content type does not work in Modern Mode. All other content types seem to be working in Classic and Modern without Compatibility. In classic mode the .potx content type opens up in PowerPoint (application) which is what is expected. In Modern mode I receive this message:

Do you want to open this file?

Program: Microsoft PowerPoint

Address: https://[our 365 root]/sites/PMO/Doc.aspx?sourcedoc=https://[our 365 root]/sites/[company]/Shared Documents/Corporate_Template.potx&action=edit&mobileredirect=true&RootFolder=/sites/PMO/Shared Documents

 

Anyway, the Address information above is abnormal to me. I've never seen this previously. Usually, the Address: part of it would say: https://[our 365 root]/sites/[company]/Shared Documents/Corporate_Template.potx without all that other stuff. And, that other stuff is not displayed for the Address information when the word or excel content types are used.

Solution

Re: Modern experience stopped working today (7th March 2018)

Glad to hear it - we have made a fix, glad it's working for you.  We're working on the issue inside attention views now.

Re: Modern experience stopped working today (7th March 2018)

Please open a support case, and let me know through private message if you're having difficulty finding a resolution.  This might need a product team fix as well.

Re: Modern experience stopped working today (7th March 2018)

Please provide a link to open a support case.

 

Further testing: It seems that when we open a site in classic view (default setting is classic) the content types are attempting to launch in MSFT Online (web browser) version and not the client application. The server setting and library settings are set to use the client application. So, all content types should open in the Office Application that is applicable. When a new document (content type Word template) is selected the online "create document - enter file name" dialog box is displayed. If you enter a file name, and click OK an "unknown" error occurs.

 

However, if I visit another site and create a new document (same content type source), it magically works as expected.

 

If I close the tab for the site that originally did not work and re-open the same site/library the new document from the content type that did not work before now also works! Not sure what is happening there.

 

Re: Modern experience stopped working today (7th March 2018)

Re: Modern experience stopped working today (7th March 2018)

More troubleshooting revealed that the IE Add-in SharePoint OpenDocuments Class is NOT loaded in IE 11. Apparently, in Classic Experience this add-in needs to be loaded to create a new document in the native Office Application rather than in the browser. It doesn't need to be loaded in Modern Experience EXCEPT to create a new file based on the PowerPoint template. 

 

Most posts suggest running a repair of Office. I've tried that 3 times so far and that hasn't worked. Will keep digging. Our Helpdesk provider will open a ticket with MSFT. 

Re: Modern experience stopped working today (7th March 2018)

@Vesa Juvonen would be great to see some documentation around number of columns that can be created in a list / library. 

Re: Modern experience stopped working today (7th March 2018)

Would recommend checking the column recommendations from the official software boundaries article at https://docs.microsoft.com/en-us/sharepoint/install/software-boundaries-and-limits.

Related Conversations
Company Logo looks terrible on Modern Site Pages
Anonymous in SharePoint on
24 Replies
Alerts on Comments in Modern Pages?
Rob Bowman in SharePoint on
45 Replies
Most Modern Webparts just crashed
Matt Coats in SharePoint on
22 Replies
Modern sites - news webpart limitations
Ian Hislop in SharePoint on
10 Replies