Home

List all the videos on a channel returns a 403

%3CLINGO-SUB%20id%3D%22lingo-sub-334317%22%20slang%3D%22en-US%22%3EList%20all%20the%20videos%20on%20a%20channel%20returns%20a%20403%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-334317%22%20slang%3D%22en-US%22%3E%3CP%3EI%20successfully%20retrieved%20a%20SharePoint%20token%20for%20my%20application%20after%20registering%20it%20with%20ACS%20(%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Ffr-fr%2Fsharepoint%2Fdev%2Fsolution-guidance%2Fsecurity-apponly-azureacs%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Ffr-fr%2Fsharepoint%2Fdev%2Fsolution-guidance%2Fsecurity-apponly-azureacs%3C%2FA%3E).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20query%20the%20Office%20Video%20API%20with%20this%20token%20I%20get%20a%20successful%20answer%20for%20the%20route%20%22%2Fportals%2Fhub%2F_api%2FVideoService%2FChannels%22%20but%20a%20403%20for%20the%20route%20%22%2Fportals%2Fhub%2F_api%2FVideoService%2FChannels%20%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20try%20by%20giving%20full%20control%20to%20my%20application%20on%20the%20Office%20Video%20site%20collection%20but%20that%20does%20not%20work%20either.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-334317%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%20Video%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
TechWatching
New Contributor

I successfully retrieved a SharePoint token for my application after registering it with ACS (https://docs.microsoft.com/fr-fr/sharepoint/dev/solution-guidance/security-apponly-azureacs).

 

When I query the Office Video API with this token I get a successful answer for the route "/portals/hub/_api/VideoService/Channels" but a 403 for the route "/portals/hub/_api/VideoService/Channels ".

 

I try by giving full control to my application on the Office Video site collection but that does not work either.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies