Home

Users will not show when starting "New chat" in MS Teams

%3CLINGO-SUB%20id%3D%22lingo-sub-323861%22%20slang%3D%22en-US%22%3EUsers%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323861%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20want%20to%20start%20a%20new%20chat%20with%20a%20user%2C%20the%20user%20will%20not%20show%20after%20I%20start%20to%20type%20the%20users%20name%20in%20the%20%22new%20chat%22%20field.%20This%20is%20true%20with%20all%20versions%20of%20teams.%20If%20I%20use%20%22who%22%2C%20the%20user%20is%20found%2C%20and%20thereafter%20on%20that%20client%2C%20the%20user%20will%20show%20in%20the%20%22new%20chat%22-field.%20The%20problem%20is%20the%20same%2C%20when%20adding%20users%20to%20a%20team.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-323861%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-332578%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-332578%22%20slang%3D%22en-US%22%3Emaybe%20the%20problem%20was%20resolved%20centrally%20by%20Microsoft%20at%20the%20same%20time%20you%20did%20your%20thing%3F%20Since%20I%20did%20nothing%2C%20and%20I%20was%20%22fixed%22.%20Well%20I%20guess%20we%20only%20will%20be%20able%20to%20speculate.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-332573%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-332573%22%20slang%3D%22en-US%22%3EUpdate%2C%20I%20talked%20to%20on%20of%20our%20o365%20admins%2C%20he%20said%20that%20there%20was%20an%20issue%20with%20this%2C%20some%20central%20error.%20It%20is%20now%20supposed%20to%20be%20fixed.%20I%20am%20sorry%20that%20I%20did%20not%20get%20a%20clear%20answer%20to%20why%20this%20was.%20But%20me%20and%20my%20users%20are%20happy%20that%20we%20now%20find%20our%20users.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-332518%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-332518%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20had%20this%20very%20annoying%20issue%20also.%26nbsp%3B%20However%2C%20we%20then%20created%20an%20%22Organizational%20Group%22%20which%20automatically%20adds%20all%20domain%20users.%26nbsp%3B%20Just%20by%20me%20doing%20this%2C%20users%20now%20have%20no%20issues%20searching%20for%20users.%26nbsp%3B%20So%20it%20seems%20there%20is%20some%20sort%20of%20caching%20mechanism%20not%20working%20correctly%20in%20Teams.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-Jason%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-327858%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-327858%22%20slang%3D%22en-US%22%3Eshort%20update%3A%20have%20not%20got%20the%20attention%20from%20out%20o365-admin%2C%20yet.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323992%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323992%22%20slang%3D%22en-US%22%3ENice%20catch!!%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323991%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323991%22%20slang%3D%22en-US%22%3EYeah%2C%20I%20looked%20at%20it%2C%20the%20setting%20is%20%22ON%22%2C%20I%20will%20talk%20to%20my%20admins%2C%20and%20report%20here%2C%20when%20I%20get%20respons%20from%20them.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323989%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323989%22%20slang%3D%22en-US%22%3EYou%20should%20be%20able%20to%20confirm%20this%20in%20part%20also%20by%20looking%20in%20the%20Skype%20and%20Teams%20admin%20centre%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fteams-scoped-directory-search%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fteams-scoped-directory-search%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ESwitching%20it%20off%20could%20resolve%20it%20in%20itself.%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323978%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323978%22%20slang%3D%22en-US%22%3E%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323977%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323977%22%20slang%3D%22en-US%22%3EIn%20that%20case%20you%20found%20a%20fishy%20workaround%20finding%20them%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323974%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323974%22%20slang%3D%22en-US%22%3ESaw%20this(see%20below)%20in%20another%20thread%2C%20might%20be%20relevant.%20I%20will%20speak%20to%20our%20admins%2C%20maybe%20they%20did%20turn%20on%20ABP.%3CBR%20%2F%3E%3CBR%20%2F%3ETeams%20is%20simply%20not%20designed%20for%20such%20scenario.%20While%20we%20do%20have%20some%20options%20to%20%22hide%22%20information%20in%20Azure%20AD%2C%20none%20of%20them%20applies%20to%20Teams.%20Best%20you%20can%20do%20is%20configure%20GAL%20segregation%2C%20which%20similar%20to%20how%20it%20work%20in%20Exchange%20will%20%22hide%22%20user%20objects%20as%20a%20whole%2C%20if%20you%20toggle%20the%20%22Scope%20directory%20search%20in%20Teams%20using%20an%20Exchange%20address%20book%20policy%20(ABP)%22%20setting.%20But%20this%20hides%20the%20entire%20object%2C%20not%20just%20some%20attribute.%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3EYou%20German%20folks%20should%20really%20raise%20this%20with%20your%20local%20Microsoft%20representatives.%20And%20maybe%20put%20it%20on%20UserVoice%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323944%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323944%22%20slang%3D%22en-US%22%3Enow%2C%20with%20English%20UI%2C%20the%20message%20I%20get%20might%20be%20useful%20%22We%20didn't%20find%20any%20matches.%20Talk%20to%20your%20IT%20admin%20about%20expanding%20the%20scope%20of%20your%20search.%22%20-%20maybe%20someone%20has%20changed%20a%20setting%20in%20out%20tenant%2C%20I%20might%20be%20a%20performance%20reason%20to%20something%20like%20that.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323935%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323935%22%20slang%3D%22en-US%22%3EI%20changed%20ui%20language%20to.%20English%20(uk)%20then%20I%20can%20use%20%2Forg%2C%20but%20it%20does%20not%20give%20me%20the%20users%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323928%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323928%22%20slang%3D%22en-US%22%3E%3CP%3EThat%20thread%20is%20answered%20by%20using%20the%20%22new%20chat%22%20instead%20of%20the%20search%20field.%20I%20use%20the%20%22new%20chat%22.%20When%20I%20use%20%2Fwho%2C%20it%20will%20always%20find%20the%20user.%20And%20I%20have%20to%20click%20on%20that%20user%20to%20get%20the%20user%20%22searchable%22.%20Not%20a%20big%20problem%20for%20me%2C%20but%20a%20pain%20for%20teachers%20when%20creating%20Teams%2C%20they%20are%20not%20able%20to%20pick%20users%2C%20without%20the%20work%20of%20%22%2Fwho%22%20for%20each%20user%20they%20want%20to%20add%20in%20the%20team.%20I%20do%20not%20see%20the%20%22%2Forg%22%2C%20is%20it%20a%20%22bot%22%2C%20like%20%22%2Fwho%22%3F.%20Maybe%20I%20do%20not%20see%20because%20I%20use%20Teams%20in%20my%20native%20language%20(Norwegian)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323920%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323920%22%20slang%3D%22en-US%22%3EI%20use%20%22new%20chat%22%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323886%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323886%22%20slang%3D%22en-US%22%3EOr%20instead%20of%20reading%20my%20previous%20post%20click%20that%20link%20Chris%20gave%20you%20%3Aface_with_tears_of_joy%3A%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323882%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323882%22%20slang%3D%22en-US%22%3EAre%20you%20clicking%20the%20new%20chat%20button%20above%20the%20contact%20list%20and%20not%20the%20search%20bar%3F%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-323876%22%20slang%3D%22en-US%22%3ERe%3A%20Users%20will%20not%20show%20when%20starting%20%22New%20chat%22%20in%20MS%20Teams%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-323876%22%20slang%3D%22en-US%22%3EHi!%3CBR%20%2F%3E%3CBR%20%2F%3EAlso%20shown%20in%20this%20thread%20too%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FMicrosoft-Teams%2FSome-users-are-unable-to-see-other-users-in-Microsoft-Teams%2Ftd-p%2F228973%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FMicrosoft-Teams%2FSome-users-are-unable-to-see-other-users-in-Microsoft-Teams%2Ftd-p%2F228973%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EApparent%20%2Forg%20user%20in%20the%20search%20is%20another%20workaround%20for%20this.%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E
Jarle Osmund Vågen
Occasional Contributor

When I want to start a new chat with a user, the user will not show after I start to type the users name in the "new chat" field. This is true with all versions of teams. If I use "who", the user is found, and thereafter on that client, the user will show in the "new chat"-field. The problem is the same, when adding users to a team.

17 Replies
Hi!

Also shown in this thread too

https://techcommunity.microsoft.com/t5/Microsoft-Teams/Some-users-are-unable-to-see-other-users-in-M...

Apparent /org user in the search is another workaround for this.

Best, Chris
Are you clicking the new chat button above the contact list and not the search bar??
Or instead of reading my previous post click that link Chris gave you :face_with_tears_of_joy:

That thread is answered by using the "new chat" instead of the search field. I use the "new chat". When I use /who, it will always find the user. And I have to click on that user to get the user "searchable". Not a big problem for me, but a pain for teachers when creating Teams, they are not able to pick users, without the work of "/who" for each user they want to add in the team. I do not see the "/org", is it a "bot", like "/who"?. Maybe I do not see because I use Teams in my native language (Norwegian)

I changed ui language to. English (uk) then I can use /org, but it does not give me the users
now, with English UI, the message I get might be useful "We didn't find any matches. Talk to your IT admin about expanding the scope of your search." - maybe someone has changed a setting in out tenant, I might be a performance reason to something like that.
Saw this(see below) in another thread, might be relevant. I will speak to our admins, maybe they did turn on ABP.

Teams is simply not designed for such scenario. While we do have some options to "hide" information in Azure AD, none of them applies to Teams. Best you can do is configure GAL segregation, which similar to how it work in Exchange will "hide" user objects as a whole, if you toggle the "Scope directory search in Teams using an Exchange address book policy (ABP)" setting. But this hides the entire object, not just some attribute.



You German folks should really raise this with your local Microsoft representatives. And maybe put it on UserVoice :)
In that case you found a fishy workaround finding them
You should be able to confirm this in part also by looking in the Skype and Teams admin centre

https://docs.microsoft.com/en-us/microsoftteams/teams-scoped-directory-search

Switching it off could resolve it in itself.

Best, Chris
Yeah, I looked at it, the setting is "ON", I will talk to my admins, and report here, when I get respons from them.
short update: have not got the attention from out o365-admin, yet.

We had this very annoying issue also.  However, we then created an "Organizational Group" which automatically adds all domain users.  Just by me doing this, users now have no issues searching for users.  So it seems there is some sort of caching mechanism not working correctly in Teams.  

 

-Jason

Update, I talked to on of our o365 admins, he said that there was an issue with this, some central error. It is now supposed to be fixed. I am sorry that I did not get a clear answer to why this was. But me and my users are happy that we now find our users.
maybe the problem was resolved centrally by Microsoft at the same time you did your thing? Since I did nothing, and I was "fixed". Well I guess we only will be able to speculate.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies