Home

User Photos not updating

%3CLINGO-SUB%20id%3D%22lingo-sub-96499%22%20slang%3D%22en-US%22%3EUser%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96499%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%20I'm%20having%20users%20update%20their%20photos%20and%20they%20aren't%20showing%20up%20for%20other%20users%2C%20they%20are%20propgating%20throughout%20365%20but%20Teams%20still%20doesn't%20show%20them.%20I%20opened%20up%20my%20Teams%20client%20on%20a%20laptop%20I%20haven't%20used%20in%20a%20bit%20and%20it%20updated%20the%20photos.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20how%20long%20it%20takes%20Teams%20to%20update%20these%20photos%3F%20Obviously%20it's%20cached%20somewhere%2C%20and%20curious%20to%20what%20that%20pulls%20from%2C%20what%20the%20timer%20is%20and%20can%20you%20manually%20tell%20Teams%20to%20refresh%20this%20photo%20cache%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-96499%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150306%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150306%22%20slang%3D%22en-US%22%3Eyeah%20i%20was%20just%20about%20to%20tell%20you%20to%20restart%20it%20so%20it%20updates%20cache.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150303%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150303%22%20slang%3D%22en-US%22%3EFixed%20it!%20Logged%20out%20of%20the%20Teams%20client%20and%20logged%20back%20in.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150295%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150295%22%20slang%3D%22en-US%22%3EMy%20photo%20is%20working%2C%20but%20it%20does%20not%20show%20the%20photo%20of%20one%20of%20the%20other%20users%20on%20my%20team.%20They%20added%20the%20photo%20over%20a%20week%20ago%2C%20it%20does%20show%20up%20for%20me%20in%20Outlook%20and%20in%20Skype.%20It%20does%20show%20his%20correct%20photo%20in%20the%20web%20version%20of%20Teams%20but%20not%20in%20my%20Android%20or%20PC%20client.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150292%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150292%22%20slang%3D%22en-US%22%3Eif%20you%20update%20your%20photo%20on%20prem%2C%20it%20will%20sync%20to%20all%20365%20services%20including%20Teams%2C%20it%20just%20takes%20like%20a%20week%20to%20propagate.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-150288%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-150288%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20issue%20here%20as%20well.%20Is%20there%20a%20known%20fix%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-97292%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-97292%22%20slang%3D%22en-US%22%3E%3CP%3Eyeah%2C%20my%20Teams%20on%20laptop%20is%20getting%20photos%20but%20not%20my%20desktop%20Teams.%20Not%20sure%20what%20causes%20it%20to%20update.%20Still%20trying%20to%20figure%20that%20out.%20Something%20up%20with%20the%20client%20itself%20not%20rendering%20them%20or%20updating%20cache.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-97041%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-97041%22%20slang%3D%22en-US%22%3E%3CP%3EActually%20I%20stand%20corrected.%20I%20changed%20my%20photo%20in%20the%20Teams%20app%20yesterday%20and%20it%20is%20now%20visible%20in%20Office%20365%2FYammer%20etc.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96674%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96674%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20pretty%20sure%20the%20MS%20Teams%20profile%20photo%20isn't%20connected%20to%20O365%20at%20this%20time.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-754377%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-754377%22%20slang%3D%22en-US%22%3E%3CP%3ETeams%20doesn't%20want%20to%20log%20out%20here%20%E2%80%A6%20%3A(%3C%2Fimg%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20stays%20on%20the%20loading%20screen%20forever%20%E2%80%A6%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-816771%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-816771%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F875%22%20target%3D%22_blank%22%3E%40Christopher%20Webb%3C%2FA%3E%26nbsp%3Btwo%20years%20later%20and%20still%20major%20issues%20with%20profil%20photo%20syncing.%20Several%20users%20have%20new%20profile%20photos%2C%20which%20show%20in%20the%20Teams%20web%20app%2C%20but%20not%20in%20the%20desktop%20Teams%20app%20-%20after%20several%20days.%26nbsp%3B%20I%20have%20restarted%20my%20computer%20a%20few%20times%2C%20no%20change.%20We%20are%20having%20similar%20issues%20in%20SharePoint%2C%20so%20I%20can%20only%20assume%20that%20the%20entire%20profile%20photo%20handling%20in%20Office%20365%20is%20mostly%20broken.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-834176%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-834176%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F54636%22%20target%3D%22_blank%22%3E%40Ian%20Caldwell%2C%20MSc%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%20we%20are%20also%20affected.%20This%20is%20really%20annoying!%3C%2FP%3E%3CP%3EAny%20solution%2C%20dear%20Microsoft%20Teams%20team%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-836986%22%20slang%3D%22en-US%22%3ERe%3A%20User%20Photos%20not%20updating%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-836986%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F875%22%20target%3D%22_blank%22%3E%40Christopher%20Webb%3C%2FA%3E%26nbsp%3Bhave%20a%20look%20on%20this%20thread%3A%26nbsp%3B%3CA%20title%3D%22Office%20365%20Profile%20picture%20not%20displayed%20inside%20SharePoint%20People%20Web%20Part%20on%20Modern%20Site%20Page%22%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint%2FOffice-365-Profile-picture-not-displayed-inside-SharePoint%2Fm-p%2F297608%22%20target%3D%22_self%22%3EOffice%20365%20Profile%20picture%20not%20displayed%20inside%20SharePoint%20People%20Web%20Part%20on%20Modern%20Site%20Page.%26nbsp%3B%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Deleted
Not applicable

Hi all, I'm having users update their photos and they aren't showing up for other users, they are propgating throughout 365 but Teams still doesn't show them. I opened up my Teams client on a laptop I haven't used in a bit and it updated the photos. 

 

Does anyone know how long it takes Teams to update these photos? Obviously it's cached somewhere, and curious to what that pulls from, what the timer is and can you manually tell Teams to refresh this photo cache? 

 

Thanks!

12 Replies

I'm pretty sure the MS Teams profile photo isn't connected to O365 at this time.

Actually I stand corrected. I changed my photo in the Teams app yesterday and it is now visible in Office 365/Yammer etc.

yeah, my Teams on laptop is getting photos but not my desktop Teams. Not sure what causes it to update. Still trying to figure that out. Something up with the client itself not rendering them or updating cache. 

I am having the same issue here as well. Is there a known fix? 

if you update your photo on prem, it will sync to all 365 services including Teams, it just takes like a week to propagate.
My photo is working, but it does not show the photo of one of the other users on my team. They added the photo over a week ago, it does show up for me in Outlook and in Skype. It does show his correct photo in the web version of Teams but not in my Android or PC client.
Fixed it! Logged out of the Teams client and logged back in.
yeah i was just about to tell you to restart it so it updates cache.

Teams doesn't want to log out here … :( 

It stays on the loading screen forever …

@Deleted two years later and still major issues with profil photo syncing. Several users have new profile photos, which show in the Teams web app, but not in the desktop Teams app - after several days.  I have restarted my computer a few times, no change. We are having similar issues in SharePoint, so I can only assume that the entire profile photo handling in Office 365 is mostly broken.

Highlighted

@Ian Caldwell, MSc 

Hi, we are also affected. This is really annoying!

Any solution, dear Microsoft Teams team?

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
*Updated 9/3* Syncing in Microsoft Edge Preview Channels
Elliot Kirk in Articles on
222 Replies