SOLVED
Home

Updating Microsoft Teams Rooms manually

%3CLINGO-SUB%20id%3D%22lingo-sub-726037%22%20slang%3D%22en-US%22%3EUpdating%20Microsoft%20Teams%20Rooms%20manually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-726037%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20the%20first%20time%20I%20am%20trying%20to%20update%20our%20Microsoft%20Teams%20Rooms%20VC%20units%2C%20and%20I%20am%20using%20the%20deployment%20package%20MSI.%20We%20have%20the%20Windows%20Store%20disabled%20in%20our%20organization.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20the%20PowerShell%20command%20that%20was%20included%20on%20a%20Microsoft%20support%20webpage%2C%20but%20it%20doesn't%20seem%20to%20work.%26nbsp%3B%3C%2FP%3E%3CP%3EAdd-AppxPackage%20-Update%20-ForceApplicationShutdown%20-Path%20%22%24PSScriptRoot%5C*.appx%22%20-DependencyPath%20(Get-ChildItem%20%22%24PSScriptRoot%5CDependencies%5Cx64%5C*.appx%22%20%7C%20Foreach-Object%20%7B%24_.FullName%7D)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20get%20the%20following%20error%3A%3C%2FP%3E%3CP%3EAdd-AppxPackage%20%3A%20Deployment%20failed%20with%20HRESULT%3A%200x80073D19%2C%20An%20error%20occurred%20because%20a%20user%20was%20logged%20off.%3CBR%20%2F%3EWindows%20cannot%20update%20package%20Microsoft.SkypeRoomSystem_4.0.85.0_x64__8wekyb3d8bbwe%20because%20the%20previous%20version%20is%3CBR%20%2F%3Enot%20installed.%20Install%20package%20Microsoft.SkypeRoomSystem_4.0.85.0_x64__8wekyb3d8bbwe%20instead%20of%20updating%20it.%3CBR%20%2F%3ENOTE%3A%20For%20additional%20information%2C%20look%20for%20%5BActivityId%5D%2049d95327-2d18-0000-c4f3-d949182dd501%20in%20the%20Event%20Log%20or%20use%3CBR%20%2F%3Ethe%20command%20line%20Get-AppxLog%20-ActivityID%2049d95327-2d18-0000-c4f3-d949182dd501%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBut%20if%20I%20remove%20the%20-update%20parameter%2C%20then%20it%20works%20fine.%20But%20I%20still%20see%20the%20old%20and%20new%20version%20installed%20under%20C%3A%5CProgram%20Files%5CWindowsApps%5C%20so%20I%20am%20guessing%20that%20isn't%20right.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20anyone%20provide%20some%20guidance%20to%20what%20might%20be%20wrong%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-726037%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%20Rooms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMTR%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESkype%20Room%20Systems%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESRSv2%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-726049%22%20slang%3D%22en-US%22%3ERe%3A%20Updating%20Microsoft%20Teams%20Rooms%20manually%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-726049%22%20slang%3D%22en-US%22%3E%3CP%3Eaaaaaaand%20if%20you%20wait%20long%20enough%2C%20the%20old%20version%20disappears.%20Is%20it%20that%20simple%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Richard Eklund
Occasional Contributor

Hello,

 

For the first time I am trying to update our Microsoft Teams Rooms VC units, and I am using the deployment package MSI. We have the Windows Store disabled in our organization.

 

I am using the PowerShell command that was included on a Microsoft support webpage, but it doesn't seem to work. 

Add-AppxPackage -Update -ForceApplicationShutdown -Path "$PSScriptRoot\*.appx" -DependencyPath (Get-ChildItem "$PSScriptRoot\Dependencies\x64\*.appx" | Foreach-Object {$_.FullName})

 

I get the following error:

Add-AppxPackage : Deployment failed with HRESULT: 0x80073D19, An error occurred because a user was logged off.
Windows cannot update package Microsoft.SkypeRoomSystem_4.0.85.0_x64__8wekyb3d8bbwe because the previous version is
not installed. Install package Microsoft.SkypeRoomSystem_4.0.85.0_x64__8wekyb3d8bbwe instead of updating it.
NOTE: For additional information, look for [ActivityId] 49d95327-2d18-0000-c4f3-d949182dd501 in the Event Log or use
the command line Get-AppxLog -ActivityID 49d95327-2d18-0000-c4f3-d949182dd501

 

But if I remove the -update parameter, then it works fine. But I still see the old and new version installed under C:\Program Files\WindowsApps\ so I am guessing that isn't right.

 

Can anyone provide some guidance to what might be wrong?

 

Thank you!

1 Reply
Solution

aaaaaaand if you wait long enough, the old version disappears. Is it that simple?

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
14 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
23 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies