Unable to List channels with Graph API

Occasional Contributor



I am trying to list channels with Graph API by sending
`GET{id}/channels` (`GET{id}/channels` does not work as well).

The response is:

"error": {
"code": "BadRequest",
"message": "Failed to execute Skype backend request GetThreadS2SRequest.",
"innerError": {
"request-id": "74635040-5d24-4399-9954-2c15643db862",
"date": "2019-03-04T13:20:37"

At the same time `GET` works well. I have tried to create a new team and pass its id, but the result is the same. Is this MS issue or something wrong with my setup/request?



10 Replies

How do you insert the id?

Thank you for your reply.

I take it from the `` response and put it to next call: ``. I am using postman.


It looks like this is definitely not an id issue: I am able to get messages with `` (I have copied channel id from the web application). I am wondering are there any limitations for the free version of MS Teams or something like this.

UP. Still facing this issue.


Can you Please go to GraphExplorer add the Teams Category and login with your Office 365 Credentials. Try the Channels of a Team which I am a member of.  which eventually is{ID}/channels. I tested just now it works fine... 

I am doing this on an E3...The Graph explorer can help you see if the API is working for your id. 

Thank you for your reply. I have signed in with the same credentials (to graph-explorer and I do have some teams, but GET returns me

"error": {
"code": "ResourceNotFound",
"message": "Resource not found.",
"innerError": {
"request-id": "75aba59f-1b7b-4edb-b923-ca4cca4f4dbe",
"date": "2019-03-07T21:39:10"


Please ignore my previous reply. I found the reason on SO why I am getting 404. Trying to resolve it.

Thanks. It turns out to be a problem with my account: it was some old account and when I logged in with it to Graph Explorer I realized that some request does not work as expected.

I have created a new account and sign into Microsoft developer program. Everything works fine now.

@Maruthi Gadde 


I'm having the same issue. I can't create another account.

I go to the graph-explorer link you give, use the Channels of a Team which I am a member of, and I get the same respone.

"error": {
"code": "AccessDenied",
"message": "Failed to execute Skype backend request GetThreadRequest.",
"innerError": {
"request-id": "870a5389-4f23-44d7-86aa-6d198dd59751",
"date": "2019-06-21T06:14:03"


I do have the Group.Read.All and Group.ReadWrite.All both as application and delegated permission.

Related Conversations