SOLVED
Home

Teams messages going to Skype for Business

%3CLINGO-SUB%20id%3D%22lingo-sub-567311%22%20slang%3D%22en-US%22%3ETeams%20messages%20going%20to%20Skype%20for%20Business%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-567311%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20a%20unique%20problem.%20We%20prefer%20Teams%20and%20had%20Teams%20Update%20in%20islands%20mode.%20As%20far%20as%20I%20can%20tell%2C%20we%20are%20very%20rare%20as%20all%20documentation%20is%20around%20supporting%20orgs%20who%20prefer%20SfB%20over%20Teams%2C%20not%20vice%20versa.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20External%20user%20A%20sends%20our%20user%20B%20a%20message%20from%20their%20Teams%20client.%3C%2FP%3E%3CP%3E2.%20User%20B%20receives%20the%20message%20on%20Skype%20for%20Business%20(strange%2C%20is%20this%20expected%3F)%3C%2FP%3E%3CP%3E3.%20To%20try%20to%20combat%20this%2C%20we%20changed%20to%20Teams%20only.%3C%2FP%3E%3CP%3E4.%20User%20A%20sends%20user%20B%20another%20Teams%20message.%20The%20message%20isn't%20received%20on%20user%20B's%20Teams.%20I%20suspect%20that%20it's%20still%20going%20to%20SfB.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20how%20to%20fix%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-567311%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Emessaging%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESkype%20for%20Business%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETeams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-567957%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20messages%20going%20to%20Skype%20for%20Business%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-567957%22%20slang%3D%22en-US%22%3EYes%2C%20this%20is%20expected!%20If%20an%20external%20users%20sends%20a%20message%20to%20a%20user%20in%20islands%20mode%2C%20it%E2%80%99s%20always%20going%20to%20Skype!%3CBR%20%2F%3E%3CBR%20%2F%3EYou%20did%20right%20setting%20him%20to%20teams-only%20but%20it%20can%20take%20time%20to%20propagate!%20Give%20it%20time%2C%20also%20there%20are%20cache%20issues!%20Both%20do%20a%20full%20logout%20%2F%20login%20of%20the%20teams%20clients%3CBR%20%2F%3E%3CBR%20%2F%3EWhen%20did%20you%20set%20the%20user%20to%20teams-only%3F%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-567962%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20messages%20going%20to%20Skype%20for%20Business%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-567962%22%20slang%3D%22en-US%22%3EThanks%20Adam.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20made%20the%20change%20about%2010%20hours%20ago%2C%20I'm%20hoping%20that's%20enough%20time.%20A%20full%20logout%20and%20in%20was%20done%2C%20but%20no%20change%20in%20result.%3CBR%20%2F%3E%3CBR%20%2F%3EOne%20thing%20to%20note%20is%20that%20on%20user%20A's%20(external)%20Teams%2C%20it%20shows%20user%20B's%20presence%20as%20offline.%20I%20suspect%20it's%20looking%20at%20SfB%20presence.%20For%20user%20B%2C%20user%20A's%20presence%20is%20online.%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20also%20had%20user%20A%20send%20to%20other%20of%20our%20users%2C%20and%20still%20same%20result%20which%20is%20nothing%20now%20(since%20we%20can%20no%20longer%20log%20into%20SfB).%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-567963%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20messages%20going%20to%20Skype%20for%20Business%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-567963%22%20slang%3D%22en-US%22%3EIt%20can%20take%20days%20afaik%20%3A%5C%3C%2Fimg%3E%3CBR%20%2F%3E%3CBR%20%2F%3EMS%20is%20aware%20of%20these%20propagation%20and%20cache%20issues%20and%20are%20working%20on%20making%20this%20more%20efficient%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-567965%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20messages%20going%20to%20Skype%20for%20Business%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-567965%22%20slang%3D%22en-US%22%3EDid%20you%20set%20all%20organization%20to%20teams%20-%20only%3F%3F%3CBR%20%2F%3E%3CBR%20%2F%3EYou%20can%20do%20this%20per%20user%20basis%20too!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-568008%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20messages%20going%20to%20Skype%20for%20Business%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-568008%22%20slang%3D%22en-US%22%3EAh%2C%20okay%2C%20it%20looks%20like%20it's%20working.%20I%20had%20to%20ask%20the%20sender%20(external)%20to%20logout%20and%20back%20in%20to%20Teams%20as%20well.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-568024%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20messages%20going%20to%20Skype%20for%20Business%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-568024%22%20slang%3D%22en-US%22%3EGreat!%20If%20all%20is%20well%20please%20set%20as%20best%20response%20too!%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E
Simon_L
Contributor

Hi all,

 

We have a unique problem. We prefer Teams and had Teams Update in islands mode. As far as I can tell, we are very rare as all documentation is around supporting orgs who prefer SfB over Teams, not vice versa.

 

1. External user A sends our user B a message from their Teams client.

2. User B receives the message on Skype for Business (strange, is this expected?)

3. To try to combat this, we changed to Teams only.

4. User A sends user B another Teams message. The message isn't received on user B's Teams. I suspect that it's still going to SfB.

 

Does anyone know how to fix this issue?

6 Replies
Solution
Yes, this is expected! If an external users sends a message to a user in islands mode, it’s always going to Skype!

You did right setting him to teams-only but it can take time to propagate! Give it time, also there are cache issues! Both do a full logout / login of the teams clients

When did you set the user to teams-only?

Adam
Thanks Adam.

I made the change about 10 hours ago, I'm hoping that's enough time. A full logout and in was done, but no change in result.

One thing to note is that on user A's (external) Teams, it shows user B's presence as offline. I suspect it's looking at SfB presence. For user B, user A's presence is online.

I've also had user A send to other of our users, and still same result which is nothing now (since we can no longer log into SfB).
It can take days afaik :\

MS is aware of these propagation and cache issues and are working on making this more efficient
Did you set all organization to teams - only??

You can do this per user basis too!
Ah, okay, it looks like it's working. I had to ask the sender (external) to logout and back in to Teams as well.
Great! If all is well please set as best response too!

Adam