SOLVED
Home

Teams URL links not clickable

%3CLINGO-SUB%20id%3D%22lingo-sub-896511%22%20slang%3D%22en-US%22%3ETeams%20URL%20links%20not%20clickable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-896511%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20am%20having%20an%20issue%20with%20a%20users%20Laptop%20where%20in%20Teams%20when%20they%20receive%20a%20message%20with%20a%20URL%20link%20and%20the%20link%20isn't%20clickable%20and%20open%20a%20web%20browser%2C%20However%20when%20you%20send%20the%20same%20message%20gets%20sent%20to%20another%20user%20the%20link%20works%20fine.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20on%20a%20HP%20laptop%20running%20Windows%2010%20using%20the%20Chrome%20browser%20as%20default.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20fixed%20this%20twice%20before%20by%20reinstalling%20Teams%20but%20I%20don't%20want%20to%20have%20to%20keep%20doing%20this.%20Does%20anyone%20have%20any%20ideas%20that%20can%20help%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-896511%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-896555%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20URL%20links%20not%20clickable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-896555%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F421191%22%20target%3D%22_blank%22%3E%40richard1991%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3ESounds%20bizarre%20considering%20it's%20working%20elsewhere.%20Could%20I%20ask%3CBR%20%2F%3E%3CBR%20%2F%3E1.)%20Does%20it%20work%20in%20the%20users%20web%20(teams.microsoft.com)%2Fmobile%20client%3F%3CBR%20%2F%3E2.)%20Does%20it%20work%20by%20simply%20cleaning%2Fre-pasting%20the%20link%3F%3CBR%20%2F%3E3.)%20Does%20it%20work%20by%20textpadding%20the%20link%20then%20copy%20pasting%20it%20to%20Teams%3F%3CBR%20%2F%3E4.)%20Is%20the%20link%20a%20'simple'%20link%20such%20as%20'%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.microsoft.com%3C%2FA%3E'%20or%20it%20is%20copied%20and%20pasted%20off%20something%20like%20YouTube%20with%20a%20long%20URL%3F%3CBR%20%2F%3E%3CBR%20%2F%3EWould%20be%20interested%20to%20know%20more%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-896566%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20URL%20links%20not%20clickable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-896566%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20the%20reply.%20It%20has%20had%20me%20stumped!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3CSPAN%3E1.)%20Does%20it%20work%20in%20the%20users%20web%20(teams.microsoft.com)%2Fmobile%20client%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3EIt%20does%20work%20in%20the%20web%20browser.%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSPAN%3E2.)%20Does%20it%20work%20by%20simply%20cleaning%2Fre-pasting%20the%20link%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3Enot%20sure%20what%20you%20mean%20by%20this%3F%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSPAN%3E3.)%20Does%20it%20work%20by%20textpadding%20the%20link%20then%20copy%20pasting%20it%20to%20Teams%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3EOr%20this%20sorry.%20The%20user%20can%20copy%20and%20past%20the%20link%20in%20the%20web%20browser%20and%20it%20will%20work%20fine.%3C%2FSTRONG%3E%3CBR%20%2F%3E%3CSPAN%3E4.)%20Is%20the%20link%20a%20'simple'%20link%20such%20as%20'%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fwww.microsoft.com%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.microsoft.com%3C%2FA%3E%3CSPAN%3E'%20or%20it%20is%20copied%20and%20pasted%20off%20something%20like%20YouTube%20with%20a%20long%20URL%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3EIts%20nomally%20a%20long%20URL.%20However%20when%20I%20did%20a%20test%20send%20of%20a%20simple%20%3CA%20href%3D%22http%3A%2F%2Fwww.google.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ewww.google.com%3C%2FA%3E%20the%20user%20still%20cant%20click%20it%20but%20shows%20as%20a%20link%20in%20the%20messages%20still!%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EThanks%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CSTRONG%3ERichard%3C%2FSTRONG%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-896571%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20URL%20links%20not%20clickable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-896571%22%20slang%3D%22en-US%22%3EHi%20Richard%2C%3CBR%20%2F%3E%3CBR%20%2F%3EThanks.%20If%20it%20is%20rendering%20as%20a%20link%20in%20the%20message%20I%20would%20ask%3CBR%20%2F%3E%3CBR%20%2F%3E1.)%20Does%20a%20simple%20log%20out%2Flog%20in%20work%3F%3CBR%20%2F%3E2.)%20Does%20a%20clearing%20of%20the%20cache%20work%20(%3CA%20href%3D%22https%3A%2F%2Fcommsverse.blog%2F2018%2F09%2F28%2Fclear-the-microsoft-teams-client-cache%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fcommsverse.blog%2F2018%2F09%2F28%2Fclear-the-microsoft-teams-client-cache%3C%2FA%3E)%3CBR%20%2F%3E%3CBR%20%2F%3EYou%20said%20a%20reinstall%20works%20-%20but%20as%20you%20said%20a%20reinstall%20isn't%20a%20good%20solution%20and%20can't%20be%20expected%20every%20time%20-%20neither%20is%20clearing%20the%20cache%20every%20time%20if%20that%20works.%20My%20feeling%20is%20that%20if%201%20and%202%20doesn't%20work%20then%20it%20would%20be%20a%20ticket%20to%20support.%20Links%20should%20work%20and%20be%20clickable%20every%20time%20it%20is%20core%20functionality%3CBR%20%2F%3E%3CBR%20%2F%3ELet%20me%20know%20how%20it%20goes%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-896608%22%20slang%3D%22en-US%22%3ERe%3A%20Teams%20URL%20links%20not%20clickable%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-896608%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20login%20and%20out%20didn't%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%20using%20the%20Powershell%20script%20and%20clearing%20the%20cache%20did%20the%20job.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20fear%20it%20may%20happen%20again%20but%20fingers%20crossed%20this%20permanently%20solves%20the%20issue!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20help%2C%20I%20appreciate%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWith%20regards%20to%20Microsoft%20support%2C%20do%20they%20charge%20for%20this%20or%20would%20they%20be%20willing%20to%20help%20if%20I%20needed%20to%20escalate%20this%20in%20the%20future%3F%20And%20how%20do%20we%20go%20about%20contacting%20them%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E
richard1991
Occasional Contributor

Hi,

I am having an issue with a users Laptop where in Teams when they receive a message with a URL link and the link isn't clickable and open a web browser, However when you send the same message gets sent to another user the link works fine.

 

This on a HP laptop running Windows 10 using the Chrome browser as default.

 

I have fixed this twice before by reinstalling Teams but I don't want to have to keep doing this. Does anyone have any ideas that can help?

 

Thanks in advance

 

4 Replies
Hi @richard1991

Sounds bizarre considering it's working elsewhere. Could I ask

1.) Does it work in the users web (teams.microsoft.com)/mobile client?
2.) Does it work by simply cleaning/re-pasting the link?
3.) Does it work by textpadding the link then copy pasting it to Teams?
4.) Is the link a 'simple' link such as 'https://www.microsoft.com' or it is copied and pasted off something like YouTube with a long URL?

Would be interested to know more

Best, Chris

Hi @Christopher Hoard

 

Thanks for the reply. It has had me stumped!

 

 1.) Does it work in the users web (teams.microsoft.com)/mobile client?

It does work in the web browser.
2.) Does it work by simply cleaning/re-pasting the link?

not sure what you mean by this?
3.) Does it work by textpadding the link then copy pasting it to Teams?

Or this sorry. The user can copy and past the link in the web browser and it will work fine.
4.) Is the link a 'simple' link such as 'https://www.microsoft.com' or it is copied and pasted off something like YouTube with a long URL?

Its nomally a long URL. However when I did a test send of a simple www.google.com the user still cant click it but shows as a link in the messages still!

 

Thanks

Richard

Solution
Hi Richard,

Thanks. If it is rendering as a link in the message I would ask

1.) Does a simple log out/log in work?
2.) Does a clearing of the cache work (https://commsverse.blog/2018/09/28/clear-the-microsoft-teams-client-cache)

You said a reinstall works - but as you said a reinstall isn't a good solution and can't be expected every time - neither is clearing the cache every time if that works. My feeling is that if 1 and 2 doesn't work then it would be a ticket to support. Links should work and be clickable every time it is core functionality

Let me know how it goes

Best, Chris

@Christopher Hoard 

 

The login and out didn't work.

 

However using the Powershell script and clearing the cache did the job.

 

I fear it may happen again but fingers crossed this permanently solves the issue! 

 

Thanks for your help, I appreciate it.

 

With regards to Microsoft support, do they charge for this or would they be willing to help if I needed to escalate this in the future? And how do we go about contacting them?

 

Thanks

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
33 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies