Teams Crashing on Mac OS Catalina Public Beta

Occasional Contributor

Anyone else noticing Teams crashing on Mac Catalina Public Beta? I noticed one other person post about the same behavior I'm seeing.

Loads for a bit and starts to show the screen, but then goes white and crashes, then tries to restart itself again. Curious if it's an OS or Teams issue, and how to get updates if Teams doesn't start.

30 Replies



I am experiencing the same problem. Interestingly, when I used Teams off the company network last night, I didn't have an issue. I attempted to replicate this morning on a hotspot and the issue returned.


When will MS update Teams for Catalina?

@michaelwblackotf Guys, you know this the first public beta of an OS only released to developers less than a month ago and not likely to ship for another 3 months, right?


This isn't a Teams issue (at least it isn't right now).   If this was mid-September and it was public beta 5 and the Teams client still crashed then there would be more cause for concern.

@Kevin Crossman You don't know if it's a Teams issue or not.

@andre-robitaille  Of course I don't.  But raising an issue of ANY app not working on BETA 1 of a brand new OS introduced to Developers less than a month ago is energy that is not well spent.


I'm sure the team at Microsoft who manage the Mac version of the Teams app are aware of the issue and will have a version of the app that works well with Catalina once it officially production launches in late September or October.

@Kevin Crossman Take it up with the Microsoft Twitter account for telling me to bring it here.

And if it is a Teams issue and not an OS issue, then it's worth bringing up. 

@andre-robitaille Was that a public reply? I'd be interested in seeing it.


Ok, let's say it IS a Teams issue. They are under no obligation to fix this until Catalina starts shipping in the fall. So, why complain now?

@Kevin Crossman I never complained. I pointed out an issue and asked if anyone else noticed it and if anyone knew if it was a Teams or OS issue. And now is the time to bring it up since the OS is in beta and it needs to be working before the OS releases.

You're really not contributing in any way and are overly argumentative.

@andre-robitaille Complaining about Discussing software that doesn't work on public beta OS releases (especially beta one) is not productive in this or any non-developer community, in my opinion.

@Kevin Crossman No one asked for your opinion about if my post was good enough to be here, but it's noted. Thanks.

@andre-robitaille Microsoft will be testing this as well, and I'm sure if they need to do anything then that will happen as the GA release becomes available. There's little point chasing round issues that may well change as the OS builds keep changing.

In the past there have been issues a number of times with updates on Apple devices that required Apple to fix them, rather than Microsoft, there's a lot of x.1 versions that allow key applications to work. 

I can tell you they are aware of the issue and probabaly working on it. Lots of us early adopters have already made them aware of the issue ;)

I'm noticing that if I'm just using my laptop it works fine. But when an external monitor is added, even if I close the laptop to make it a single screen external monitor, that's when it crashes for me.



that is interesting. I was able to use over the weekend on a non-work network just fine.



there is also a browser edition of teams that I am finding useful

@michaelwblackotf Calling and meeting features are less robust, but for chat it's decent.

Chrome now supports full audio and video, so really the only draw back of browser version is still calling.

@Chris Webb The single video versus 4-up video is a little annoying, but yes.

My Teams (on home Mac mini) started crash looping on me yesterday after working for the morning. It connects to my personal tenant. On Catalina v10.15 (19A501i).


My work MbP is running Mojave beta 10.14.6 (18G71a) and Teams is working fine. It connects to my work tenant.


Going to send the Teams logs to Microsoft and Apple. @andre-robitaille 

I think I figured this out, sort of. If you have tried to launch Teams via the Safari web browser you should get an error about blocking cross-site traffic being enabled. Unchecking that box and trying again did not work for me.


I tried again using MS Edge for Mac and got an error about having to enable 3rd party cookies. I did that in order to test it, and after enabling it, Teams now launches.


This must have something to do with the new security features built into Catalina and because Teams is not a signed application. @andre-robitaille 

Hi @mitch80132, that didn't work for me unfortunately - still in the crash after launch loop. Oddly Teams was working fine until this morning. However, I didn't realise MS has launched Edge on Mac (so thanks for that!!) -  it didn't prompt me about 3rd party cookies but the good news is that Teams Web App works fine on this Edge browser so at least I am back working (as on Chrome for Mac I was getting an error saying I could not make calls and needed to use a browser like Edge or... Chrome!!!).


Looking back at this thread, I cannot see the problem with posting about this issue here... we are a community just helping each other after all... As a Mac user for years, I've typically taken the beta OS and barring a few glitches, been ok. This time I feel there is a significant rewrite of the OS code and security framework and it has pretty much disabled my machine - not just Office apps but even Apple ones are crashing all the time. It's so bad I am going to roll-back. So I agree this is not a MS problem, but hey, it does no harm to post here - at least I know others are having the same problem as me and it may stop other users with Macs+Office doing the same dumb thing as me and upgrading to a beta load when they use it as their main machine - Doh!


On my machine I have isolated it down to being when a USB headset is plugged in or not plugged in.




Excellent work!

I’ve confirmed that’s the issue I’m having as well. Within seconds of plugging in my USB connector to my Plantronics headset, the white screen shows up and Teams crashes.

Confirmed the same. Sennheiser headset. @zigford 

@andre-robitaille I just read your post as I was having the exact same issue, pulled the plug on my Plantronics Headset and BOOM! Teams is running again. That is absolutely insane!

I publed the plug on my Sennheiser headset and everything is working fine.......very interesting

@michaelwblackotf and all, I would like to also confirm that I'm experiencing the same issue. I'm using a Plantronics Blackwire C320 with the latest version of the firmware.

@andre-robitaille so this was happening to be even on mojave - Removed headset - fixed!!!

@zigford The latest version of teams for Mac fixed the USB headset issue for me.  I'm running version 1.00.221868 and no problems with my Jabra USB headset.  On the previous version of teams, it crashed every time I plugged the headset it.

Just a heads-up, we do encourage people to post about their issues, bugs and questions here. It's not the most constructive feedback to just say someone's issue isn't valid. Thanks. 

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies