Home

Sharepoint page stops loading in Teams client Tab

%3CLINGO-SUB%20id%3D%22lingo-sub-236076%22%20slang%3D%22en-US%22%3ESharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-236076%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20noticed%20that%20when%20adding%20a%20Sharepoint%20page%20to%20a%20Team's%20tab%20the%20page%20eventually%20stops%20loading%20in%20the%20Teams%20client.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhile%20it%20displays%20beautifully%20when%20it%20is%20first%20added%2C%20it%20seems%20that%20once%20the%20client%20is%20closed%20and%20then%20reopened%20some%20time%20later%2C%20clicking%20on%20the%20same%20page%20tab%20simply%20presents%20a%20blank%20screen.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20loads%20correctly%20in%20the%20web%20version%20of%20Teams%20though.%20Anyone%20else%20experienced%20this%20or%20have%20a%20solution%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-236076%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-329395%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-329395%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%2C%20Chris!%20I've%20also%20noticed%20that%20if%20I%20have%20created%20one%20of%20the%20tabs%20as%20a%20Website%20link%20and%20it%20asks%20me%20each%20time%20to%20login%2C%20then%20if%20I%20choose%20%22Keep%20me%20signed%20in%22%20and%20%22don't%20show%20this%20again%22%20then%20it%20seems%20to%20persist%20beyond%20closing%20Teams%20and%20rebooting%20the%20computer.%20Additionally%20it%20appears%20to%20keep%20me%20logged%20in%20to%20the%20tabs%20that%20were%20created%20as%20Sharepoint%20Pages%20as%20well%2C%20since%20they%20no%20longer%20disappear%20each%20time.%20Might%20not%20be%20the%20case%20for%20everyone%20but%20something%20that%20seems%20to%20be%20working%20on%20my%20end.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-329181%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-329181%22%20slang%3D%22en-US%22%3EHi%20Chris%2C%3CBR%20%2F%3ECan%20you%20share%20some%20details%20about%20how%20your%20users%20access%20to%20Office%20365%3F%20I'm%20specifically%20thinking%20on%20things%20such%20as%20if%20you%20have%20ADFS%20deployed%2C%20if%20there%20are%20any%20restrictions%20applied%20to%20your%20corporate%20network%20and%20so%20on.%20What%20I%20can%20do%20here%20is%20to%20point%20the%20Team%20to%20this%20thread%2C%20but%20more%20information%20is%20required.%3CBR%20%2F%3E%3CBR%20%2F%3EThanks!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-329176%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-329176%22%20slang%3D%22en-US%22%3E%3CP%3EI%20posted%20this%20to%20the%20Teams%20feedback%20area%20in%20hopes%20that%20the%20Teams%20developers%20become%20aware%20of%20the%20problem.%26nbsp%3B%20Please%20upvote%20below%20if%20you%20have%20experienced%20this%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%2Fsuggestions%2F36706186-sharepoint-tabs-won-t-load%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmicrosoftteams.uservoice.com%2Fforums%2F555103-public%2Fsuggestions%2F36706186-sharepoint-tabs-won-t-load%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-329171%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-329171%22%20slang%3D%22en-US%22%3EKeep%20us%20posted!%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-329149%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-329149%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20this%20info.%26nbsp%3B%20I%20have%20been%20seeing%20similar%20things%2C%20but%20there%20isn't%20much%20consistency%20to%20when%20the%20problem%20occurs.%26nbsp%3B%20It%20is%20a%20significant%20problem%20that%20makes%20what%20could%20be%20great%20functionality%2C%20almost%20unusable.%26nbsp%3B%20I%20don't%20think%20Microsoft%20is%20currently%20aware%5Cinvestigating%20the%20problem.%26nbsp%3B%20I%20have%20also%20found%20that%20updating%20the%20settings%20of%20the%20tab%20will%20often%20bring%20the%20tab%20back%2C%20despite%20not%20being%20logged%20into%20the%20sharepoint%20website%20or%20office%20365.%26nbsp%3B%20I%20will%20try%20to%20raise%20a%20ticket%20with%20Microsoft.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325838%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325838%22%20slang%3D%22en-US%22%3EGreat!%20Let%20us%20know%20how%20it%20goes!!%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325821%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325821%22%20slang%3D%22en-US%22%3E%3CP%3EDear%20all%3C%2FP%3E%3CP%3EI%20want%20oty%20thank%20everyone%20who%20has%20replied%20to%20my%20original%20poost%20about%20this.%20I%20suseocted%20it%20had%20sometign%20to%20do%20with%20passing%20credentials%20arond%20but%20i%20am%20not%20technical%20enough%20to%20know%20the%20ins%20and%20outs.%20I%20must%20admit%20that%20i%20thought%20adding%20the%20site%20as%20a%20websute%20tab%20also%20produced%20the%20issue%20after%20a%20while%20but%20maybe%20i%20am%20mistaken%20or%20MS%20did%20make%20some%20change%20to%20at%20least%20allow%20this..%20I'll%20do%20as%20the%20suggestion%20and%20see%20if%20it%20holds%20until%20they%20can%20get%20his%20sorted.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325310%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325310%22%20slang%3D%22en-US%22%3EYeah!%20I%E2%80%99ll%20try%20to%20get%20more%20info%20on%20this!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325309%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325309%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20heads%20up%20about%20the%20website%20tab.%20It%20does%20work%20and%20does%20provide%20a%20login%20(both%20the%20standard%20O365%20and%20a%20purple%20ADFS%20one)%2C%20interestingly%20enough%20once%20logged%20in%20all%20the%20other%20SharePoint%20based%20tabs%20began%20working%20again%20too.%20Think%20you%20have%20a%20bug%20on%20your%20hands%20Microsoft%20as%20it%20does%20not%20appear%20that%20the%20users%20credentials%20are%20being%20passed%20along%20properly%20to%20SharePoint%20based%20tabs.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325224%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325224%22%20slang%3D%22en-US%22%3EI'll%20mention%20that%20to%20IT.%20Thanks!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325205%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325205%22%20slang%3D%22en-US%22%3EYes%20the%20website%20option%20works%20better%20usually!%20I%E2%80%99ve%20never%20had%20the%20login%20problem%20though%20or%20anyone%20else%20I%E2%80%99ve%20heard%20of!%20But%20it%20might%20have%20to%20do%20with%20if%20you%20have%20sso%20or%20not..%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325195%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325195%22%20slang%3D%22en-US%22%3E%3CP%3EI%20believe%20I%20may%20have%20figured%20out%20the%20reason%20as%20well%20as%20a%20possible%20work%20around.%20I%20ran%20into%20the%20same%20problem%20where%20the%20page%20would%20show%20and%20then%20the%20next%20day%20it%20would%20be%20blank%2C%20but%20then%20if%20I%20was%20playing%20around%20with%20other%20things%20sometimes%20it%20would%20come%20back%20again.%20I%20believe%20what%20is%20happening%20is%20you%20are%20being%20logged%20out%20of%20Sharepoint%20(as%20far%20as%20TEAMS%20is%20concerned)%20and%20then%20the%20Sharepoint%20Page%20is%20no%20longer%20showing%20because%20you%20don't%20have%20access.%20The%20workaround%20is%20to%20create%20the%20tab%20as%20a%20Website%20instead%20of%20a%20Sharepoint%20Page.%20You%20need%20to%20get%20the%20Link%20to%20the%20Sharepoint%20page%20you%20already%20created%20and%20use%20that%20link%20as%20the%20Website%20URL.%20It%20then%20shows%20the%20page%20in%20the%20tab%20just%20like%20when%20you%20create%20a%20Sharepoint%20page.%20The%20difference%20is%20that%20when%20you%20shutdown%20your%20computer%20or%20close%20Teams%20and%20it%20logs%20you%20out%20of%20Sharepoint%2C%20you'll%20get%20a%20login%20page%20within%20the%20Website%20Tab%20instead%20of%20just%20a%20blank%20screen.%20You'll%20need%20to%20log%20in%20again%20which%20is%20annoying%2C%20but%20at%20least%20it's%20intuitive%20for%20other%20team%20members%20and%20doesn't%20just%20look%20broken%20or%20missing.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20920px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F70858i928F442376BFD7AF%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%222019-01-24_13-48-43.jpg%22%20title%3D%222019-01-24_13-48-43.jpg%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EWebsite%20Tab%20linked%20to%20SharePoint%20Page%20-%20Login%20required%20to%20view%20page.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20some%20reason%20it%20doesn't%20matter%20if%20you%20are%20logged%20into%20Sharepoint%20through%20your%20web%20browser%20when%20you%20open%20Teams%2C%20nor%20does%20it%20matter%20if%20you%20log%20in%20and%20out%20on%20your%20web%20browser%20while%20Teams%20is%20open%20and%20then%20refresh.%20Instead%20there%20is%20some%20issue%20within%20the%20Teams%2FSharepoint%20connection%20that%20seems%20to%20be%20causing%20the%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBTW%2C%20during%20testing%20I%20noticed%20that%20logging%20into%20the%20Website%20Tab%20made%20my%20Sharepoint%20Page%20tabs%20all%20work%20again%2C%20which%20is%20why%20I%20believe%20it's%20a%20Teams%2FSharepoint%20connection%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHopefully%20this%20helps%20anyone%20who%20has%20been%20having%20this%20extremely%20frustrating%20problem%20until%20Microsoft%20can%20fix%20their%20bugs.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325047%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325047%22%20slang%3D%22en-US%22%3EThis%20is%20why%20I%20use%20the%20website%20tab%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325044%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325044%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20issue%20across%20all%20users%20who%20access%20via%20the%20MS%20Teams%20Desktop%20app.%20I%20have%20a%20SP%20Modern%20Page%20and%20an%20SP%20Modern%20List%20(no%20customization).%20The%20pages%20weren't%20working%20last%20week%2C%20then%20they%20worked%20for%20a%20few%20days%2C%20and%20now%20they%20aren't%20working%20again.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20the%20tabs%20work%20as%20expected%20when%20accessed%20via%20the%20Teams%20Online%20version.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298452%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298452%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20having%20the%20same%20issue.%20I%20hope%20MS%20is%20still%20working%20on%20a%20solution%20to%20this%20bug!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-286980%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-286980%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20experience%20inconsistent%20behavior%20with%20SharePoint%20team%20site%20pages%20added%20as%20tabs%20in%20the%20Teams%20app%2C%20including%20symptoms%20like%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-Pages%20sometimes%20won't%20load%20in%20Teams%20tab%2C%20only%20displaying%20a%20blank%20white%20screen.%3C%2FP%3E%3CP%3E-Hero%20web%20part%20links%20to%20PDF%20files%20in%20team%20site%20Documents%20will%20not%20load.%26nbsp%3B%20Click%20the%20tile%2C%20nothing%20happens.%20Other%20Hero%20tiles%20linked%20to%20other%20PDFs%20will%20load%20successfully.%3C%2FP%3E%3CP%3E-Adding%20a%20new%20tab%20and%20selecting%20SharePoint%20will%20sometimes%20fail%20to%20display%20any%20pages%2C%20libraries%20or%20lists%20to%20choose.%20The%20window%20gets%20stuck%20with%20a%20blank%20white%20screen.%3C%2FP%3E%3CP%3E-Clicking%20the%20icon%20to%20%22Go%20to%20website%22%20launches%20a%20browser%20page%20address%20that%20begins%20with%20%22%3CA%20href%3D%22https%3A%2F%2Fspoprod-a.akamaihd.net%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fspoprod-a.akamaihd.net%3C%2FA%3E%22%20and%20only%20displays%20a%20blank%20white%20screen.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EObservations%3A%3C%2FP%3E%3CP%3E-Failures%20happen%20in%20the%20Windows%20Teams%20Desktop%20App%20and%20Teams%20Online%20with%20Internet%20Explorer%2C%20but%20not%20in%20Teams%20Online%20with%20Chrome.%26nbsp%3B%20Using%20Teams%20in%20Chrome%20eliminates%20the%20failures.%26nbsp%3B%20The%20Teams%20Mobile%20app%20works%20fine%2C%20because%20it%20sends%20you%20to%20the%20device's%20default%20browser%20instead%20of%20trying%20to%20render%20pages%20within%20the%20Teams%20App.%3C%2FP%3E%3CP%3E-Different%20people%20in%20different%20Teams%20in%20different%20channels%20are%20affected.%26nbsp%3B%20Some%20days%20are%20better%20than%20others.%3C%2FP%3E%3CP%3E-The%20pages%20that%20won't%20load%20or%20have%20problem%20tile%20links%20are%20in%20the%20Modern%20format.%3C%2FP%3E%3CP%3E-We%20had%20some%20success%20shortening%20the%20Hero%20link%20URLs%20as%20suggested%20by%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F875%22%20target%3D%22_blank%22%3E%40Christopher%20Webb%3C%2FA%3E%26nbsp%3Bin%20this%20thread%3A%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FSharePoint%2FAbility-to-make-intrasite-page-on-Hero-Bar-open-in-new-tab%2Ftd-p%2F195943%22%20target%3D%22_self%22%3EHero%20Link%20Open%20in%20New%20Tab%3C%2FA%3E.%26nbsp%3B%20But%20not%20always.%3C%2FP%3E%3CP%3E-Have%20tried%20adding%20the%20Pages%20as%20Website%20and%20SharePoint%20tabs%20with%20no%20difference.%3C%2FP%3E%3CP%3E-Microsoft%20premier%20support%20thinks%20the%20problem%20is%20likely%20with%20our%20company's%20internal%20network%20and%2For%20firewall%20settings.%26nbsp%3B%20Our%20network%20team%20is%20skeptical.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDefinitely%20looking%20forward%20to%20any%20future%20improvements%20in%20this%20Teams%20feature.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-283381%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-283381%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F136494%22%20target%3D%22_blank%22%3E%40Hemat%20Maheshwari%3C%2FA%3E%26nbsp%3BI%20faced%20same%20issue%20in%20a%20customer's%20tenant.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F60%22%20target%3D%22_blank%22%3E%40Juan%20Carlos%20Gonz%C3%A1lez%20Mart%C3%ADn%3C%2FA%3E%26nbsp%3B%3A%20SPO%20Tab%2C%20Modern%20SPO%20Page%2C%20no%20customization%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Efrom%20MS%20%3A%20after%20analyzing%20correlation%20ID%2C%20issue%20seems%20to%20be%20with%20%22an%20connection%20error%20between%20Teams%20%26amp%3B%20SPO.%20Teams%20ask%20informations%20to%20SPO%20and%20SPO%20refuses%20with%20a%20network%20error%20related%20to%20network%20port%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStill%20analyzing%20on%20MS%20support%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20faced%20similar%20issue%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-281866%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-281866%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20experienced%20the%20similar%20issue%20-%20but%20it's%20limited%20to%20using%20Teams%20Web%20client%20on%20IE.%20It%20works%20fine%20while%20using%20Teams%20desktop%20client%20and%20web%20client%20on%20Edge%20and%20Chrome%20browser.%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20a%20support%20ticket%20open%20for%20last%20three%20months.%20It's%20been%20escalated%20to%20product%20team%20but%20no%20updates%20on%20resolution%20and%20no%20ETA.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%2C%3C%2FP%3E%3CP%3EH.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-281492%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-281492%22%20slang%3D%22en-US%22%3EI%E2%80%99ve%20seen%20it%20in%20multiple%20tenants..it%E2%80%99s%20not%20always%20but%20the%20experience%20is%20uneven.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-281491%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-281491%22%20slang%3D%22en-US%22%3ENot%20seeing%20this%20problem%20in%20my%20test%20tenant%2C%20so%20not%20sure%20if%20this%20is%20a%20general%20problem%20or%20a%20problem%20in%20your%20tenants%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-281481%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-281481%22%20slang%3D%22en-US%22%3EYeah%2C%20I%E2%80%99ve%20noticed%20this%20too!%20Pages%20have%20stopped%20loading%2C%20showing%20just%20a%20white%20screen%20one%20so%20on!%3CBR%20%2F%3EFeels%20better%20when%20you%20know%20they%20are%20working%20with%20doing%20a%20better%20experience%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-281471%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-281471%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20isn't%20just%20your%20experience%20that%20is%20broken%20-%20everyone%20in%20our%20tenant%20is%20experiencing%20the%20same%20thing.%3C%2FP%3E%3CP%3EAt%20one%20time%2C%20we%20could%20add%20a%20SharePoint%20Page%20-%20nothing%20custom%2C%20taken%20straight%20from%20a%20new%20news-feed%20page%20right%20from%20the%20SharePoint%20team%20site%20sitting%20underneath%20the%20Teams%20team.%3C%2FP%3E%3CP%3EBut%20now%2C%20we%20can%20no%20longer%20see%20that%20page%20in%20the%20tab%2C%20and%20we%20can%20no%20longer%20add%20a%20SharePoint%20news%20article%20or%20page%20using%20that%20one%20SharePoint%20add-a-tab%20icon.%3C%2FP%3E%3CP%3EAlso%2C%20Connector%20method%20is%20broken%2C%20too.%26nbsp%3B%20Can't%20specify%20which%20news%20article%20or%20page.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270356%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270356%22%20slang%3D%22en-US%22%3EOk!%20Tried%20without%20issues%3CBR%20%2F%3EPlease%20create%20a%20ticket%20with%20Microsoft!%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270351%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270351%22%20slang%3D%22en-US%22%3EOK%20thanks%2C%20I%20look%20forward%20to%20see%20that.%3CBR%20%2F%3E%3CBR%20%2F%3EI%20Try%20from%20the%20web%20version%20and%20my%20collegue%20too.%20Nothing%20work.%3CBR%20%2F%3EFor%20now%20the%20tab%20who%20doesn't%20work%2C%20we%20had%20a%20website%20(instead%20of%20Sharepoint%20pages).%3CBR%20%2F%3EToo%20bad%20for%20the%20adding%20elements...%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270347%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270347%22%20slang%3D%22en-US%22%3E%3CP%3EI%20believe%20it's%20Q1%20next%20year..I'll%20check%20up%20on%20that!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20you%20tried%20doing%20this%20from%20the%20web%3F%20Another%20user%2Fcomputer%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270346%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270346%22%20slang%3D%22en-US%22%3EYes%20I%20know%20this%20solution%20but%20we%20work%20in%20Teams%20and%20we%20want%20guys%20to%20stay%20on%20teams%20and%20don't%20go%20to%20sharepoint.%20This%20solution%20was%20working%20really%20fine%2C%20I%20would%20like%20to%20know%20why%20now%20pages%20doesn't%20work%20anymore%20(I%20can't%20even%20add%20a%20new%20one%20in%20tab).%3CBR%20%2F%3EAnd%20It's%20not%20the%20sharepoint%20connection%20because%20add%20a%20new%20tab%20with%20library%20add-on%20work%20fine...%20I%20have%20no%20clues...%3CBR%20%2F%3E%3CBR%20%2F%3EWhen%20the%20new%20%22Sharepoint%20Interface%22%20in%20Teams%20will%20be%20released%20%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270341%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270341%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20had%20trouble%20with%20this%20as%20well..If%20the%20page%20not%20showing%2C%20I%20need%20to%26nbsp%3Bbrowse%20the%20SharePoint%20site%20itself%20then%20it%20will%20load%20in%20Teams..%3C%2FP%3E%3CP%3EAlso%20there%20are%20webparts%20not%20working%20when%20the%20SP%20is%20added%20with%20the%20Sharepoint%20Tab%2C%20this%20was%20resolved%20by%20opening%20the%20site%20with%20the%20Web%20Tab%20instead%2C%20so%20try%20that!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHopefully%20this%20integration%20will%20be%20better%20when%20the%20new%20%22Sharepoint%20interface%22%20in%20Teams%20is%20released!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAdam%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-270338%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-270338%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESince%20one%20week%2C%20I%20have%20the%20same%20problem%20with%20Sharepoint%20pages.%26nbsp%3B%3C%2FP%3E%3CP%3EThey%20first%20work%20fine%20on%20TEAMS%20but%20by%20now%20I%20can%20read%20them%20(blank%20page%20or%20error%20message)%20but%20I%20also%20cann't%20add%20a%20new%20one%20!%20Same%20Error%20message%20%22A%20problem%20is%20going%20on%22%2C%20no%20precisions.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20try%20to%20abb%20Sharepoint%20Library%20it's%20working%20but%20for%20pages%20not.%20I%20don't%20know%20why...%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-237886%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-237886%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Juan%20Carlos%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank-you%20for%20the%20reply%20and%20your%20time.%3C%2FP%3E%3CP%3EI%20added%20the%20pages%20to%20the%20channels%20using%20the%20Sharepoint%20tab.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20pages%20I%20am%20adding%20are%20new%20pages%20to%20the%20best%20of%20my%20knowledge...i%20have%20only%20recently%20made%20them%20usign%20the%20new%20page-%20site%20page%20template%20provided%20-%20all%20web%20parts%20they%20use%20are%20standard%20eg%20file%20viewer%2C%20embed%2C%20text%20etc%3C%2FP%3E%3CP%3EThere%20arent%20any%20customizations%20that%20I%20am%20aware%20of....you%20can%20see%20the%20issue%20at%20this%20link...%3C%2FP%3E%3CP%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fbrisbanegrammarcom-my.sharepoint.com%2F%3Av%3A%2Fg%2Fpersonal%2Fgreg_dabelstein_brisbanegrammar_com%2FEdDqtd9uM-dEidPgjlAWbSYB3skJHMEjb9ZKoNi2g8vY3Q%3Fe%3DCldwUu%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fbrisbanegrammarcom-my.sharepoint.com%2F%3Av%3A%2Fg%2Fpersonal%2Fgreg_dabelstein_brisbanegrammar_com%2FEdDqtd9uM-dEidPgjlAWbSYB3skJHMEjb9ZKoNi2g8vY3Q%3Fe%3DCldwUu%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eregards%3C%2FP%3E%3CP%3EGreg%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-236151%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20page%20stops%20loading%20in%20Teams%20client%20Tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-236151%22%20slang%3D%22en-US%22%3EEy%20Greg%2C%3CBR%20%2F%3ESome%20questions%20here%20to%20narrow%20the%20issue%3A%3CBR%20%2F%3E(1)%20How%20did%20you%20add%20the%20page%20to%20the%20Team%3A%20using%20the%20SharePoint%20Tab%20or%20the%20Web%20one%3F%3CBR%20%2F%3E(2)%20The%20SPO%20page%20you%20are%20adding%3A%20is%20a%20modern%20SPO%20page%20or%20a%20classic%20one%3F%3CBR%20%2F%3E(3)%20What%20customizations%20do%20you%20have%20in%20the%20page%3F%3CBR%20%2F%3EIt%20might%20happen%20that%20something%20in%20the%20page%20is%20preventing%20it%20to%20be%20displayed%20properly%20in%20the%20Teams%20App%3C%2FLINGO-BODY%3E
Greg Dabelstein
Occasional Contributor

I have noticed that when adding a Sharepoint page to a Team's tab the page eventually stops loading in the Teams client.

 

While it displays beautifully when it is first added, it seems that once the client is closed and then reopened some time later, clicking on the same page tab simply presents a blank screen.

 

It loads correctly in the web version of Teams though. Anyone else experienced this or have a solution?

30 Replies
Ey Greg,
Some questions here to narrow the issue:
(1) How did you add the page to the Team: using the SharePoint Tab or the Web one?
(2) The SPO page you are adding: is a modern SPO page or a classic one?
(3) What customizations do you have in the page?
It might happen that something in the page is preventing it to be displayed properly in the Teams App

Hi Juan Carlos

 

Thank-you for the reply and your time.

I added the pages to the channels using the Sharepoint tab. 

The pages I am adding are new pages to the best of my knowledge...i have only recently made them usign the new page- site page template provided - all web parts they use are standard eg file viewer, embed, text etc

There arent any customizations that I am aware of....you can see the issue at this link...

 https://brisbanegrammarcom-my.sharepoint.com/:v:/g/personal/greg_dabelstein_brisbanegrammar_com/EdDq...

 

regards

Greg

Hello, 

 

Since one week, I have the same problem with Sharepoint pages. 

They first work fine on TEAMS but by now I can read them (blank page or error message) but I also cann't add a new one ! Same Error message "A problem is going on", no precisions. 

 

When I try to abb Sharepoint Library it's working but for pages not. I don't know why... 

I've had trouble with this as well..If the page not showing, I need to browse the SharePoint site itself then it will load in Teams..

Also there are webparts not working when the SP is added with the Sharepoint Tab, this was resolved by opening the site with the Web Tab instead, so try that!

 

Hopefully this integration will be better when the new "Sharepoint interface" in Teams is released!

 

Adam

Yes I know this solution but we work in Teams and we want guys to stay on teams and don't go to sharepoint. This solution was working really fine, I would like to know why now pages doesn't work anymore (I can't even add a new one in tab).
And It's not the sharepoint connection because add a new tab with library add-on work fine... I have no clues...

When the new "Sharepoint Interface" in Teams will be released ?

I believe it's Q1 next year..I'll check up on that!

 

Have you tried doing this from the web? Another user/computer?

OK thanks, I look forward to see that.

I Try from the web version and my collegue too. Nothing work.
For now the tab who doesn't work, we had a website (instead of Sharepoint pages).
Too bad for the adding elements...
Ok! Tried without issues
Please create a ticket with Microsoft!

Adam

It isn't just your experience that is broken - everyone in our tenant is experiencing the same thing.

At one time, we could add a SharePoint Page - nothing custom, taken straight from a new news-feed page right from the SharePoint team site sitting underneath the Teams team.

But now, we can no longer see that page in the tab, and we can no longer add a SharePoint news article or page using that one SharePoint add-a-tab icon.

Also, Connector method is broken, too.  Can't specify which news article or page.

Yeah, I’ve noticed this too! Pages have stopped loading, showing just a white screen one so on!
Feels better when you know they are working with doing a better experience
Not seeing this problem in my test tenant, so not sure if this is a general problem or a problem in your tenants
I’ve seen it in multiple tenants..it’s not always but the experience is uneven.

We have experienced the similar issue - but it's limited to using Teams Web client on IE. It works fine while using Teams desktop client and web client on Edge and Chrome browser. 

We have a support ticket open for last three months. It's been escalated to product team but no updates on resolution and no ETA.

 

Cheers,

H.

@Hemat Maheshwari I faced same issue in a customer's tenant.

 

@Juan Carlos González Martín : SPO Tab, Modern SPO Page, no customization

 

from MS : after analyzing correlation ID, issue seems to be with "an connection error between Teams & SPO. Teams ask informations to SPO and SPO refuses with a network error related to network port"

 

 

 

Still analyzing on MS support 

Anyone faced similar issue ?

Highlighted

We experience inconsistent behavior with SharePoint team site pages added as tabs in the Teams app, including symptoms like:

 

-Pages sometimes won't load in Teams tab, only displaying a blank white screen.

-Hero web part links to PDF files in team site Documents will not load.  Click the tile, nothing happens. Other Hero tiles linked to other PDFs will load successfully.

-Adding a new tab and selecting SharePoint will sometimes fail to display any pages, libraries or lists to choose. The window gets stuck with a blank white screen.

-Clicking the icon to "Go to website" launches a browser page address that begins with "https://spoprod-a.akamaihd.net" and only displays a blank white screen.

 

Observations:

-Failures happen in the Windows Teams Desktop App and Teams Online with Internet Explorer, but not in Teams Online with Chrome.  Using Teams in Chrome eliminates the failures.  The Teams Mobile app works fine, because it sends you to the device's default browser instead of trying to render pages within the Teams App.

-Different people in different Teams in different channels are affected.  Some days are better than others.

-The pages that won't load or have problem tile links are in the Modern format.

-We had some success shortening the Hero link URLs as suggested by @Deleted in this thread: Hero Link Open in New Tab.  But not always.

-Have tried adding the Pages as Website and SharePoint tabs with no difference.

-Microsoft premier support thinks the problem is likely with our company's internal network and/or firewall settings.  Our network team is skeptical.

 

Definitely looking forward to any future improvements in this Teams feature.

I am having the same issue. I hope MS is still working on a solution to this bug!

I am having the same issue across all users who access via the MS Teams Desktop app. I have a SP Modern Page and an SP Modern List (no customization). The pages weren't working last week, then they worked for a few days, and now they aren't working again.  

 

All the tabs work as expected when accessed via the Teams Online version. 

This is why I use the website tab :)

I believe I may have figured out the reason as well as a possible work around. I ran into the same problem where the page would show and then the next day it would be blank, but then if I was playing around with other things sometimes it would come back again. I believe what is happening is you are being logged out of Sharepoint (as far as TEAMS is concerned) and then the Sharepoint Page is no longer showing because you don't have access. The workaround is to create the tab as a Website instead of a Sharepoint Page. You need to get the Link to the Sharepoint page you already created and use that link as the Website URL. It then shows the page in the tab just like when you create a Sharepoint page. The difference is that when you shutdown your computer or close Teams and it logs you out of Sharepoint, you'll get a login page within the Website Tab instead of just a blank screen. You'll need to log in again which is annoying, but at least it's intuitive for other team members and doesn't just look broken or missing.


2019-01-24_13-48-43.jpgWebsite Tab linked to SharePoint Page - Login required to view page.

 

For some reason it doesn't matter if you are logged into Sharepoint through your web browser when you open Teams, nor does it matter if you log in and out on your web browser while Teams is open and then refresh. Instead there is some issue within the Teams/Sharepoint connection that seems to be causing the issue.

 

BTW, during testing I noticed that logging into the Website Tab made my Sharepoint Page tabs all work again, which is why I believe it's a Teams/Sharepoint connection issue.

 

Hopefully this helps anyone who has been having this extremely frustrating problem until Microsoft can fix their bugs.

Yes the website option works better usually! I’ve never had the login problem though or anyone else I’ve heard of! But it might have to do with if you have sso or not..
I'll mention that to IT. Thanks!

Thanks for the heads up about the website tab. It does work and does provide a login (both the standard O365 and a purple ADFS one), interestingly enough once logged in all the other SharePoint based tabs began working again too. Think you have a bug on your hands Microsoft as it does not appear that the users credentials are being passed along properly to SharePoint based tabs. 

Yeah! I’ll try to get more info on this!

Dear all

I want oty thank everyone who has replied to my original poost about this. I suseocted it had sometign to do with passing credentials arond but i am not technical enough to know the ins and outs. I must admit that i thought adding the site as a websute tab also produced the issue after a while but maybe i am mistaken or MS did make some change to at least allow this.. I'll do as the suggestion and see if it holds until they can get his sorted.

Great! Let us know how it goes!!

Adam

Thanks for this info.  I have been seeing similar things, but there isn't much consistency to when the problem occurs.  It is a significant problem that makes what could be great functionality, almost unusable.  I don't think Microsoft is currently aware\investigating the problem.  I have also found that updating the settings of the tab will often bring the tab back, despite not being logged into the sharepoint website or office 365.  I will try to raise a ticket with Microsoft.

Keep us posted!

Adam

I posted this to the Teams feedback area in hopes that the Teams developers become aware of the problem.  Please upvote below if you have experienced this problem.

 

https://microsoftteams.uservoice.com/forums/555103-public/suggestions/36706186-sharepoint-tabs-won-t...

Hi Chris,
Can you share some details about how your users access to Office 365? I'm specifically thinking on things such as if you have ADFS deployed, if there are any restrictions applied to your corporate network and so on. What I can do here is to point the Team to this thread, but more information is required.

Thanks!

Thanks, Chris! I've also noticed that if I have created one of the tabs as a Website link and it asks me each time to login, then if I choose "Keep me signed in" and "don't show this again" then it seems to persist beyond closing Teams and rebooting the computer. Additionally it appears to keep me logged in to the tabs that were created as Sharepoint Pages as well, since they no longer disappear each time. Might not be the case for everyone but something that seems to be working on my end.

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies