Home

Remove redirection login teams to an STS

%3CLINGO-SUB%20id%3D%22lingo-sub-179415%22%20slang%3D%22en-US%22%3ERemove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-179415%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3BI%20recently%20stopped%20working%20for%20a%20company%20where%20I%20used%20Teams.%20I%20have%20now%20a%20new%20own%20O365%20E5%20licenses%20active%20but%20when%20I%20try%20to%20start%20teams%20my%20login%20is%20getting%20redirected%20to%20the%20STS%20page%20of%20the%20previous%20company%20I%20worked%20for%2C%20how%20can%20I%20remove%20this%20redirection%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3BI%20have%26nbsp%3Bno%20problem%20to%20login%20the%20Office%20365%20starting%20page%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fwww.office.com%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.office.com%2F%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3BAny%20help%20is%20welcome%3C%2FP%3E%0A%3CP%3E%26nbsp%3BThanks%2C%20in%20advanced.%3C%2FP%3E%0A%3CP%3E%26nbsp%3BRGDS%20Eric%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-179415%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ELogin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EO365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-302822%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-302822%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%20-%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20a%20%2B1%20for%20this%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUsed%20to%20work%20for%20a%20365%20organisation%2C%20now%20work%20for%20a%20different%20365%20organisation%2C%20have%20my%20own%20365%20subscription%20too.%26nbsp%3B%20Throughout%20the%20above%20I've%20used%20a%20Surface%20Pro%2C%20so%20accounts%20are%20interweaved%20there%20too.%26nbsp%3B%20Very%20wary%20of%20deleting%20the%20wrong%20profile%2Fdata.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20deleted%20all%20of%20the%20web%20credentials%20for%20my%20old%20organisation%20in%20the%20Windows%20credentials%20manager%20(Start%20%26gt%3B%20search%20%22Credentials%22%20%26gt%3B%20Credentials%20Manager%20-%20pick%20and%20Remove%20obviously%20'old%20org'%20credentials.%26nbsp%3B%20Can't%20see%20anything%20keyed%20on%20%22Teams%22).%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20use%20both%20Chrome%20and%20Edge.%26nbsp%3B%20I've%20deleted%20all%20cookies%20in%20Chrome%20for%20old%20organisation.%26nbsp%3B%20Can't%20find%20anything%20in%20Edge%20to%20delete.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20thick-client%20app%20on%20my%20Surface%20works%20fine%20-%20new%20organisation%2C%20it's%20the%20web%20client%20which%20always%20goes%20to%20old%20organisation.%20%26nbsp%3B%20when%20I'm%20on%20the%20Office%20365%20%22Home%22%20for%20my%20new%20organisation%20all%20of%20the%20365%20apps%20seem%20to%20work%20ok%20in%20browser%2C%20except%20Teams%20which%20keeps%20redirecting%20me%20to%20the%20STS%20login%20page%20for%20old%20organisation.%20%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20give%20any%20specific%20guidance%20on%20where%20else%20to%20look%2Fwhat%20else%20to%20clean%20up%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance%20-%20John%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-179461%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-179461%22%20slang%3D%22en-US%22%3E%3CP%3EAll%2C%20I%20have%20removed%20and%20recreated%20my%20profile%20and%20now%20all%20is%20ok.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-179432%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-179432%22%20slang%3D%22en-US%22%3E%3CP%3EFor%20the%20webclient%2C%20clear%20the%20browser%20cache%2Fcookies%20or%20simply%20try%20a%20Private%20session.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-179431%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-179431%22%20slang%3D%22en-US%22%3E%3CP%3EJuan%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Elocal%20installed%20app%20is%20working%20OK%2C%20trouble%20is%20the%20webclient.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERGDS%20Eric%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-179430%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-179430%22%20slang%3D%22en-US%22%3E%3CP%3EVasil%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20for%20the%20answer.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3Elocal%20installed%20teams%20is%20working%20OK%2C%20only%20the%20HTML%20version%20has%20this%20problem.%3C%2FP%3E%0A%3CP%3Eallready%20logged%20of%20and%20on%20again.%3C%2FP%3E%0A%3CP%3EI%20have%20allredy%20removed%20all%20entries%20in%20the%20credential%20manager%20(VAULT)%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20will%20see%26nbsp%3Bis%20i%20can%20find%20some%20entrieas%20in%20my%20appData%20fodler.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERGDS%20Eric%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-179429%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-179429%22%20slang%3D%22en-US%22%3EHave%20you%20tried%20to%20uninstall%20the%20App%20and%20Install%20it%20but%20from%20the%20Web%20App%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-179427%22%20slang%3D%22en-US%22%3ERe%3A%20Remove%20redirection%20login%20teams%20to%20an%20STS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-179427%22%20slang%3D%22en-US%22%3E%3CP%3EI%20assume%20you%20already%20tried%20logging%20out%20of%20the%20client%2C%20so%20if%20that%20didn't%20help%20you%20have%20to%20delete%20all%20the%20stored%20Teams%20entries%20under%20Credentials%20manager.%20If%20that%20doesn't%20help%20either%2C%20delete%20all%20content%20from%20the%20AppData%20directories%20for%20Teams%2C%20apart%20from%20the%20actual%20client.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Eric Bridié
New Contributor

Hi all,

 I recently stopped working for a company where I used Teams. I have now a new own O365 E5 licenses active but when I try to start teams my login is getting redirected to the STS page of the previous company I worked for, how can I remove this redirection?

 I have no problem to login the Office 365 starting page https://www.office.com/

 Any help is welcome

 Thanks, in advanced.

 RGDS Eric

 

7 Replies

I assume you already tried logging out of the client, so if that didn't help you have to delete all the stored Teams entries under Credentials manager. If that doesn't help either, delete all content from the AppData directories for Teams, apart from the actual client.

Have you tried to uninstall the App and Install it but from the Web App?

Vasil,

 

Thanks for the answer.

 

local installed teams is working OK, only the HTML version has this problem.

allready logged of and on again.

I have allredy removed all entries in the credential manager (VAULT) 

I will see is i can find some entrieas in my appData fodler.

 

RGDS Eric

Juan,

 

local installed app is working OK, trouble is the webclient.

 

RGDS Eric

For the webclient, clear the browser cache/cookies or simply try a Private session.

All, I have removed and recreated my profile and now all is ok.

 

Thanks.

Hi @Vasil Michev

 

I'm a +1 for this problem.

 

Used to work for a 365 organisation, now work for a different 365 organisation, have my own 365 subscription too.  Throughout the above I've used a Surface Pro, so accounts are interweaved there too.  Very wary of deleting the wrong profile/data.

 

I've deleted all of the web credentials for my old organisation in the Windows credentials manager (Start > search "Credentials" > Credentials Manager - pick and Remove obviously 'old org' credentials.  Can't see anything keyed on "Teams"). 

 

I use both Chrome and Edge.  I've deleted all cookies in Chrome for old organisation.  Can't find anything in Edge to delete.

 

The thick-client app on my Surface works fine - new organisation, it's the web client which always goes to old organisation.   when I'm on the Office 365 "Home" for my new organisation all of the 365 apps seem to work ok in browser, except Teams which keeps redirecting me to the STS login page for old organisation.  

 

Can you give any specific guidance on where else to look/what else to clean up?

 

Thanks in advance - John

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies