Home

Outbound / Inbound calls from Teams Client - Direct Routing

%3CLINGO-SUB%20id%3D%22lingo-sub-705957%22%20slang%3D%22en-US%22%3EOutbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-705957%22%20slang%3D%22en-US%22%3E%3CP%3EGood%20Day%20Teams%20Community.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20logged%20a%20call%20with%20MS%20a%20week%20and%20half%20ago%20and%20it%20seems%20they%20have%20no%20idea%20how%20to%20resolve%20my%20issue.%26nbsp%3B%20Maybe%20someone%20has%20had%20the%20same%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20MS%20Teams%20with%20Direct%20Routing%20with%20a%20Audiocodes%20SBC.%26nbsp%3B%20The%20Audiocodes%20send%20MS%20a%20OPTIONS%20request%20and%20MS%20replies%20back%20200%20OK.%26nbsp%3B%20MS%20then%20sends%20me%20a%20OPTIONS%20request%20and%20my%20SBC%20sends%20back%20a%20200%20OK.%26nbsp%3B%20When%20I%20check%20on%20my%20Teams%20Admin%20Page%20(Office%20Portal)%2C%20the%20SBC%20is%20up.%26nbsp%3B%20When%20I%20make%20a%20call%20from%20my%20teams%20client%2C%20the%20call%20never%20gets%20to%20my%20SBC%2C%20and%20the%20call%20just%20disconnects.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20make%20a%20call%20to%20my%20Teams%20number%2C%20it%20rings%20twice%2C%20goes%20straight%20to%20voicemail%20and%20I%20get%20a%20notification%20about%20the%20voicemail.%26nbsp%3B%20But%20the%20call%20never%20rings%20on%20my%20Teams%20client.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20advice%20or%20assistance%20will%20be%20held%20in%20high%20regard%20as%20I%20have%20been%20battling%20with%20this%20for%20months%20and%20I%20need%20to%20get%20this%20working%20this%20week%20for%20my%20directors.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-705957%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-709493%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-709493%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F362755%22%20target%3D%22_blank%22%3E%40Gysbert%3C%2FA%3E%26nbsp%3BYou%20should%20check%20the%20logs%20from%20the%20Audiocodes%20SBC.%20Often%20there%20is%20something%20wrong%20with%20the%20configuration%2C%20maybe%20codecs%20that%20are%20not%20matching.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EInstall%20Audiocodes%20syslog%20viewer%20on%20a%20computer%20and%20set%20the%20SBC%20to%20send%20syslogs%20to%20that%20computer.%20In%20the%20syslog%20viewer%20you%20should%20be%20able%20to%20see%20why%20the%20call%20is%20not%20connected%20as%20it%20should%2C%20or%20at%20least%20get%20some%20indication%20on%20why.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.audiocodes.com%2Flibrary%2Ffirmware%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.audiocodes.com%2Flibrary%2Ffirmware%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-709556%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-709556%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9476%22%20target%3D%22_blank%22%3E%40Linus%20Cansby%3C%2FA%3E%26nbsp%3BI%20have%20the%20syslog%20software%20from%20Audiocodes%20installed%20and%20checked%20the%20logs%20for%20a%20few%20days%20now.%26nbsp%3B%20I%20had%20a%20Teams%20Implementations%20Engineer%20from%20Audiocodes%20at%20our%20offices%20also%20to%20ensure%20I%20had%20the%20Audiocodes%20setup%20100%25.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20am%20a%20call%20from%20my%20mobile%20to%20my%20landline%2C%20I%20see%20the%20INVITE%20back%20and%20forth%2C%20it%20all%20seems%20correct%20(and%20Audiocodes%20confirmed%20this%20also).%26nbsp%3B%20I%20see%20the%20call%20hot%20the%20microsoft%20PSTN%20gateway%20and%20coming%20back%20also.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20suspicion%20that%20my%20issue%20is%20either%20with%20my%20Hybrid%20deployment%20of%20SfB%20(All%20my%20users%20are%20currently%20either%20in%20Islands%20mode%20or%20TeamsOnly%20Mode)%20or%20that%20my%20actual%20configuration%20on%20SkypeOnline%20is%20not%20correct%2C%20although%20I%20have%20followed%20all%20the%20documentation%20from%20MS%20to%20the%20T.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-709608%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-709608%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F362755%22%20target%3D%22_blank%22%3E%40Gysbert%3C%2FA%3E%26nbsp%3BI%20guess%20you%20can%20dial%20out%20without%20any%20problems%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20you%20increase%20the%20time%20for%20%22Ring%20for%20this%20many%20seconds%20before%20redirecting%22%20is%20there%20any%20difference%20behavior%3F%20Can%20you%20try%20to%20activate%20Simultaneously%20ring%20to%20your%20mobile%20phone%20or%20other%20number%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20guess%20you%20tried%20being%20signed%20in%20with%20the%20Teams%20mobile%20app%20and%20other%20clients.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-709612%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-709612%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9476%22%20target%3D%22_blank%22%3E%40Linus%20Cansby%3C%2FA%3E%26nbsp%3BDialing%20out%20is%20also%20not%20working.%26nbsp%3B%20It%20does%20not%20hit%20the%20SBC%20at%20all.%26nbsp%3B%20When%20I%20run%20a%20few%20tests%20(Test-CSOnlineUserVoiceRouting.ps1%20and%20TeamsDirectRoutingTool-1.00.ps1)%20it%20all%20says%20that%20the%20call%20is%20being%20normalized%20correctly%20and%20that%20it%20is%20routed%20to%20my%20PSTNGateway.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20the%20mobile%20client%20also%20on%20Android%20and%20iOS.%26nbsp%3B%20I%20even%20went%20as%20far%20as%20to%20delete%20my%20account%20from%20SfB%20On-Prem%20and%20also%20create%20a%20pure%20cloud%20user.%26nbsp%3B%20All%20users%20have%20E5%20licenses.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESimultaneous%20ring%20does%20not%20make%20a%20difference%20at%20all.%26nbsp%3B%20I%20will%20adjust%20the%20%22Ring%20for%20this%20many%20seconds%20before%20redirecting%22%20now%20and%20let%20you%20know.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20appreciate%20the%20assistance%20btw.%26nbsp%3B%20I%20am%20at%20loss%20currently%20why%20this%20is%20simply%20just%20not%20working.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-709727%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-709727%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9476%22%20target%3D%22_blank%22%3E%40Linus%20Cansby%3C%2FA%3E%26nbsp%3BI%20changed%20the%20setting%20to%2060%20seconds%20with%20no%20change%20in%20the%20behavior.%3C%2FP%3E%3CP%3EWhen%20I%20forward%20to%20my%20mobile%20number%2C%20I%20do%20see%20on%20the%20SBC%20logs%20that%20it%20is%20trying%20to%20route%20it%20to%20my%20mobile%20number%20and%20it%20also%20does%20pick%20up%20the%20users%20SIP%20address.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-718188%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-718188%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20experiencing%20similar%20issues.%3C%2FP%3E%3CP%3EI'm%20hybrid%20on-prem%20and%20online%2C%20and%20paired%20a%20AudioCodes%20M1000.%20Created%20a%20%22unrestricted%22%20voice%20routing%20policy%20with%20number%20pattern%20%22.*%22%2C%20and%20assigned%20to%20a%20test%20user.%3C%2FP%3E%3CP%3EAssigned%20a%20LineUri%20%3A%20TEL%3A%2B14441233888%26nbsp%3B%20to%20this%20user%20and%20in%20my%20SBC%20through%20message%20manipulation%20changed%20public%20DID%20to%20the%204441233888.%3C%2FP%3E%3CP%3EInbound%20calls%20to%20the%20public%20DID%20looks%20perfect%20in%20the%20syslog.%20but%20I%20get%20same%20behaviour%3B%20rings%20twice%2C%20then%20dead%20air.%20and%20does%20not%20ring%20the%20client.%26nbsp%3B%3C%2FP%3E%3CP%3Edoing%20a%20get-csuser%20for%20the%20test%20user%20shows%20no%20VoiceRouting%20Policy%20assigned%2C%20and%20EnterpriseVoiceEnabled%20still%20shows%20False%2C%20although%20I%20assigned%20that%20several%20hours%20ago.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-719057%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-719057%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F365713%22%20target%3D%22_blank%22%3E%40P_theGr8%3C%2FA%3E%26nbsp%3B%20I%20also%20had%20that%20issue.%26nbsp%3B%20Turned%20out%20that%20the%20a%20certain%20portion%20of%20the%20license%20did%20not%20apply%20correctly.%26nbsp%3B%20When%20you%20do%20a%20Get-CsOnlineUser%20-Identity%2C%20look%20for%26nbsp%3BInterpretedUserType.%26nbsp%3B%20Make%20sure%20that%20it%20does%20not%20say%20Needs%20Provisioning.%26nbsp%3B%20If%20it%20does%20not%2C%20go%20to%20your%20user%20on%20the%20Office%20365%20portal%2C%20edit%20the%20user%2C%20remove%20the%20PhoneSystem%20and%20SkypeOnline%20portions%20of%20the%20license%2C%20apply%20the%20changes%2C%20wait%20a%20bout%205%20minutes%2C%20re-enable%20the%20PhoneSystem%20and%20SkypeOnline%20portions%20and%20apply.%26nbsp%3B%20It%20should%20take%20about%2015%20mins%20to%20replicate.%26nbsp%3B%20After%20that%2C%20set%20HostedVoiceMail%20and%20EnterpriseVoice%20to%20%24True%20again%2C%20wait%2015%20mins%20then%20you%20should%20be%20sorted.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-726902%22%20slang%3D%22en-US%22%3ERe%3A%20Outbound%20%2F%20Inbound%20calls%20from%20Teams%20Client%20-%20Direct%20Routing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-726902%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F362755%22%20target%3D%22_blank%22%3E%40Gysbert%3C%2FA%3E%26nbsp%3BThanks%20for%20the%20help.%20I%20followed%20the%20procedure%20you%20described.%20But%20no%20improvement.%3C%2FP%3E%3CP%3EDid%20some%20more%20research%20and%20I'm%20now%20at%20this%20point%3A%3C%2FP%3E%3CP%3EI%20have%20forced%20my%20AudioCodes%20Mediant%201000%20to%20only%20use%20G.711%20coder%2C%20since%20I%20don't%20have%20DSP%20modules.%3C%2FP%3E%3CP%3EI%20can%20make%20inbound%20and%20outbound%20calls%20with%20my%20Teams%20client%2C%20however%20there%20is%20no%20audio.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20syslog%20shows%20that%20G.711%20is%20being%20negotiated%20successfully%2C%20but%20my%20SBC%20is%20not%20receiving%20any%20RTP%2FRTSP%20packets%20from%20Teams.%3C%2FP%3E%3CP%3EIt%20is%20not%20a%20firewall%20issue%2C%20all%20ports%20are%20open.%20In%20Teams%20admin%20portal%20the%20SBC%20shows%20as%20active%2C%20and%20that%20calls%20have%20been%20made.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Gysbert
Occasional Contributor

Good Day Teams Community.

 

I logged a call with MS a week and half ago and it seems they have no idea how to resolve my issue.  Maybe someone has had the same issue.

 

I am using MS Teams with Direct Routing with a Audiocodes SBC.  The Audiocodes send MS a OPTIONS request and MS replies back 200 OK.  MS then sends me a OPTIONS request and my SBC sends back a 200 OK.  When I check on my Teams Admin Page (Office Portal), the SBC is up.  When I make a call from my teams client, the call never gets to my SBC, and the call just disconnects.

 

When I make a call to my Teams number, it rings twice, goes straight to voicemail and I get a notification about the voicemail.  But the call never rings on my Teams client.

 

Any advice or assistance will be held in high regard as I have been battling with this for months and I need to get this working this week for my directors.

8 Replies

@Gysbert You should check the logs from the Audiocodes SBC. Often there is something wrong with the configuration, maybe codecs that are not matching.

 

Install Audiocodes syslog viewer on a computer and set the SBC to send syslogs to that computer. In the syslog viewer you should be able to see why the call is not connected as it should, or at least get some indication on why.

https://www.audiocodes.com/library/firmware

@Linus Cansby I have the syslog software from Audiocodes installed and checked the logs for a few days now.  I had a Teams Implementations Engineer from Audiocodes at our offices also to ensure I had the Audiocodes setup 100%.

 

When I am a call from my mobile to my landline, I see the INVITE back and forth, it all seems correct (and Audiocodes confirmed this also).  I see the call hot the microsoft PSTN gateway and coming back also.

 

I have a suspicion that my issue is either with my Hybrid deployment of SfB (All my users are currently either in Islands mode or TeamsOnly Mode) or that my actual configuration on SkypeOnline is not correct, although I have followed all the documentation from MS to the T.

@Gysbert I guess you can dial out without any problems?

 

If you increase the time for "Ring for this many seconds before redirecting" is there any difference behavior? Can you try to activate Simultaneously ring to your mobile phone or other number?

 

I guess you tried being signed in with the Teams mobile app and other clients.

@Linus Cansby Dialing out is also not working.  It does not hit the SBC at all.  When I run a few tests (Test-CSOnlineUserVoiceRouting.ps1 and TeamsDirectRoutingTool-1.00.ps1) it all says that the call is being normalized correctly and that it is routed to my PSTNGateway.

 

I tried the mobile client also on Android and iOS.  I even went as far as to delete my account from SfB On-Prem and also create a pure cloud user.  All users have E5 licenses.

 

Simultaneous ring does not make a difference at all.  I will adjust the "Ring for this many seconds before redirecting" now and let you know.

 

I appreciate the assistance btw.  I am at loss currently why this is simply just not working.

@Linus Cansby I changed the setting to 60 seconds with no change in the behavior.

When I forward to my mobile number, I do see on the SBC logs that it is trying to route it to my mobile number and it also does pick up the users SIP address.

I'm experiencing similar issues.

I'm hybrid on-prem and online, and paired a AudioCodes M1000. Created a "unrestricted" voice routing policy with number pattern ".*", and assigned to a test user.

Assigned a LineUri : TEL:+14441233888  to this user and in my SBC through message manipulation changed public DID to the 4441233888.

Inbound calls to the public DID looks perfect in the syslog. but I get same behaviour; rings twice, then dead air. and does not ring the client. 

doing a get-csuser for the test user shows no VoiceRouting Policy assigned, and EnterpriseVoiceEnabled still shows False, although I assigned that several hours ago.

 

 

@P_theGr8  I also had that issue.  Turned out that the a certain portion of the license did not apply correctly.  When you do a Get-CsOnlineUser -Identity, look for InterpretedUserType.  Make sure that it does not say Needs Provisioning.  If it does not, go to your user on the Office 365 portal, edit the user, remove the PhoneSystem and SkypeOnline portions of the license, apply the changes, wait a bout 5 minutes, re-enable the PhoneSystem and SkypeOnline portions and apply.  It should take about 15 mins to replicate.  After that, set HostedVoiceMail and EnterpriseVoice to $True again, wait 15 mins then you should be sorted.

@Gysbert Thanks for the help. I followed the procedure you described. But no improvement.

Did some more research and I'm now at this point:

I have forced my AudioCodes Mediant 1000 to only use G.711 coder, since I don't have DSP modules.

I can make inbound and outbound calls with my Teams client, however there is no audio. 

The syslog shows that G.711 is being negotiated successfully, but my SBC is not receiving any RTP/RTSP packets from Teams.

It is not a firewall issue, all ports are open. In Teams admin portal the SBC shows as active, and that calls have been made.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies