Home

MP4 videos uploaded in Teams doesnt play when trying in web app mode from IE browser

%3CLINGO-SUB%20id%3D%22lingo-sub-331585%22%20slang%3D%22en-US%22%3EMP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331585%22%20slang%3D%22en-US%22%3E%3CDIV%3EIssue%20is%20with%20MS%20Teams%20and%20not%20Office%20365%20Videos.%3C%2FDIV%3E%3CDIV%3EI%20have%20uploaded%20the%20mp4%20video%20in%20my%20teams%20and%20I%20tried%20playing%20the%20video%20in%20TEAMS%20itself%20from%20app%20and%20all%203%20browsers(IE%2C%20edge%20%26amp%3B%20chrome).%3C%2FDIV%3E%3CDIV%3EI%20am%20getting%20an%20error%20in%20IE%20while%20playing%20video%20in%20TEAMS%20but%20desktop%20app%2C%20edge%20%26amp%3B%20chrome%20worked%20fine.%20Size%20of%20the%20video%20is%208%20MB%3C%2FDIV%3E%3CDIV%3Ewhen%20opening%20same%20video%20in%20IE%20in%20O365%20videos%2C%20it%20is%20working%20fine%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-331585%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-331630%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331630%22%20slang%3D%22en-US%22%3EIt%20is%20working%20fine%20in%20other%20browsers.%20I%20will%20check%20on%20the%20youtube%20channel%20but%20I%20am%20really%20looking%20for%20an%20answer%20%3A%20why%20O365%20videos%20not%20working%20in%20MS%20teams%20via%20IE11%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-331629%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331629%22%20slang%3D%22en-US%22%3E%3CP%3EYes%2C%20absolutely.%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20solution%20is%20really%20outlined%20on%20the%20screenshot%20above%20that%20you%20provided%20from%20Teams%20-%20play%20in%20a%20different%20browser%20or%20play%20the%20video%20in%20a%20video%20app.%20Teams%20isn't%20a%20video%20app.%20If%20you%20don't%20want%20to%20use%20Stream%20because%20its%20not%20rolled%20out%20yet%20-%20which%20is%20completely%20understood%20-%20then%20as%20Adam%20says%20use%20YT%20or%20another%20video%20site%20and%20add%20it%20as%20a%20Tab.%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20you%20are%20adamant%20that%20you%20want%20this%20specific%20functionality%20then%20I%20would%20consider%20raising%20it%20in%20a%20ticket%20to%20Microsoft.%20I%20hope%20they%20will%20resolve%20it%20however%2C%20I%20would%20anticipate%20them%20coming%20back%20saying%20its%20either%20not%20supported%20or%20to%20use%20the%20above.%20It%20may%20take%20them%20a%20long%20time%20to%20fix%20it%20if%20they%20do%20find%20it%20is%20a%20bug.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETo%20add%20its%20not%20on%20the%20known%20bug%20list%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fknown-issues%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fmicrosoftteams%2Fknown-issues%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-331625%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331625%22%20slang%3D%22en-US%22%3E%3CP%3EAnd%20other%20browsers%20is%20not%20applicable%3F%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUpload%20to%20a%20private%20Youtube%20channel%20and%20add%20as%20a%20tab%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAdam%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-331624%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331624%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%26nbsp%3B%26nbsp%3BThis%20is%20not%20a%20solution%20for%20us%20as%20Stream%20is%20not%20open%20for%20all%20users%20in%20our%20organization%20yet.%20Is%20this%20Microsoft%20bug%20in%20IE%20or%20what%3F%20Do%20we%20have%20any%20other%20workaround%20for%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-331616%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331616%22%20slang%3D%22en-US%22%3EThanks%20Chris!%20That%E2%80%99s%20a%20good%20point%20to%20the%20mix!%20Better%20to%20use%20stream!%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-331600%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331600%22%20slang%3D%22en-US%22%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F277674%22%20target%3D%22_blank%22%3E%40rupaliagrawal%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EWould%20recommend%20using%20Microsoft%20Stream%20within%20Teams.%20MOV%20files%20are%20supported%20by%20Microsoft%20Stream%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fstream%2Finput-audio-video-formats-codecs%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fstream%2Finput-audio-video-formats-codecs%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3E1.)%20Upload%20the%20movie%20file%20to%20Microsoft%20Stream%3CBR%20%2F%3E2.)%20Set%20permissions%20on%20the%20movie%20file%20(I.e.%20All%20users%20or%20just%20Team%20Members)%3CBR%20%2F%3E3.)%20Create%20a%20Stream%20Channel%20and%20add%20the%20movie%20to%20it%3CBR%20%2F%3E4.)%20In%20Teams%2C%20create%20a%20Stream%20Tab%2C%20you%20can%20either%3CBR%20%2F%3E-%20Just%20add%20the%20sole%20video%20you%20created%3CBR%20%2F%3E-%20Add%20the%20channel%20so%20if%20you%20have%20further%20videos%20in%20the%20future%20just%20upload%20them%20to%20that%20Stream%20Channel%3CBR%20%2F%3E%3CBR%20%2F%3EVideo%20should%20now%20play.%20Having%20tested%2C%20Stream%20videos%20should%20be%20fine%20in%20IE11.%3CBR%20%2F%3E%3CBR%20%2F%3EHope%20that%20helps%20to%20solve%20your%20issue.%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-331594%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-331594%22%20slang%3D%22en-US%22%3E%3CP%3EYeah%2C%20I%20have%20the%20same!%20Working%20everywhere%20except%20from%20IE!%20Could%20be%20a%20limitation%20but%20on%20the%20other%20hand%20IE%20is%20supported!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eadam%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-990092%22%20slang%3D%22en-US%22%3ERe%3A%20MP4%20videos%20uploaded%20in%20Teams%20doesnt%20play%20when%20trying%20in%20web%20app%20mode%20from%20IE%20browser%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-990092%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F169605%22%20target%3D%22_blank%22%3E%40Christopher%20Hoard%3C%2FA%3E%26nbsp%3Bnot%20sure%20if%20this%20is%20still%20an%20active%20thread%20but%20we%20actually%20have%20the%20issue%20where%20mp4s%20are%20not%20playing%20in%20the%20desktop%20app%2C%20but%20they%20do%20play%20fine%20in%20browsers.%20In%20the%20desktop%20app%2C%20we%20can%20hear%20them%20but%20there%20is%20either%20a%20white%20or%20gray%20screen.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENote%20we%20try%20and%20view%20mp4s%20we've%20published%20and%20uploaded%20as%20well%20as%20videos%20from%20Stream%20that%20we've%20added%20as%20a%20tab%20to%20a%20channel.%20Any%20guesses%3F%20Not%20sure%20if%20it%20has%20something%20to%20do%20with%20our%20video%20driver.%3C%2FP%3E%3C%2FLINGO-BODY%3E
rupaliagrawal
New Contributor
Issue is with MS Teams and not Office 365 Videos.
I have uploaded the mp4 video in my teams and I tried playing the video in TEAMS itself from app and all 3 browsers(IE, edge & chrome).
I am getting an error in IE while playing video in TEAMS but desktop app, edge & chrome worked fine. Size of the video is 8 MB
when opening same video in IE in O365 videos, it is working fine
 
 
8 Replies

Yeah, I have the same! Working everywhere except from IE! Could be a limitation but on the other hand IE is supported! 

 

adam

Hi @rupaliagrawal

Would recommend using Microsoft Stream within Teams. MOV files are supported by Microsoft Stream

https://docs.microsoft.com/en-us/stream/input-audio-video-formats-codecs

1.) Upload the movie file to Microsoft Stream
2.) Set permissions on the movie file (I.e. All users or just Team Members)
3.) Create a Stream Channel and add the movie to it
4.) In Teams, create a Stream Tab, you can either
- Just add the sole video you created
- Add the channel so if you have further videos in the future just upload them to that Stream Channel

Video should now play. Having tested, Stream videos should be fine in IE11.

Hope that helps to solve your issue.

Best, Chris
Thanks Chris! That’s a good point to the mix! Better to use stream!

Adam

@Christopher Hoard  This is not a solution for us as Stream is not open for all users in our organization yet. Is this Microsoft bug in IE or what? Do we have any other workaround for this?

And other browsers is not applicable??

 

Upload to a private Youtube channel and add as a tab?

 

Adam

Yes, absolutely.

The solution is really outlined on the screenshot above that you provided from Teams - play in a different browser or play the video in a video app. Teams isn't a video app. If you don't want to use Stream because its not rolled out yet - which is completely understood - then as Adam says use YT or another video site and add it as a Tab.

If you are adamant that you want this specific functionality then I would consider raising it in a ticket to Microsoft. I hope they will resolve it however, I would anticipate them coming back saying its either not supported or to use the above. It may take them a long time to fix it if they do find it is a bug.

 

To add its not on the known bug list

 

https://docs.microsoft.com/en-us/microsoftteams/known-issues

Best, Chris

It is working fine in other browsers. I will check on the youtube channel but I am really looking for an answer : why O365 videos not working in MS teams via IE11

@Christopher Hoard not sure if this is still an active thread but we actually have the issue where mp4s are not playing in the desktop app, but they do play fine in browsers. In the desktop app, we can hear them but there is either a white or gray screen. 

 

Note we try and view mp4s we've published and uploaded as well as videos from Stream that we've added as a tab to a channel. Any guesses? Not sure if it has something to do with our video driver.

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
29 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies