Home

Logitech Group / Skype / Teams poor sound quality

%3CLINGO-SUB%20id%3D%22lingo-sub-357349%22%20slang%3D%22en-US%22%3ELogitech%20Group%20%2F%20Skype%20%2F%20Teams%20poor%20sound%20quality%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-357349%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20Logitech%20SmartDock%20%2F%20Group%20setup.%20When%20I%20plug%20my%20computer%20into%20the%20Logitech%20SmartDock%20extender%2C%20use%20Teams%2C%20voice%20recorder%20or%20anything%20else%20the%20audio%20sounds%20fine.%20When%20I%20use%20voice%20recorder%20on%20the%20Surface%20in%20the%20SmartDock%2C%20audio%20sounds%20fine.%20When%20I%20make%20a%20teams%20or%20skype%20call%20to%20teams%20or%20skype%20or%20the%20PSTN%2C%20the%20audio%20(on%20the%20non%20SrS)%20end%20sounds%20very%20unclear.%20This%20is%20a%20new%20system%20and%20has%20never%20worked%20(had%20it%20about%2030%20days).%20I%20updated%20everything%20on%20the%20surface%20(now%20using%204.0.64.0%2C%20previously%20used%20whichever%20version%20Logitech%20had%20preinstalled).%20Seems%20like%20I've%20tested%20all%20the%20hardware%20and%20the%20only%20possible%20problem%20is%20the%20skype%20%2F%20teams%20client%20(I%20tried%20skype%20default%20%26amp%3B%20teams%20default%20PSTN%20dialing%20although%20it%20is%20currently%20set%20as%20skype%20default%20because%20of%20the%20lack%20of%20DTMF%20in%20Teams%20default).%20Any%20ideas%20on%20what%20to%20try%3F%20If%20I%20were%20to%20describe%20the%20sound%2C%20it%20would%20be%20muffled%20or%20not%20crisp.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-357349%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Andrew Alexander
Senior Member

I have the Logitech SmartDock / Group setup. When I plug my computer into the Logitech SmartDock extender, use Teams, voice recorder or anything else the audio sounds fine. When I use voice recorder on the Surface in the SmartDock, audio sounds fine. When I make a teams or skype call to teams or skype or the PSTN, the audio (on the non SrS) end sounds very unclear. This is a new system and has never worked (had it about 30 days). I updated everything on the surface (now using 4.0.64.0, previously used whichever version Logitech had preinstalled). Seems like I've tested all the hardware and the only possible problem is the skype / teams client (I tried skype default & teams default PSTN dialing although it is currently set as skype default because of the lack of DTMF in Teams default). Any ideas on what to try? If I were to describe the sound, it would be muffled or not crisp. 

Related Conversations
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
22 Replies
flashing a white screen while open new tab
cntvertex in Discussions on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
PacketMon Components are not loading in WAC 1909
HotCakeX in Windows Admin Center on
2 Replies