Home

Issues with Teams Sharing Links?

%3CLINGO-SUB%20id%3D%22lingo-sub-923204%22%20slang%3D%22en-US%22%3EIssues%20with%20Teams%20Sharing%20Links%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-923204%22%20slang%3D%22en-US%22%3E%3CP%3EHas%20anyone%20else%20noticed%20since%20the%20new%20version%20of%20the%20desktop%20client%20was%20pushed%20out%20for%20Teams%20that%20%22Copy%20link%22%20permissions%20aren't%20working%20as%20they%20should%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETypically%2C%20%22copy%20link%22%20and%20%22people%20with%20existing%20access%20can%20use%20this%20link%22%20makes%20it%20easy%20to%20send%20out%20links%20to%20help%20people%20find%20documents.%26nbsp%3B%20However%2C%20we%20have%20noticed%20lately%20this%20link%20doesn't%20work%20and%20adds%20extra%20sharing%20permissions%20to%20the%20file-%20the%20user%20will%20get%20prompted%20to%20log%20in%20with%20their%20email%20address%20and%20then%20get%20a%20message%20saying%20the%20file%20hasn't%20been%20shared%20with%20them.%26nbsp%3B%20But%20if%20you%20highlight%20the%20URL%20within%20the%20Sharepoint%20site%20and%20copy%20and%20paste%20that%20link%2C%20sharing%20works.%26nbsp%3B%20Any%20thoughts%20or%20has%20anyone%20else%20noticed%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-923204%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-926539%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Teams%20Sharing%20Links%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-926539%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F185103%22%20target%3D%22_blank%22%3E%40Ethan%20Stern%3C%2FA%3E%26nbsp%3B%20Do%20You%20copy%20the%20link%20in%20the%20SharePoint%20site%20or%20in%20the%20Team%3F%20In%20the%20attached%20picture%20it%20looks%20like%20You%20do%20it%20from%20SharePoint.%3C%2FP%3E%3CP%3EI%20have%20tested%20on%20two%20different%20Tenants%20now%20(and%20copied%20link%20both%20in%20SharePoint%20and%20in%20Teams)%20and%20everything%20works%20fine.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-926883%22%20slang%3D%22en-US%22%3ERe%3A%20Issues%20with%20Teams%20Sharing%20Links%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-926883%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F7661%22%20target%3D%22_blank%22%3E%40Magnus%20Goks%C3%B8yr%3C%2FA%3E%26nbsp%3BHi%20Magnus!%26nbsp%3B%20Thanks%20for%20reaching%20out.%26nbsp%3B%20That%20screen%20shot%20is%20from%20within%20Teams%20using%20the%20copy%20button.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Ethan Stern
Contributor

Has anyone else noticed since the new version of the desktop client was pushed out for Teams that "Copy link" permissions aren't working as they should?

 

Typically, "copy link" and "people with existing access can use this link" makes it easy to send out links to help people find documents.  However, we have noticed lately this link doesn't work and adds extra sharing permissions to the file- the user will get prompted to log in with their email address and then get a message saying the file hasn't been shared with them.  But if you highlight the URL within the Sharepoint site and copy and paste that link, sharing works.  Any thoughts or has anyone else noticed this?

3 Replies

@Ethan Stern  Do You copy the link in the SharePoint site or in the Team? In the attached picture it looks like You do it from SharePoint.

I have tested on two different Tenants now (and copied link both in SharePoint and in Teams) and everything works fine.

@Magnus Goksøyr Hi Magnus!  Thanks for reaching out.  That screen shot is from within Teams using the copy button.

You appear to be on an early release tenant with the new files tab experience. I don't think this has started to roll out to production yet and thought this was a bug that had happened to Sharing in general awhile back (not in Teams but SharePoint / OneDrive). Curious if it's possible you have a regression of that.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies