Home

Error when trying to add SharePoint list tab to Teams channel

%3CLINGO-SUB%20id%3D%22lingo-sub-302939%22%20slang%3D%22en-US%22%3EError%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-302939%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20receiving%20an%20error%20message%20when%20attempting%20to%20add%20a%20SharePoint%20list%20tab.%20xxxxx.sharepoint.com%20refused%20to%20connect.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20worked%20for%20me%20last%20week%20in%20another%20team%2C%20but%20only%20when%20using%20Chrome.%20Several%20of%20us%20are%20experiencing%20this%20today%20in%20Chrome.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20599px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F62959i4104FC1ECE5C777D%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22TeamsSharepointListTabError.png%22%20title%3D%22TeamsSharepointListTabError.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20else%20experiencing%20this%20or%20have%20some%20troubleshooting%20ideas%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EBrian%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-302939%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EError%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETab%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-367249%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-367249%22%20slang%3D%22en-US%22%3E%3CP%3EI%C2%B4m%20seeing%20this%20same%20issue%20in%20the%20Desktop%20application%20(%26nbsp%3B%20and%20only%20for%20some%20Teams%20not%20others.%26nbsp%3B%20Is%20this%20issue%20being%20worked%20on%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-354089%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-354089%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20receive%20the%20same%20issue%20when%20attempting%20to%20hit%20apps.powerbi.com%20from%20the%20Teams%20web%20client.%26nbsp%3B%20It%20works%20fine%20from%20the%20app.%26nbsp%3B%20We%20access%20PowerBI%20reports%20via%20the%20embedded%20website%20because%20we%20need%20to%20link%20directly%20to%20bookmarks%20within%20a%20PowerBI%20report.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%2C%3C%2FP%3E%3CP%3EEric%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-330109%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-330109%22%20slang%3D%22en-US%22%3E%3CP%3EWas%20asked%20to%20provide%20logs%20for%20an%20unaffected%20user.%20Pretty%20sure%20they%20don't%20need%20them%20to%20investigate%20this%20issue%2C%20but%20fine.%20Logs%20have%20been%20shared.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-329465%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-329465%22%20slang%3D%22en-US%22%3EFor%20mine%2C%20it%20seems%20consistent%20across%20multiple%20users%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-328799%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-328799%22%20slang%3D%22en-US%22%3EAre%20these%20issues%20related%20to%20you%20or%20does%20it%20affect%20all%20users%20in%20those%20tenants%3F%3F%3CBR%20%2F%3E%3CBR%20%2F%3EAdam%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-328794%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-328794%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20folks%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20too%20am%20having%20issues%20in%20Teams.%20Not%20just%20on%20my%20tenancy%20but%20on%20multiple%20tenancies%20I%20provide%20admin%20support%20for.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%E2%80%A2%20Unable%20to%20add%20a%20SharePoint%20site%20to%20a%20Teams%20channel%20%22Desktop%20%2F%20Web%20App%22%3C%2FP%3E%3CP%3E%E2%80%A2%20Unable%20to%20upload%20documents%20to%20a%20document%20library%20which%20is%20also%20in%20a%20Teams%20channel%20%22Desktop%20%2F%20Web%20App%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUploading%20via%20SharePoint%20online%20directly%20is%20functioning%20as%20expected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20too%20have%20opened%20a%20support%20ticket%20with%20Microsoft%20which%20is%20active%20close%20to%20a%20week%20now%20with%20very%20little%20progress%20made.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20supplied%20all%20log%20and%20test%20data%2C%20I've%20checked%20all%20firewall%20rules%2C%20ports%2C%20web%20filters%20etc.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20impressed%20%3A(%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-328443%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-328443%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20multiple%20users%20that%20experience%20this%20issue.%20The%20desktop%20app%20won't%20allow%20them%20to%20use%20the%20SharePoint%20connector%20in%20any%20Microsoft%20Teams%20environment%2C%20but%20it%20works%20fine%20in%20all%20major%20browsers.%20They%20all%20have%20the%20latest%20version%20of%20the%20desktop%20app%20and%20the%20issue%20started%20for%20them%20around%20a%20week%20ago.%20My%20account%20is%20not%20impacted%20which%20is%20why%20I%20can't%20reproduce%20the%20issue.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20just%20created%20a%20ticket%20with%20Microsoft%20support%20and%20also%20provided%20the%20Fiddler%20log%2C%20the%20debug%20logs%20(Ctrl%20%2B%20Alt%20%2B%20Shift%20%2B%201)%20and%20the%20desktop%20logs%20(%25appdata%25%5CMicrosoft%5CTeams%5Clogs.txt).%26nbsp%3BThey%20now%20have%20all%20the%20information%20we%20can%20provide%20to%20allow%20them%20to%20investigate%20this%20issue%20and%20work%20on%20a%20fix.%20This%20will%20be%20a%20good%20test%20case.%20The%20last%202%20times%20I%20reported%20a%20bug%20in%20Microsoft%20Teams%2C%20it%20took%20them%20%2B3%20Months%20to%20fix%20them.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-303085%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-303085%22%20slang%3D%22en-US%22%3E%3CP%3EThat's%20interesting.%20For%20me%20the%20desktop%20app%20won't%20allow%20me%20to%20successfully%20add%20this%20for%20any%20team.%20I%20see%20the%20following%20(nothing%20ever%20loads)%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20428px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F62973i570FB5E723C1319C%2Fimage-dimensions%2F428x437%3Fv%3D1.0%22%20width%3D%22428%22%20height%3D%22437%22%20alt%3D%22TeamsSharePointListTabIssue2.png%22%20title%3D%22TeamsSharePointListTabIssue2.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUsing%20Chrome%2C%20it%20works%20properly%20like%20this%20for%20all%20teams%20except%20the%20one%20I%20mentioned%20in%20the%20original%20post%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20429px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F62974i6A67E2C980FC85C6%2Fimage-dimensions%2F429x467%3Fv%3D1.0%22%20width%3D%22429%22%20height%3D%22467%22%20alt%3D%22TeamsSharePointListTabIssue3.png%22%20title%3D%22TeamsSharePointListTabIssue3.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-303018%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-303018%22%20slang%3D%22en-US%22%3ESame%20experience%20here!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-303014%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-303014%22%20slang%3D%22en-US%22%3EI%20have%20seen%20couple%20of%20issues%20related%20to%20this%2C%20for%20now%20the%20only%20solution%20I%20see%20is%20to%20use%20desktop%20app%20so%20%2C%20please%20download%20MS%20Team%20desktop%20app%20and%20try%20the%20same%20thing%20.%20let%20me%20now%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-303007%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-303007%22%20slang%3D%22en-US%22%3EI've%20never%20been%20able%20to%20use%20SharePoint%20tabs%20or%20things%20linked%20to%20SharePoint%20when%20using%20the%20web%20at%20all.%20I've%20always%20had%20to%20use%20the%20client%20to%20get%20the%20tabs%20to%20work%20properly.%20Usually%20it's%20related%20to%20having%20some%20form%20of%20iframed%20contact%20on%20the%20page%2C%20but%20if%20all%20you%20are%20doing%20is%20linking%20to%20a%20list%2C%20and%20it's%20using%20a%20modern%20UI%20it%20should%20work%20you%20would%20think.%20Check%20the%20desktop%20client%2C%20it's%20probably%20working.%20They%20need%20to%20really%20work%20on%20the%20tab%20compatibility%20when%20it%20comes%20to%20using%20browser%20Teams.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-426441%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-426441%22%20slang%3D%22en-US%22%3E%3CP%3EAnyone%20still%20getting%20this%3F%20Found%20this%20same%20error%20for%20the%20first%20time%20today.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENow%20I%20don't%20use%20the%20SharePoint%20connector.%20I%20just%20use%20the%20Website%20tab%20in%20Teams.%20This%20has%20worked%20quite%20well%2C%20until%20today.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F2144%22%20target%3D%22_blank%22%3E%40Pooya%20Obbohat%3C%2FA%3E%26nbsp%3BDid%20you%20ever%20hear%20back%20from%20MS%20support%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-428279%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-428279%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F118317%22%20target%3D%22_blank%22%3E%40Deric%20Curtis%3C%2FA%3E%26nbsp%3Beach%20time%20we%20had%20an%20issue%20with%20connectors%20in%20Teams%2C%20the%20issue%20was%20fixed%20by%20Microsoft.%20Nothing%20we%20could%20do%20to%20fix%20it%20ourselves%20unfortunately.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-428820%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20trying%20to%20add%20SharePoint%20list%20tab%20to%20Teams%20channel%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-428820%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F2144%22%20target%3D%22_blank%22%3E%40Pooya%20Obbohat%3C%2FA%3E%26nbsp%3BThanks%20for%20the%20info.%20In%20the%20last%202%20weeks%20we%20have%20had%20all%20sorts%20of%20SharePoint%20Online%20issues.%20Slowness%2C%20part%20sites%20not%20loading%20and%20all%20sorts%20of%20other%20troubles.%3C%2FP%3E%3C%2FLINGO-BODY%3E
some guy
Contributor

I'm receiving an error message when attempting to add a SharePoint list tab. xxxxx.sharepoint.com refused to connect.

 

This worked for me last week in another team, but only when using Chrome. Several of us are experiencing this today in Chrome.  

 

TeamsSharepointListTabError.png

 

Anyone else experiencing this or have some troubleshooting ideas?

 

Thanks,

Brian

14 Replies
I've never been able to use SharePoint tabs or things linked to SharePoint when using the web at all. I've always had to use the client to get the tabs to work properly. Usually it's related to having some form of iframed contact on the page, but if all you are doing is linking to a list, and it's using a modern UI it should work you would think. Check the desktop client, it's probably working. They need to really work on the tab compatibility when it comes to using browser Teams.
I have seen couple of issues related to this, for now the only solution I see is to use desktop app so , please download MS Team desktop app and try the same thing . let me now
Same experience here!

That's interesting. For me the desktop app won't allow me to successfully add this for any team. I see the following (nothing ever loads):

TeamsSharePointListTabIssue2.png

 

Using Chrome, it works properly like this for all teams except the one I mentioned in the original post:

TeamsSharePointListTabIssue3.png

We have multiple users that experience this issue. The desktop app won't allow them to use the SharePoint connector in any Microsoft Teams environment, but it works fine in all major browsers. They all have the latest version of the desktop app and the issue started for them around a week ago. My account is not impacted which is why I can't reproduce the issue. 

 

Have just created a ticket with Microsoft support and also provided the Fiddler log, the debug logs (Ctrl + Alt + Shift + 1) and the desktop logs (%appdata%\Microsoft\Teams\logs.txt). They now have all the information we can provide to allow them to investigate this issue and work on a fix. This will be a good test case. The last 2 times I reported a bug in Microsoft Teams, it took them +3 Months to fix them. 

Hi folks,

 

I too am having issues in Teams. Not just on my tenancy but on multiple tenancies I provide admin support for.

 

• Unable to add a SharePoint site to a Teams channel "Desktop / Web App"

• Unable to upload documents to a document library which is also in a Teams channel "Desktop / Web App"

 

Uploading via SharePoint online directly is functioning as expected.

 

I too have opened a support ticket with Microsoft which is active close to a week now with very little progress made.

 

I've supplied all log and test data, I've checked all firewall rules, ports, web filters etc.

 

Not impressed :(

Are these issues related to you or does it affect all users in those tenants??

Adam
For mine, it seems consistent across multiple users

Was asked to provide logs for an unaffected user. Pretty sure they don't need them to investigate this issue, but fine. Logs have been shared. 

Hi, 

 

I receive the same issue when attempting to hit apps.powerbi.com from the Teams web client.  It works fine from the app.  We access PowerBI reports via the embedded website because we need to link directly to bookmarks within a PowerBI report.

 

Thanks,

Eric

I´m seeing this same issue in the Desktop application (  and only for some Teams not others.  Is this issue being worked on?

Anyone still getting this? Found this same error for the first time today.

 

Now I don't use the SharePoint connector. I just use the Website tab in Teams. This has worked quite well, until today.

 

@Pooya Obbohat Did you ever hear back from MS support?

@Deric Curtis each time we had an issue with connectors in Teams, the issue was fixed by Microsoft. Nothing we could do to fix it ourselves unfortunately. 

@Pooya Obbohat Thanks for the info. In the last 2 weeks we have had all sorts of SharePoint Online issues. Slowness, part sites not loading and all sorts of other troubles.

Related Conversations
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
Early preview of Microsoft Edge group policies
Sean Lyndersay in Discussions on
65 Replies
*Updated 9/3* Syncing in Microsoft Edge Preview Channels
Elliot Kirk in Articles on
201 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
2 Replies