SOLVED
Home

Error at startup: There was a glitch and we're recovering...

Highlighted
Johan Borg
Occasional Contributor

Error at startup: There was a glitch and we're recovering...

Hi,

 

Some of our users reported problems starting the Teams desktop client today.

Problem came out of the blue, has worked before.

 

Gave error message "There was a glitch and we're recovering..."

 

Any ideas?

 

Best regards,

Johan

37 Replies

Re: Error at startup: There was a glitch and we're recovering...

I'm adding me to this topic. I have users reporting this today.

Re: Error at startup: There was a glitch and we're recovering...

Adding screenshot of error message.

 

Teams_20170510.png

Re: Error at startup: There was a glitch and we're recovering...

I have users expericiencing the same issue.

 

The error is related to GPU Crash. Already sent an e-mail to 'microsoftteamsdev@microsoft.com'

 

Wed May 10 2017 11:01:38 GMT+0100 (GMT Daylight Time) <23280> -- error -- GPU process crashed, restarting the app.

Wed May 10 2017 11:01:38 GMT+0100 (GMT Daylight Time) <23280> -- info -- Saved renderer crash info

Wed May 10 2017 11:01:38 GMT+0100 (GMT Daylight Time) <23280> -- info -- Set restartReason state.

Wed May 10 2017 11:01:38 GMT+0100 (GMT Daylight Time) <23280> -- info -- Restarting app Teams with reason crash

 

Waiting for feedback. So far no one is using Teams!...

Re: Error at startup: There was a glitch and we're recovering...

I to am having this issue!!

Re: Error at startup: There was a glitch and we're recovering...

I'm having the same problem on a 2008 R2 Remote Desktop environment. I just tried re-running the installer and that seemed to get it working.

Re: Error at startup: There was a glitch and we're recovering...

We tested uninstalling and reinstalling Teams with freshly downloaded installer file, but to no avail.

Windows 7 pro - 64bit

Re: Error at startup: There was a glitch and we're recovering...

Hi James,

 

I have the same environment, 2008 R2 in Terminal Server, and re-installing solved it for some minutes, but then started to glitched again...

 

You didn't have anymore issues after that?

 

Cheers

Re: Error at startup: There was a glitch and we're recovering...

Not yet....I will post again if it comes back.

Re: Error at startup: There was a glitch and we're recovering...

It has started glitching again, I think it may be updating itself as I had installed an older copy of the installer.

Re: Error at startup: There was a glitch and we're recovering...

I had to uninstall the desktop app to get it to stop looping through the restart.  Was very annoying.  Couldn't kill it from Task Manager (threw an error message when I tried).

Re: Error at startup: There was a glitch and we're recovering...

Yep, I did the same and had the same problem...

 

Already investigate and didn't find any documentation about auto-update process and how to stop if exists.

Re: Error at startup: There was a glitch and we're recovering...

Seeing the same in our virtual desktop environment (Windows 7 64 bit). Was working fine until a recent update and new installs also fail.

Where did find the log with that GPU error?

Re: Error at startup: There was a glitch and we're recovering...

AppData\Roaming\Microsoft\Teams\logs.txt

RE: Error at startup: There was a glitch and we're recovering...

Same here, happening on my Windows 7 VDI desktop. My installation on Windows 10 seems to be working fine. Others at my company having trouble running Microsoft Teams in Windows 7 on our VDI as well in the last couple of days.

Re: Error at startup: There was a glitch and we're recovering...

Same problem out of the blue.  Windows 7 Enterprise, 64 bit running in a VMware VM.

Re: Error at startup: There was a glitch and we're recovering...

We are also having users on Surface Pro 4 Win10 with the same issue. 

Re: Error at startup: There was a glitch and we're recovering...

We have the same issue, I've raised a case with support teams, so I'll let you know how we go.

Re: Error at startup: There was a glitch and we're recovering...

We just rolled out teams across our network. Same issue with us on two PCs. Hope Microsoft will fix the desktop clients at the earliest.

Re: Error at startup: There was a glitch and we're recovering...

Same thing happening here too. For non virtualised desktops it is fine, but everyone else using Xendesktop suffers from that issue since yesterday.

Re: Error at startup: There was a glitch and we're recovering...

Interesting, our few affected machines are all regular desktops.

Re: Error at startup: There was a glitch and we're recovering...

Ours are almost all virtual desktops, same build on vanilla Win10 is working fine. Logs are off to the engineering teams and hope to hear more back US time.

Re: Error at startup: There was a glitch and we're recovering...

Hello,

 

I'm also getting the same issue from a couple of days,

Uninstalling and reinstalling doesn't help, I'm using this on a machine which is Remotely connected(Remote Desktop Connection).

 

Esh

Re: Error at startup: There was a glitch and we're recovering...

Same problem here...

Re: Error at startup: There was a glitch and we're recovering...

We have this happening on on Win7 32bit machine.  We have tried reinstalling, including blowing out the teams and Squirrel directories then rebooting and downloading a fresh installer.  The problem is still happening.

Solution

Re: Error at startup: There was a glitch and we're recovering...

We have found a work around. The recent update is a problem. I expect the work-around will also become problematic.

 

What we have done is to create a shortcut to:

c:\users\username\appdata\local\microsoft\teams\previous\teams.exe.

(change username to the current user's name)

 

The standard shortcut runs "Update.exe" each time Teams is launched.

 

Very best regards,

Iver Nielsen

 

 

Re: Error at startup: There was a glitch and we're recovering...

Tried the workaround to no avail.  The update exe must have already updated.  Tried to extract the original Teams.exe from the install package and running it from a shortcut, also to no avail.

Re: Error at startup: There was a glitch and we're recovering...

Working on 2008 R2 for me, make sure your shortcut points to the "previous" folder. The version on that EXE for me is 1.0.00.7405

Re: Error at startup: There was a glitch and we're recovering...

For those users that still have the folder previous (You have the option to copy it from user to user), it's a workaround to open the application.

It's a way to force opening teams in the previous version.

 

I change the shortcut to a user and so far, it's ok. (Again, important to point out, this way is using the version before the problem one)

Re: Error at startup: There was a glitch and we're recovering...

Sadly no previous folder in mine.  It got removed in troubleshooting yesterday.

Got a copy of previous from an unaffected co-worker.  I'm back up.  Thanks

Re: Error at startup: There was a glitch and we're recovering...

I have been playing with this on 2008 R2 and found that if you edit the settings.json file and change the entries for 

"ignoreGpuBlacklist":false

to true it will run once, but the app resets those values and it will crash the next time you try to run it.

Re: Error at startup: There was a glitch and we're recovering...

I tried downloading the program yesterday and now the error message regarding the glitch has been popping up on my screen...CONTINUALLY...every 5 seconds...ever since.  I can't get it to stop.  I have since deleted the program from the computer.  I've tried deleting it from the task manager when it pops up, I've tried "x-ing" it out when it pops up, I've tried minimizing it - NOTHING stops it.  It's been over 24 hours.  It pops up over everything I'm using...even typing this message.  I'm about to lose my mind.

Re: Error at startup: There was a glitch and we're recovering...

Can confirm workaround works for us. We manually distributed a working "previous" folder for affected users.

 

We have also raised issue with Microsoft through O365 support. It has now been sent to "back end engineers". Hopefully we will soon see a new update that resolve the issue. Fingers crossed.

Re: Error at startup: There was a glitch and we're recovering...

Unfortunately, only one 32 bit system here and original folder got deleted before we found work around so we are unable to resolve at this time.

Re: Error at startup: There was a glitch and we're recovering...

The latest update (Microsoft Teams Version 1.0.00.13152 (64-bit)) installed today fixed this issue.

Re: Error at startup: There was a glitch and we're recovering...

I can confirm this, this has resolved our issues as well.

Re: Error at startup: There was a glitch and we're recovering...

I also confirm, installing the new release solved this issue.

Re: Error at startup: There was a glitch and we're recovering...

On 2008 R2 I had to reinstall from the newest available version 1.0.00.13152 from Microsoft and then it works. When trying to run the update from the previous version of the client I couldn't get it to work.

Related Conversations
Availability
Yinghua Zeng  in  System Center AMA  on
6 Replies
Embedding on SharePoint
Audrie Gordon  in  Microsoft Stream Forum  on
19 Replies
Having an Issue with Excel hour/time formatting
Mike Button  in  Excel  on
13 Replies
Cost estimator for small scale catering
Louisa Dira  in  Excel  on
12 Replies
AAD PowerShell Commands not working (get-msol ...)
Ivan Unger  in  Azure Active Directory  on
16 Replies