Home

Auto Attendant and Call Queues issue

%3CLINGO-SUB%20id%3D%22lingo-sub-699231%22%20slang%3D%22en-US%22%3EAuto%20Attendant%20and%20Call%20Queues%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-699231%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Guys%2C%3C%2FP%3E%3CP%3Ei%20am%20trying%20to%20setup%20auto%20attendant%20with%20on-premises%20telephone%20number.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20assigned%20on-premises%20number%20(not%20a%20service%20number)%20to%20a%20resources%20account%20and%20assign%20to%20auto%20attendant.%20I%20am%20getting%20a%20404%20response%20on%20SBC%20(reason%20No_USER_Responding)%2C%20I%20enabled%20Teams%20only%20for%20the%20resource%20account%20but%20the%20issue%20is%20not%20resolved.%20also%20I%20enabled%20direct%20routing%20for%20the%20the%20number.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EAny%20idea%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-699231%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-699239%22%20slang%3D%22en-US%22%3ERe%3A%20Auto%20Attendant%20and%20Call%20Queues%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-699239%22%20slang%3D%22en-US%22%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-699261%22%20slang%3D%22en-US%22%3ERe%3A%20Auto%20Attendant%20and%20Call%20Queues%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-699261%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20you%20assign%20a%20Phone%20System%20license%20to%20the%20resource%20account%3F%20If%20you%20did%20that%20you%20might%20have%20the%20same%20problem%20as%20I%20did%20when%20tested%20this%2C%20that%20there%20is%20something%20in%20the%20backend%20that%20Microsoft%20have%20to%20fix.%20I%20got%20the%20404%20error%20when%20the%20SBC%20tried%20to%20route%20calls%20to%20Teams%2C%20I%20created%20a%20support%20case%20with%20Microsoft%20and%20they%20%22did%20a%20synchronization%22%20in%20the%20system%20and%20it%20started%20to%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.lync.se%2F2019%2F05%2Fdirect-routing-numbers-in-call-queues-and-auto-attendant%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.lync.se%2F2019%2F05%2Fdirect-routing-numbers-in-call-queues-and-auto-attendant%2F%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-699373%22%20slang%3D%22en-US%22%3ERe%3A%20Auto%20Attendant%20and%20Call%20Queues%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-699373%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Linus%2C%20thanks%20for%20update%20i%20will%20reach%20out%20Microsoft.%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9476%22%20target%3D%22_blank%22%3E%40Linus%20Cansby%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-699695%22%20slang%3D%22en-US%22%3ERE%3A%20Auto%20Attendant%20and%20Call%20Queues%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-699695%22%20slang%3D%22en-US%22%3EI'm%20not%20sure%20it%20was%20the%20404%20issue%3B%20or%20another.%20But%20I%20had%20to%20open%20a%20premier%20case%20when%20these%20accounts%20weren't%20working%20correctly.%20The%20ticket%20came%20back%20from%20Microsoft%20that%20we%20had%20to%20explicitly%20set%20a%20DEPARTMENT%20on%20the%20AD%20Account%20%22Microsoft%20Communication%20Application%20Instance%22%3B%20(blew%20me%20away.....)%20the%20account%20would%20keep%20failing%20online%20in%20a%20get-csonlineuser%20with%20a%20InterpretedUserType%20of%20'HybridOnlineAppEndpointFailedProvisioning'%3B%20For%20good%20measure%20I%20threw%20in%20first%20and%20last%20names%20and%20description%20on%20the%20account%20too.%20After%20a%20few%20hours%20of%20replication%20time%20it'd%20start%20working.%20So%20now%20on%20all%20accounts%20I%20build%20I%20put%20in%20a%20FirstName%20(givenNAme)%2C%20LastName%20(surName)%2C%20description%2C%20and%20department.%3C%2FLINGO-BODY%3E
Mohamed_Abdelrahman
New Contributor

Hi Guys,

i am trying to setup auto attendant with on-premises telephone number. 

 

I assigned on-premises number (not a service number) to a resources account and assign to auto attendant. I am getting a 404 response on SBC (reason No_USER_Responding), I enabled Teams only for the resource account but the issue is not resolved. also I enabled direct routing for the the number.

 

Any idea?

 

Thanks

4 Replies

Hi,

 

Did you assign a Phone System license to the resource account? If you did that you might have the same problem as I did when tested this, that there is something in the backend that Microsoft have to fix. I got the 404 error when the SBC tried to route calls to Teams, I created a support case with Microsoft and they "did a synchronization" in the system and it started to work.

 

https://www.lync.se/2019/05/direct-routing-numbers-in-call-queues-and-auto-attendant/

Hi Linus, thanks for update i will reach out Microsoft. @Linus Cansby 

I'm not sure it was the 404 issue; or another. But I had to open a premier case when these accounts weren't working correctly. The ticket came back from Microsoft that we had to explicitly set a DEPARTMENT on the AD Account "Microsoft Communication Application Instance"; (blew me away.....) the account would keep failing online in a get-csonlineuser with a InterpretedUserType of 'HybridOnlineAppEndpointFailedProvisioning'; For good measure I threw in first and last names and description on the account too. After a few hours of replication time it'd start working. So now on all accounts I build I put in a FirstName (givenNAme), LastName (surName), description, and department.
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies