SOLVED
Home

Video Playback Blurry first half of video

%3CLINGO-SUB%20id%3D%22lingo-sub-79251%22%20slang%3D%22en-US%22%3EVideo%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79251%22%20slang%3D%22en-US%22%3E%3CP%3EMaybe%20it's%20how%20Stream%20handles%20video%2C%20but%20it%20seems%20to%20simply%20not%20want%20to%20render%20the%20first%20half%20of%20my%2012%20second%20video%20in%20720p%20or%20higher.%20If%20I%20let%20it%20get%20to%20about%2000%3A05%3A30%20then%20it%20looks%20great%2C%20but%20even%20when%20I%20rewind%20back%20to%2000%3A00%3A00%20and%26nbsp%3Bset%20the%20quality%20to%20max%20in%20the%20player%2C%20it%20looks%20like%20360p%20or%20worse.%20My%20video%20was%20probably%20uploaded%20around%2020%20minutes%20ago%20or%20more%20maybe%20so%20it%20should%20have%20finished%20processing.%20I've%20tried%20it%20on%20Chrome%26nbsp%3B%3CSPAN%3E51.0.2704.103%20m.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20also%20noticed%20I%20had%20to%20kick%20up%20the%26nbsp%3Bquality%20manually%20because%20within%2012%20seconds%20it%26nbsp%3Bdidn't%20decide%20to%20automatically%20change%20to%20720p%20or%20higher.%20It%20should%20probably%20kick%20up%20to%20that%20automatically%20as%20soon%20as%20it%20can%20if%20you're%20in%20full-screen.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-79251%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Eauto%20playback%20quality%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eblurry%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-335142%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-335142%22%20slang%3D%22en-US%22%3E%3CP%3EA%20hello%20from%20February%20of%202019%20--%20it%20hasn't%20been%20fixed%20yet.%26nbsp%3B%3C%2FP%3E%3CP%3ESMH%2C%20Microsoft...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-264279%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-264279%22%20slang%3D%22en-US%22%3E%3CP%3EVote%20on%20User%20Voice%20for%20a%20fix%3A%20%3CA%20href%3D%22https%3A%2F%2Foffice365.uservoice.com%2Fforums%2F264636-general%2Fsuggestions%2F35568271-improve-stream-performance-picture-blurry-first%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Foffice365.uservoice.com%2Fforums%2F264636-general%2Fsuggestions%2F35568271-improve-stream-performance-picture-blurry-first%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-242821%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-242821%22%20slang%3D%22en-US%22%3E%3CP%3EAny%20word%20on%20this%3F%20We%2C%20too%20are%20getting%20the%206-12%20second%20blurry%20display%20followed%20by%20the%20normal%20display%20when%20viewing%20videos.%20For%20short%20instructional%20videos%2C%20this%20is%20noticeable.%20Other%20video%20streaming%20products%20do%20not%20do%20this%20-%20video%20plays%20from%20the%20get-go.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-195777%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-195777%22%20slang%3D%22en-US%22%3E%3CP%3EHas%20this%20been%20resolved%3F%20I%20have%20screen%20casts%20that%20cannot%20be%26nbsp%3Bviewed%20until%2012%20seconds%20after%20playback%20has%20started%20because%20of%20how%20blurry%20the%20text%20in%20the%20video%20is.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-102661%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-102661%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20with%20OP%20here.%20%26nbsp%3BI%20have%20several%20quick%20videos%20to%20demonstrate%20user%20interactions%20with%20our%20software.%20%26nbsp%3BThe%20initial%20poor%20quality%20obscures%20the%20entirety%20of%20the%20screen-capture%20for%20half%20the%20video%2C%20which%20is%20unacceptable.%20%26nbsp%3BWe're%20on%20a%20100%20Mbps%20symmetrical%20pipe%20here%20and%20this%20shouldn't%20take%20that%20long.%20%26nbsp%3BActually%2C%20I%20don't%20think%20it%20should%20take%20any%20time%20at%20all.%20%26nbsp%3BIf%20the%20player%20is%20using%20the%20first%206%20seconds%20to%20determine%20appropriate%20playback%20quality%2C%20why%20don't%20you%20start%20running%20those%20scripts%20when%20the%20page%20itself%20loads%20so%20that%20by%20the%20time%20the%20user%20clicks%20play%2C%20they%20already%20get%20the%20highest%20quality%20starting%20at%20second%200.%20%26nbsp%3BDon't%20wait%20until%20the%20user%20clicks%20play%20to%20start%20that.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20there%20is%20a%20resolution%20to%20this%20problem%2C%20or%20any%20devised%20workarounds%20to%20begin%20playing%20original%20quality%20video%20at%20the%20onset%2C%20please%20let%20me%20know.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79258%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79258%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20your%20input%20and%20feedback!%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79257%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79257%22%20slang%3D%22en-US%22%3E%3CP%3EAh%20okay.%20As%20long%20as%20that's%20expected%20behavior%20at%20this%20time%20then%20all%20is%20well.%20I%20wanted%20to%20just%20make%20sure%20someone%20was%20aware%20of%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20time%20%3CIMG%20class%3D%22emoticon%20emoticon-smileyhappy%22%20id%3D%22smileyhappy%22%20src%3D%22https%3A%2F%2Fjgvjg48436.i.lithium.com%2Fi%2Fsmilies%2F16x16_smiley-happy.png%22%20alt%3D%22Smiley%20Happy%22%20title%3D%22Smiley%20Happy%22%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79256%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79256%22%20slang%3D%22en-US%22%3E%3CP%3EYes.%20It%20was%20just%20a%2012%20second%20test%20video%20of%20me%20capturing%20myself%20clicking%20around%20on%20the%20desktop.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79255%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79255%22%20slang%3D%22en-US%22%3E%3CP%3EJust%20clarifying%20also...%20did%20you%20say%20you%20uploaded%20a%2012%20second%20video%3F%20%26nbsp%3B%20%22%3CSPAN%3EIn%20a%2012%20second%20video...%22%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Ecan%20you%20confirm%20what%20the%20duration%20of%20the%20source%20video%20was%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79254%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79254%22%20slang%3D%22en-US%22%3E%3CP%3EGot%20it!%20%26nbsp%3BIt%20could%20have%20been%20one%20of%20the%20two%20issues%20you%20were%20referring%20to.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EThe%20technical%20reason%20for%20that%20taking%20so%20long%20is%20that%20we%20currently%20use%206%20second%20long%20video%20chunks%20in%20Stream%20preview.%20So%20it%20can%20take%20up%20to%2012%20seconds%20to%20adapt%20after%20it%20has%20downloaded%20the%20first%20two%20chunks%20and%20chosen%20which%20bandwidth%20is%20correct.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EAt%20this%20time%20that%20is%20expected%20behavior.%20%26nbsp%3BWe%20are%20looking%20at%20ways%20we%20can%20optimize%20that%20experience.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79253%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79253%22%20slang%3D%22en-US%22%3E%3CP%3EThat%20thread%20wasn't%20at%20all%20what%20I'm%20referring%20to.%20That%20user's%20problem%20is%20that%26nbsp%3Bthey%20didn't%20wait%20for%20their%20video%20to%20be%20processed.%20My%20problem%20is%20that%20the%20high%20resolutions%20appear%2C%20but%20the%20beginning%20of%20the%20video%20doesn't%20actually%20play%20back%20in%20the%20specified%20quality%20in%20the%20first%20half%20of%20the%20video.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20think%20it's%20expected%20behavior%26nbsp%3Bif%20I%20pause%20the%20video%2C%20select%26nbsp%3Bmax%20quality%2C%20wait%2030%20seconds%2C%20hit%20play%20and%20it%20still%20not%20be%20at%20max%20quality%3F%20That's%20currently%20what's%20happening.%20It's%20like%20it's%20impossible%20to%20see%20the%20first%26nbsp%3Bhalf%20of%20the%20video%20at%20max%20quality%20no%20matter%20what%20I%20do.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAuto%20just%20doesn't%20seem%20to%20work%26nbsp%3Bthat%20fast.%20In%20a%2012%20second%20video%2C%20it%20never%20changed%20quality%20from%20whatever%20it%20was%20using.%20It's%20certainly%20not%20my%20internet%20speed%20as%20I'm%20getting%20about%2094%20down%20and%2020%20up%20at%20the%20moment%20from%20home%20and%20I%20was%20getting%20similar%20results%20at%20work%20as%20well.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere's%20what%20happens%20currently%3A%3C%2FP%3E%3CP%3EI%20load%20the%20video%2C%3C%2FP%3E%3CP%3Ehit%20pause%2C%3C%2FP%3E%3CP%3Echange%20to%20max%20quality%20(1048p)%3C%2FP%3E%3CP%3Ewait%2030%20seconds%2C%3C%2FP%3E%3CP%3Ehit%20play%2C%3C%2FP%3E%3CP%3Ewatch%20low%20quality%20stream%2C%3C%2FP%3E%3CP%3Eat%20the%206%20second%20mark%20it%20significantly%20improves%20in%20quality.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20is%2C%20it%20should%20be%20high%20quality%20throughout%20the%20whole%20video%20if%20I%20pause%20it%20initially.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20give%20you%20the%20original%20file%20if%20that%20helps%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79252%22%20slang%3D%22en-US%22%3ERe%3A%20Video%20Playback%20Blurry%20first%20half%20of%20video%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79252%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20was%20discussed%20in%20the%20previous%20thread%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2FStream-Forum%2FResolution-Other-Than-360p%2Fm-p%2F4325%23U4325%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2FStream-Forum%2FResolution-Other-Than-360p%2Fm-p%2F4325%23U4325%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYes%2C%20we%20create%26nbsp%3Ba%20low%20resolution%20proxy%20as%20quickly%20as%20possible%20so%20that%20you%20can%20continue%20while%20we%20are%20generating%20the%20higher%20quality%20bitrate%20tracks%20in%20the%20background.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EAlso%20note%20that%20depending%20on%20your%20network%2C%20playback%20will%20start%20at%20lower%20bitrates%20and%20gradually%20adjust%20up%20to%20higher%20quality%20bitrates%20(assuming%20that%20the%20higher%20quality%20bitrates%20have%20finished).%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20player%20does%20a%20quick%20bandwidth%20test%20before%20playback%20and%20attempts%20to%20start%20with%20the%20most%20appropriate%20bitrate%20for%20your%20network.%26nbsp%3B%20Let%20us%20know%20if%20you%20see%20a%20lot%26nbsp%3Bmore%20issues%20with%20that%20ramp%20up%20time%20in%20your%20network.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
anonymous-user
Regular Contributor

Maybe it's how Stream handles video, but it seems to simply not want to render the first half of my 12 second video in 720p or higher. If I let it get to about 00:05:30 then it looks great, but even when I rewind back to 00:00:00 and set the quality to max in the player, it looks like 360p or worse. My video was probably uploaded around 20 minutes ago or more maybe so it should have finished processing. I've tried it on Chrome 51.0.2704.103 m.

 

I also noticed I had to kick up the quality manually because within 12 seconds it didn't decide to automatically change to 720p or higher. It should probably kick up to that automatically as soon as it can if you're in full-screen.

 

Thanks.

12 Replies

It was discussed in the previous thread:

https://powerusers.microsoft.com/t5/Stream-Forum/Resolution-Other-Than-360p/m-p/4325#U4325

 

Yes, we create a low resolution proxy as quickly as possible so that you can continue while we are generating the higher quality bitrate tracks in the background.


Also note that depending on your network, playback will start at lower bitrates and gradually adjust up to higher quality bitrates (assuming that the higher quality bitrates have finished). 

The player does a quick bandwidth test before playback and attempts to start with the most appropriate bitrate for your network.  Let us know if you see a lot more issues with that ramp up time in your network.

That thread wasn't at all what I'm referring to. That user's problem is that they didn't wait for their video to be processed. My problem is that the high resolutions appear, but the beginning of the video doesn't actually play back in the specified quality in the first half of the video.

 

I don't think it's expected behavior if I pause the video, select max quality, wait 30 seconds, hit play and it still not be at max quality? That's currently what's happening. It's like it's impossible to see the first half of the video at max quality no matter what I do.

 

Auto just doesn't seem to work that fast. In a 12 second video, it never changed quality from whatever it was using. It's certainly not my internet speed as I'm getting about 94 down and 20 up at the moment from home and I was getting similar results at work as well. 

 

Here's what happens currently:

I load the video,

hit pause,

change to max quality (1048p)

wait 30 seconds,

hit play,

watch low quality stream,

at the 6 second mark it significantly improves in quality.

 

The problem is, it should be high quality throughout the whole video if I pause it initially.

 

I can give you the original file if that helps?

Solution

Got it!  It could have been one of the two issues you were referring to.


The technical reason for that taking so long is that we currently use 6 second long video chunks in Stream preview. So it can take up to 12 seconds to adapt after it has downloaded the first two chunks and chosen which bandwidth is correct. 

At this time that is expected behavior.  We are looking at ways we can optimize that experience. 

Just clarifying also... did you say you uploaded a 12 second video?   "In a 12 second video..."

can you confirm what the duration of the source video was?

Yes. It was just a 12 second test video of me capturing myself clicking around on the desktop.

Ah okay. As long as that's expected behavior at this time then all is well. I wanted to just make sure someone was aware of it.

 

Thanks for your time Smiley Happy

Thanks for your input and feedback! 

I'm with OP here.  I have several quick videos to demonstrate user interactions with our software.  The initial poor quality obscures the entirety of the screen-capture for half the video, which is unacceptable.  We're on a 100 Mbps symmetrical pipe here and this shouldn't take that long.  Actually, I don't think it should take any time at all.  If the player is using the first 6 seconds to determine appropriate playback quality, why don't you start running those scripts when the page itself loads so that by the time the user clicks play, they already get the highest quality starting at second 0.  Don't wait until the user clicks play to start that.

 

If there is a resolution to this problem, or any devised workarounds to begin playing original quality video at the onset, please let me know.

Has this been resolved? I have screen casts that cannot be viewed until 12 seconds after playback has started because of how blurry the text in the video is.

Any word on this? We, too are getting the 6-12 second blurry display followed by the normal display when viewing videos. For short instructional videos, this is noticeable. Other video streaming products do not do this - video plays from the get-go. 

A hello from February of 2019 -- it hasn't been fixed yet. 

SMH, Microsoft...

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
46 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies
Stable version of Edge insider browser
HotCakeX in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
13 Replies
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
30 Replies