SOLVED
Home

Captions showing letters with accents as '?'

%3CLINGO-SUB%20id%3D%22lingo-sub-107924%22%20slang%3D%22en-US%22%3ECaptions%20showing%20letters%20with%20accents%20as%20'%3F'%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-107924%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20deploying%20a%20video%20to%20a%20dozen%20different%20countries%2C%20so%20I%20have%20a%20dozen%20different%20VTT%20files%20so%20viewers%20can%20select%20the%20language%20they%20want%20when%20they're%20watching%20the%20video.%20%26nbsp%3BHowever%2C%20all%20letters%20with%20accents%20are%20currently%20being%20replaced%20with%20a%20'%3F'%20in%20a%20diamond%20instead%20of%20the%20actual%20letter.%20%26nbsp%3BThis%20means%20that%20countries%20like%20Spain%2C%20Portugal%20and%20Sweden%20are%20having%20a%20lot%20of%20trouble%20reading%20the%20captions.%20%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20a%20way%20to%20fix%20this%20myself%3F%20Or%20is%20it%20a%20bug%20that%20needs%20a%20central%20fix%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-107924%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECaptions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EStream%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Esubtitles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ETranslation%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-324685%22%20slang%3D%22en-US%22%3ERe%3A%20Captions%20showing%20letters%20with%20accents%20as%20'%3F'%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-324685%22%20slang%3D%22en-US%22%3E%3CP%3EHey!%20I%20don't%20have%20Notepad%20%2B%2B%20and%20I%20am%20having%20the%20same%20problem.%20I%20am%20doing%20my%20VTT%20files%20with%20notepad%20windows.%20Is%20there%20another%20way%20to%20fix%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-130182%22%20slang%3D%22en-US%22%3ERe%3A%20Captions%20showing%20letters%20with%20accents%20as%20'%3F'%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-130182%22%20slang%3D%22en-US%22%3E%3CP%3EIt%20is%20important%20after%20translating%20the%20transcript%20file%20to%20save%20the%20file%20as%20UTF-8%20encoded.%26nbsp%3B%3C%2FP%3E%0A%3CP%3EI%20can%20confirm%20that%20special%20characters%20DO%20INDEED%20WORK%20as%20long%20as%20the%20file%20is%20encoded%20UTF-8%2C%20which%20can%20be%20done%20from%20the%20top%20menu%20of%20Notepad%2B%2B%2C%20by%20choosing%20Encoding%20%26gt%3B%20Convert%20to%20UTF-8!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-108119%22%20slang%3D%22en-US%22%3ERe%3A%20Captions%20showing%20letters%20with%20accents%20as%20'%3F'%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-108119%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%40Deleted%26nbsp%3Bit%20looks%20like%20this%20may%20be%20a%20character%20encoding%20issue.%20How%20are%20you%20generating%20the%20VTT%20files%3F%20Do%20you%20know%20if%20they%20are%20utf-8%20encoded%3F%20Can%20you%20uproved%20an%20example%20VTT%20file%20that%20displays%20the%20'%3F''s%20please%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-744622%22%20slang%3D%22en-US%22%3ERe%3A%20Captions%20showing%20letters%20with%20accents%20as%20'%3F'%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-744622%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F128753%22%20target%3D%22_blank%22%3E%40Mariel%20Vargas%3C%2FA%3E%26nbsp%3BI%20don't%20know%20if%20you%20solved%20this%20already%2C%20but%20you%20can%20save%20them%20as%20UTF-8%20encoded%20straight%20from%20normal%20Notepad.%20Just%20choose%20%22Save%20as%22%20and%20beneath%20the%20file%20type%2C%20you%20can%20choose%20which%20encoding%20you%20want%20to%20save%20it%20as.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20did%20this%20for%20all%20my%20subtitles%20and%20it%20works%20well!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable

I'm deploying a video to a dozen different countries, so I have a dozen different VTT files so viewers can select the language they want when they're watching the video.  However, all letters with accents are currently being replaced with a '?' in a diamond instead of the actual letter.  This means that countries like Spain, Portugal and Sweden are having a lot of trouble reading the captions.  

 

Is there a way to fix this myself? Or is it a bug that needs a central fix? 

4 Replies

Hi @Deleted it looks like this may be a character encoding issue. How are you generating the VTT files? Do you know if they are utf-8 encoded? Can you uproved an example VTT file that displays the '?''s please?

 

Thanks!

Solution

It is important after translating the transcript file to save the file as UTF-8 encoded. 

I can confirm that special characters DO INDEED WORK as long as the file is encoded UTF-8, which can be done from the top menu of Notepad++, by choosing Encoding > Convert to UTF-8!

Hey! I don't have Notepad ++ and I am having the same problem. I am doing my VTT files with notepad windows. Is there another way to fix this?

@Mariel Vargas I don't know if you solved this already, but you can save them as UTF-8 encoded straight from normal Notepad. Just choose "Save as" and beneath the file type, you can choose which encoding you want to save it as.

 

I did this for all my subtitles and it works well!