SOLVED
Home

Can't assign stream admins

%3CLINGO-SUB%20id%3D%22lingo-sub-298622%22%20slang%3D%22en-US%22%3ECan't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298622%22%20slang%3D%22en-US%22%3E%3CP%3EHi.%20We%20are%20just%20starting%20out%20with%20Microsoft%20Stream%20and%20I%20am%20unable%20to%20assign%20ordinary%20users%20as%20stream%20admins%20(which%20the%20documentation%20and%20instructional%20video%20indicates%20you%20can).%20It%20fails%20with%20the%20following%3A%3C%2FP%3E%3CP%3E%3CEM%3EThe%20settings%20were%20not%20updated%2C%20please%20try%20again.%20Role%20assignment%20failed%20for%20these%20users%3A%20John%20Smith.%20These%20users%20either%20have%20no%20service%20plans%20or%20their%20service%20plan%20does%20not%20allow%20them%20to%20be%20administrators.%3C%2FEM%3E%3C%2FP%3E%3CP%3EThe%20user%20in%20question%20has%20an%20Office%20365%20Enterprise%20E3%20license%20and%20I%20can%20see%20they%20have%20a%20license%20for%20'Stream%20for%20Office%20365'.%3C%2FP%3E%3CP%3EI%20would%20appreciate%20any%20assistance%20or%20pointers%20in%20the%20right%20direction.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-522623%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-522623%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20this%20same%20issue%20-%20receiving%20the%20message%20%22%3CSPAN%3ERole%20assignment%20failed%20for%20these%20users%3A%26nbsp%3B%20These%20users%20either%20have%20no%20service%20plans%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F114%22%20target%3D%22_blank%22%3E%40Marc%20Mroz%3C%2FA%3E%26nbsp%3BAny%20ideas%20what%20i%20need%20to%20do%20to%20correct%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-301200%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-301200%22%20slang%3D%22en-US%22%3E%3CP%3EYes%2C%20it%20is%20all%20good%20now.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%20for%20that.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-300996%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-300996%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20if%20we%20are%20still%20having%20this%20issue%20as%20of%202019-12-12%2014%3A00%20PST%2C%20what%20should%20we%20do%3F%20Because%20I%20have%20previous%20Stream%20admins%20and%20new%20Stream%20admins%20a%20wee%20bit%20upset%20at%20me%20as%20a%20Global%20Admin.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-300672%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-300672%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EThe%20hotfix%20for%20this%20went%20out%20to%20all%20data%20centers%20last%20night%20around%207pm%20PST.%20This%20should%20be%20fixed%20now.%20Sorry%20for%20the%20interruption.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-299240%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-299240%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%20for%20reporting%20this.%3C%2FP%3E%0A%3CP%3EWe've%20been%20able%20to%20identify%20the%20issue%20and%20are%20working%20to%20fix%20it.%20Our%20target%20is%20to%20have%20a%20hotfix%20out%20by%20end%20of%20day%20today%20which%20puts%20everything%20back%20working.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EUpdates%20on%20this%20issue%20will%20be%20posted%20here%3A%20%3CA%20href%3D%22http%3A%2F%2Faka.ms%2FStreamServiceUpdates%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttp%3A%2F%2Faka.ms%2FStreamServiceUpdates%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EFor%20more%20information%20on%20how%20we%20message%20on%20service%20updates%20you%20can%20read%20this%20help%20doc%3A%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CFONT%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fstream%2Fservice-updates%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fstream%2Fservice-updates%3C%2FA%3E%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-298976%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-298976%22%20slang%3D%22en-US%22%3EHas%20that%20user%20logged%20into%20Stream%20yet%3F%20Maybe%20need%20to%20have%20them%20do%20that%20before%20it%20will%20allow%20assignment%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-681348%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-681348%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20also%20experiencing%20this%20issue%20when%20attempting%20to%20add%20a%26nbsp%3Buser%20as%20an%20admin.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-682073%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20assign%20stream%20admins%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-682073%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F194153%22%20target%3D%22_blank%22%3E%40Pat%20Sullivan%3C%2FA%3E%26nbsp%3BHey%20Pat%2C%20here%20is%20what%20I%20had%20to%20do%20to%20fix%20it%20-%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EInstead%20of%20the%20O365%20admin%20page%2C%20navigate%20to%20your%20Microsoft%20Azure%20administration%20portal.%20Find%20the%20Azure%20Active%20Directory%20tab%20on%20the%20left%20and%20navigate%20to%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EYourCompanyName--%26gt%3BLicences%20-%20Overview--%26gt%3BProducts--%26gt%3BOffice365%20E3--%26gt%3BLicenced%20Groups.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENow%20select%20the%20licence%20group%20that%20applies%20to%20your%20users%20and%20check%20the%20%22Enabled%20Services%22.%20You%20need%20to%20make%20sure%20Stream%20is%20enabled%20(using%20the%20toggle%20button)%20for%20the%20group%20containing%20users%20that%20you%20want%20to%20enable.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20to%20make%20that%20change%20and%20then%20wait%20about%202%20hours%2C%20but%20after%20that%20the%20issue%20was%20resolved.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
NickHenderson
New Contributor

Hi. We are just starting out with Microsoft Stream and I am unable to assign ordinary users as stream admins (which the documentation and instructional video indicates you can). It fails with the following:

The settings were not updated, please try again. Role assignment failed for these users: John Smith. These users either have no service plans or their service plan does not allow them to be administrators.

The user in question has an Office 365 Enterprise E3 license and I can see they have a license for 'Stream for Office 365'.

I would appreciate any assistance or pointers in the right direction.

8 Replies
Has that user logged into Stream yet? Maybe need to have them do that before it will allow assignment?
Solution

Thank you for reporting this.

We've been able to identify the issue and are working to fix it. Our target is to have a hotfix out by end of day today which puts everything back working.

 

Updates on this issue will be posted here: http://aka.ms/StreamServiceUpdates

 

For more information on how we message on service updates you can read this help doc: 

https://docs.microsoft.com/stream/service-updates

The hotfix for this went out to all data centers last night around 7pm PST. This should be fixed now. Sorry for the interruption.

So if we are still having this issue as of 2019-12-12 14:00 PST, what should we do? Because I have previous Stream admins and new Stream admins a wee bit upset at me as a Global Admin. 

Yes, it is all good now.

 

Cheers for that.

I'm having this same issue - receiving the message "Role assignment failed for these users:  These users either have no service plans  @Marc Mroz Any ideas what i need to do to correct this?

I am also experiencing this issue when attempting to add a user as an admin.

@Pat Sullivan Hey Pat, here is what I had to do to fix it -

 

Instead of the O365 admin page, navigate to your Microsoft Azure administration portal. Find the Azure Active Directory tab on the left and navigate to:

 

YourCompanyName-->Licences - Overview-->Products-->Office365 E3-->Licenced Groups. 

 

Now select the licence group that applies to your users and check the "Enabled Services". You need to make sure Stream is enabled (using the toggle button) for the group containing users that you want to enable.

 

I had to make that change and then wait about 2 hours, but after that the issue was resolved. 

 

Related Conversations
How to Prevent Teams from Auto-Launch
chenrylee in Microsoft Teams on
28 Replies
Tabs and Dark Mode
cjc2112 in Discussions on
2 Replies
*Updated 9/3* Syncing in Microsoft Edge Preview Channels
Elliot Kirk in Articles on
205 Replies
Early preview of Microsoft Edge group policies
Sean Lyndersay in Discussions on
65 Replies